[Lldb-commits] [lldb] c874dd5 - [llvm][clang][NFC] updates inline licence info

2021-08-10 Thread Christopher Di Bella via lldb-commits
Author: Christopher Di Bella Date: 2021-08-11T02:48:53Z New Revision: c874dd53628db8170d4c5ba3878817abc385a695 URL: https://github.com/llvm/llvm-project/commit/c874dd53628db8170d4c5ba3878817abc385a695 DIFF: https://github.com/llvm/llvm-project/commit/c874dd53628db8170d4c5ba3878817abc385a695.dif

[Lldb-commits] [PATCH] D107869: [LLDB][GUI] Add Process Launch form

2021-08-10 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added inline comments. Comment at: lldb/source/Core/IOHandlerCursesGUI.cpp:3105 + +m_arguments_field = AddArgumentsField(); +m_enviroment_field = AddEnvironmentVariableListField(); We should fill in any arguments automatically into this field fro

[Lldb-commits] [PATCH] D107869: [LLDB][GUI] Add Process Launch form

2021-08-10 Thread Omar Emara via Phabricator via lldb-commits
OmarEmaraDev added a comment. Herald added a subscriber: JDevlieghere. This is not fully working yet, and I am still debugging it. But I thought I would push it for early feedback regardless. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107869/new

[Lldb-commits] [PATCH] D107869: [LLDB][GUI] Add Process Launch form

2021-08-10 Thread Omar Emara via Phabricator via lldb-commits
OmarEmaraDev created this revision. OmarEmaraDev added a reviewer: clayborg. Herald added a reviewer: teemperor. OmarEmaraDev requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This patch adds a process launch form. Additionally, a LazyBoolean

[Lldb-commits] [PATCH] D107704: [LLDB][NFC] Simplify IOHandler's getLine to avoid strange casts and redundant checks

2021-08-10 Thread Alf via Phabricator via lldb-commits
gAlfonso-bit marked an inline comment as done. gAlfonso-bit added a comment. Addressed all issues! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107704/new/ https://reviews.llvm.org/D107704 ___ lldb-commits mailing list lldb-commits@lists.llv

[Lldb-commits] [PATCH] D107521: [lldb/Plugins] Introduce Scripted Interface Factory

2021-08-10 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. This is a good start, but it seems like there's still a lot of boilerplate once you get to the python side that could be trimmed down. For instance, ScriptedProcessPythonInterface::GetThreadWithID is almost entirely generic. The only things that make it specific to thi

[Lldb-commits] [PATCH] D107659: [nfc] [lldb] Assertions for D106270 - [DWARF5] Fix offset check when using .debug_names

2021-08-10 Thread Jan Kratochvil via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGf3932b9a0b0b: [nfc] [lldb] Assertions for D106270 - [DWARF5] Fix offset check when using . (authored by jankratochvil). Repository: rG LLVM Github

[Lldb-commits] [PATCH] D107521: [lldb/Plugins] Introduce Scripted Interface Factory

2021-08-10 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: lldb/bindings/python/python-wrapper.swig:291 - PyErr_Cleaner py_err_cleaner(true); Unrelated whitespace change? Comment at: lldb/include/lldb/Interpreter/ScriptedInterface.h:25 + virtual S

[Lldb-commits] [lldb] f3932b9 - [nfc] [lldb] Assertions for D106270 - [DWARF5] Fix offset check when using .debug_names

2021-08-10 Thread Jan Kratochvil via lldb-commits
Author: Jan Kratochvil Date: 2021-08-10T20:43:24+02:00 New Revision: f3932b9a0b0b7787ccd3572bad134acc4146acaa URL: https://github.com/llvm/llvm-project/commit/f3932b9a0b0b7787ccd3572bad134acc4146acaa DIFF: https://github.com/llvm/llvm-project/commit/f3932b9a0b0b7787ccd3572bad134acc4146acaa.diff

[Lldb-commits] [PATCH] D107840: [lldb] [gdb-server] Implement the vFile:fstat packet

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny created this revision. mgorny added reviewers: labath, JDevlieghere, jasonmolenda, krytarowski, emaste. mgorny requested review of this revision. https://reviews.llvm.org/D107840 Files: lldb/include/lldb/Utility/StringExtractorGDBRemote.h lldb/source/Plugins/Process/gdb-remote/GDBRemot

[Lldb-commits] [PATCH] D107704: [LLDB][NFC] Simplify IOHandler's getLine to avoid strange casts and redundant checks

2021-08-10 Thread Alf via Phabricator via lldb-commits
gAlfonso-bit updated this revision to Diff 365497. gAlfonso-bit added a comment. Remove goto CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107704/new/ https://reviews.llvm.org/D107704 Files: lldb/include/lldb/Core/IOHandler.h lldb/source/Core/IOHandler.cpp Index: lldb/source/Core/

[Lldb-commits] [PATCH] D107674: [tests] [trace] Add a more comprehensive test for `thread trace export ctf` command

2021-08-10 Thread Jakob Johnson via Phabricator via lldb-commits
jj10306 updated this revision to Diff 365477. jj10306 added a comment. lint + comments CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107674/new/ https://reviews.llvm.org/D107674 Files: lldb/docs/htr.rst lldb/source/Plugins/TraceExporter/common/TraceHTR.cpp lldb/source/Plugins/Tra

[Lldb-commits] [lldb] 2db8461 - [lldb][NFC] Fix inversed documentation of Process::GetID/SetID

2021-08-10 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-08-10T16:15:57+02:00 New Revision: 2db8461a9492cb64046a085f35048b9c4e45bfc2 URL: https://github.com/llvm/llvm-project/commit/2db8461a9492cb64046a085f35048b9c4e45bfc2 DIFF: https://github.com/llvm/llvm-project/commit/2db8461a9492cb64046a085f35048b9c4e45bfc2.dif

[Lldb-commits] [lldb] 9900af5 - [lldb][NFC] Add a FIXME for NameSearchContext::AddFunDecl's missing addDecl

2021-08-10 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-08-10T16:14:27+02:00 New Revision: 9900af52f6b186a260d83321791177728fb369c5 URL: https://github.com/llvm/llvm-project/commit/9900af52f6b186a260d83321791177728fb369c5 DIFF: https://github.com/llvm/llvm-project/commit/9900af52f6b186a260d83321791177728fb369c5.dif

[Lldb-commits] [PATCH] D107778: [lldb] Add a test for user-defined objc_copyRealizedClassList_nolock

2021-08-10 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG57bf5c86591a: [lldb] Add a test for user-defined objc_copyRealizedClassList_nolock (authored by teemperor). Herald added a subscriber: lldb-commits.

[Lldb-commits] [lldb] 57bf5c8 - [lldb] Add a test for user-defined objc_copyRealizedClassList_nolock

2021-08-10 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-08-10T14:54:42+02:00 New Revision: 57bf5c86591a1ff664f99d47e9f6a03a280f7a02 URL: https://github.com/llvm/llvm-project/commit/57bf5c86591a1ff664f99d47e9f6a03a280f7a02 DIFF: https://github.com/llvm/llvm-project/commit/57bf5c86591a1ff664f99d47e9f6a03a280f7a02.dif

[Lldb-commits] [PATCH] D107821: [lldb] [gdb-server] Add tests for more vFile packets

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny created this revision. mgorny added reviewers: krytarowski, labath, emaste, jasonmolenda, JDevlieghere. mgorny requested review of this revision. https://reviews.llvm.org/D107821 Files: lldb/test/API/tools/lldb-server/TestGdbRemotePlatformFile.py Index: lldb/test/API/tools/lldb-server/

[Lldb-commits] [lldb] 4994890 - [lldb] Add a test for potentially conflicting names for the Objective-C class update utility expression

2021-08-10 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2021-08-10T14:42:06+02:00 New Revision: 499489064b7a4519f7c566e76077821ae1f3446d URL: https://github.com/llvm/llvm-project/commit/499489064b7a4519f7c566e76077821ae1f3446d DIFF: https://github.com/llvm/llvm-project/commit/499489064b7a4519f7c566e76077821ae1f3446d.dif

[Lldb-commits] [PATCH] D107776: [lldb] Add a test for potentially conflicting names for the Objective-C class update utility expression

2021-08-10 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG499489064b7a: [lldb] Add a test for potentially conflicting names for the Objective-C class… (authored by teemperor). Herald added a project: LLDB. H

[Lldb-commits] [PATCH] D103626: [lldb][AArch64] Remove non address bits from memory read arguments

2021-08-10 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett updated this revision to Diff 365436. DavidSpickett added a comment. Rebase Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D103626/new/ https://reviews.llvm.org/D103626 Files: lldb/source/Commands/CommandObjectMemory.cpp lldb/test/

[Lldb-commits] [PATCH] D102757: [lldb] Remove non address bits when looking up memory regions

2021-08-10 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett updated this revision to Diff 365435. DavidSpickett added a comment. Rebase Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D102757/new/ https://reviews.llvm.org/D102757 Files: lldb/include/lldb/Target/Process.h lldb/source/Plugins/

[Lldb-commits] [PATCH] D101361: [LLDB] Support AArch64/Linux watchpoint on tagged addresses

2021-08-10 Thread Andrew Turner via Phabricator via lldb-commits
andrew added a comment. FreeBSD doesn't currently support TBI. I'm trying to decide if it will be enabled everywhere, or just when needed (e.g. for HWASAN) due to how it interacts with PAC. I have a patch in review in the FreeBSD phabricator to add PAC support. Repository: rG LLVM Github Mo

[Lldb-commits] [PATCH] D107811: [lldb] [gdb-remote] Add fallbacks for vFile:mode and vFile:exists

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny created this revision. mgorny added reviewers: krytarowski, emaste, labath, jasonmolenda, JDevlieghere. mgorny requested review of this revision. Add a GDB-compatible fallback to vFile:fstat for vFile:mode, and to vFile:open for vFile:exists. https://reviews.llvm.org/D107811 Files: lld

[Lldb-commits] [PATCH] D107809: [lldb] Add new commands and tests for getting file perms & exists

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 365416. mgorny added a comment. Fix colliding test name. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107809/new/ https://reviews.llvm.org/D107809 Files: lldb/source/Commands/CommandObjectPlatform.cpp lldb/source/Plugins/Process/gdb-remote/GDBR

[Lldb-commits] [PATCH] D107780: [lldb] [gdb-remote] Implement fallback to vFile:stat for GetFileSize()

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 365414. mgorny added a comment. Add a helper `Stat` method to take care of opening and closing the file. Add a cache variable for whether `vFile:size` is supported. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107780/new/ https://reviews.llvm.org/D

[Lldb-commits] [PATCH] D107809: [lldb] Add new commands and tests for getting file perms & exists

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny created this revision. mgorny added reviewers: labath, emaste, krytarowski, jasonmolenda, JDevlieghere. mgorny requested review of this revision. Add two new commands 'platform get-file-permissions' and 'platform file-exists' for the respective bits of LLDB protocol. Add tests for them. F

[Lldb-commits] [PATCH] D107780: [lldb] [gdb-remote] Implement fallback to vFile:stat for GetFileSize()

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 365408. mgorny added a comment. Fix integer-type related warnings. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107780/new/ https://reviews.llvm.org/D107780 Files: lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunication.h lldb/source/Plug

[Lldb-commits] [PATCH] D107665: [lldb] [Commands] Fix reporting errors in 'platform file read/write'

2021-08-10 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 365407. mgorny added a comment. Fix integer type mismatches. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107665/new/ https://reviews.llvm.org/D107665 Files: lldb/source/Commands/CommandObjectPlatform.cpp lldb/test/API/functionalities/gdb_remot