labath accepted this revision.
labath added inline comments.
This revision is now accepted and ready to land.
Comment at: source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp:81
+info.Age = read32be(&pdb_info->PDB70.Age);
+return UUID::fromOptionalData((uint8_t *
aadsm marked an inline comment as done.
aadsm added inline comments.
Comment at: lldb/unittests/Utility/TimerTest.cpp:100-101
+ << "String: " << ss.GetData();
+ EXPECT_GT(total1 - child1, seconds1 - 0.001);
+ EXPECT_LT(total1 - child1, seconds1 + 0.001);
+ EXPECT_EQ(1, co
davide added inline comments.
Comment at: lldb/unittests/Utility/TimerTest.cpp:100-101
+ << "String: " << ss.GetData();
+ EXPECT_GT(total1 - child1, seconds1 - 0.001);
+ EXPECT_LT(total1 - child1, seconds1 + 0.001);
+ EXPECT_EQ(1, count1);
this seems ...
aadsm updated this revision to Diff 197049.
aadsm added a comment.
Move struct to anonymous namespace
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D61235/new/
https://reviews.llvm.org/D61235
Files:
lldb/include/lldb/Utility/Timer.h
lldb/source
aadsm created this revision.
Herald added subscribers: lldb-commits, jfb, erik.pilkington, aprantl.
Herald added a project: LLDB.
aadsm abandoned this revision.
The `log timer dump` is showing the time of the function itself minus any
function that is called from this one that also happens to be
aadsm updated this revision to Diff 197048.
aadsm added a comment.
Fix and add unit test
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D61235/new/
https://reviews.llvm.org/D61235
Files:
lldb/include/lldb/Utility/Timer.h
lldb/source/Utility/Time
davide accepted this revision.
davide added a comment.
This revision is now accepted and ready to land.
LGTM
Repository:
rLLDB LLDB
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D61244/new/
https://reviews.llvm.org/D61244
___
lldb-commits
teemperor created this revision.
teemperor added a reviewer: labath.
Herald added a project: LLDB.
Herald added a subscriber: lldb-commits.
teemperor edited the summary of this revision.
These tests are not failing for me on (Arch) Linux, so I would suggest that we
re-enable them. See also http:/
teemperor added a comment.
Yeah, I'm also just like 60% confident that this more readable/expressive.
`anyOf` sounds good to me. Will update the patch in case this gets community
approval.
Repository:
rLLDB LLDB
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D61231/new/
https://revie
JDevlieghere added a comment.
I'm on the fence on this one. I think the `==` pattern attracts more attention
to the fact that we are comparing strings. However, I also see the benefit,
like in the example, where even a temporary variable wouldn't help much.
Regarding the name, how would you fee
teemperor added a comment.
Could you provide a test? There are some existing tests for Timer in
`lldb/unittests/Utility/TimerTest.cpp` which you can extend. You can
run/compile these tests via `LIT_FILTER="TimerTest" make check-lldb`.
(I also believe this patch breaks `TimerTest` as it checks t
teemperor created this revision.
teemperor added a reviewer: aprantl.
Herald added subscribers: lldb-commits, abidh.
Herald added a project: LLDB.
`GetSystemIncludeDirectories` is currently only implemented for Linux where it
returns `/usr/include` with a potential sysroot
as a prefix. This patch
12 matches
Mail list logo