Thanks for vigilance. I added a couple more tests in r299729.
On Thu, Apr 6, 2017 at 4:06 PM, Jim Ingham via Phabricator <
revi...@reviews.llvm.org> wrote:
> jingham added a comment.
>
> I'm sorry, I don't have time actually review the code here for
> correctness... But can you make sure that th
Author: eugene
Date: Thu Apr 6 18:12:43 2017
New Revision: 299729
URL: http://llvm.org/viewvc/llvm-project?rev=299729&view=rev
Log:
Add more tests for ExtractContextAndIdentifier
Modified:
lldb/trunk/unittests/Language/CPlusPlus/CPlusPlusLanguageTest.cpp
Modified: lldb/trunk/unittests/Langu
jingham added a comment.
I'm sorry, I don't have time actually review the code here for correctness...
But can you make sure that this also rejects a two or three field selector, not
just "selector:" but "selector:otherField:"? That seems sufficiently different
that you might get the one : bu
Author: eugene
Date: Thu Apr 6 17:36:02 2017
New Revision: 299721
URL: http://llvm.org/viewvc/llvm-project?rev=299721&view=rev
Log:
New C++ function name parsing logic (Resubmit)
Current implementation of CPlusPlusLanguage::MethodName::Parse() doesn't
get anywhere close to covering full extent o
Agreed. Before I clang-formatted it, it looked fine, because each
definition was on a single line. But clang-format made them 3 lines each.
So yea, we should definitely merge them. I was copy/pasting the output
from IWYU, which is why it looks this way. Thanks for bringing it up
On Thu, Apr 6,
tberghammer added subscribers: lldb-commits, tberghammer.
tberghammer added inline comments.
/lldb/trunk/include/lldb/Core/Address.h:21-50 I think we should try to merge
these namespace definitions as in my view the current syntax makes the top of
the file very noisy. What do you think?
Users:
Author: zturner
Date: Thu Apr 6 17:18:59 2017
New Revision: 299719
URL: http://llvm.org/viewvc/llvm-project?rev=299719&view=rev
Log:
Try to fix FreeBSD build after IWYU changes.
Modified:
lldb/trunk/source/Plugins/Process/FreeBSD/ProcessFreeBSD.cpp
Modified: lldb/trunk/source/Plugins/Proces
Author: zturner
Date: Thu Apr 6 16:57:39 2017
New Revision: 299718
URL: http://llvm.org/viewvc/llvm-project?rev=299718&view=rev
Log:
Fix build failure in unit test.
Modified:
lldb/trunk/unittests/Core/BroadcasterTest.cpp
Modified: lldb/trunk/unittests/Core/BroadcasterTest.cpp
URL:
http://l
Author: zturner
Date: Thu Apr 6 15:51:22 2017
New Revision: 299705
URL: http://llvm.org/viewvc/llvm-project?rev=299705&view=rev
Log:
Try to fix FreeBSD build after iwyu changes.
Modified:
lldb/trunk/source/Host/freebsd/HostInfoFreeBSD.cpp
Modified: lldb/trunk/source/Host/freebsd/HostInfoFre
krytarowski created this revision.
krytarowski added a project: LLDB.
This replaces old code in Host::GetEnvironment for NetBSD
with the version from Linux. This makes parsing environment
variables correctly. It also fixes programs that depend on the
variables like curses(3) applications.
Long te
Author: tberghammer
Date: Thu Apr 6 13:15:43 2017
New Revision: 299677
URL: http://llvm.org/viewvc/llvm-project?rev=299677&view=rev
Log:
XFAIL TestDataFormatterLibcxxVBool on Linux & Android
The skipping logic for the test have been fixed recently but the test is
very flakey on the buildbot.
Mo
Author: zturner
Date: Thu Apr 6 13:12:24 2017
New Revision: 299676
URL: http://llvm.org/viewvc/llvm-project?rev=299676&view=rev
Log:
iwyu fixes on lldbUtility.
This patch makes adjustments to header file includes in
lldbUtility based on recommendations by the iwyu tool
(include-what-you-use). T
beanz added a comment.
I will fix up the naming conventions. Switching back and forth between LLVM and
LLDB conventions has done a number on my brain.
The test cases only abort on the child process side of the fork calls. This
results in printing a stack trace, but it also will get captured as
jingham added a comment.
On the small points side: for lldb code we use lower-case, _ separated names
for local variables, the point being that it allow you to tell at a glance
what's a local and what's an ivar. Looks like you use a mixture of the two
styles? exit_status, result, etc. alongsi
beanz added a reviewer: jingham.
beanz added a comment.
Adding Jim as a reviewer.
Jim, with the added comment about debugserver being Darwin-only, are you happy
with this patch?
https://reviews.llvm.org/D31357
___
lldb-commits mailing list
lldb-co
beanz updated this revision to Diff 94374.
beanz added a comment.
Some cleanup to the test case:
- Auto-select a port, which will make this more reliable
- Open listening sockets before the fork() so that the sockets are ready for
connection (this avoids a race)
- Put test logic into reusable fu
16 matches
Mail list logo