tfiala marked an inline comment as done.
Comment at: source/Core/Disassembler.cpp:292-294
@@ -291,2 +291,5 @@
decl_line.line = func_decl_line;
+ // TODO do we care about column on these entries? If so, we need to
+ // plumb that through GetStartLineSourceInfo.
+
Author: jingham
Date: Tue Sep 20 20:21:19 2016
New Revision: 282043
URL: http://llvm.org/viewvc/llvm-project?rev=282043&view=rev
Log:
Adds tests for breakpoint names, and a FindBreakpointsByName.
Also if you set a breakpoint with an invalid name, we'll
refuse to set the breakpoint rather than sil
This revision was automatically updated to reflect the committed changes.
Closed by commit rL282041: Fix Clang initialization and Clang-tidy
modernize-use-nullptr warnings in… (authored by eugenezelenko).
Changed prior to commit:
https://reviews.llvm.org/D24694?vs=71718&id=72002#toc
Repository
Author: eugenezelenko
Date: Tue Sep 20 19:59:22 2016
New Revision: 282041
URL: http://llvm.org/viewvc/llvm-project?rev=282041&view=rev
Log:
Fix Clang initialization and Clang-tidy modernize-use-nullptr warnings in
source/Plugins/Process/Utility.
Differential revision: https://reviews.llvm.org/D2
tfiala updated this revision to Diff 71996.
tfiala added a comment.
This change addresses Jim's and Greg's suggestions.
- stop-show-column now is a quad-state:
- ansi-or-caret (default): Shows ANSI if color is enabled; otherwise, uses
the text-based caret.
- ansi-only: ANSI highlighting is
Author: jingham
Date: Tue Sep 20 17:54:49 2016
New Revision: 282036
URL: http://llvm.org/viewvc/llvm-project?rev=282036&view=rev
Log:
Add some more tests for breakpoint serialization.
Serialize breakpoint names & the hardware_requested attributes.
Also added a few missing affordances to SBBreakpo
wallace updated this revision to Diff 71995.
wallace added a comment.
rebase
https://reviews.llvm.org/D24284
Files:
source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp
source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.h
Index: source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.h
=
I rebased it
2016-09-20 15:44 GMT-07:00 walter erquinigo :
> wallace updated this revision to Diff 71995.
> wallace added a comment.
>
> rebase
>
>
> https://reviews.llvm.org/D24284
>
> Files:
> source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp
> source/Plugins/ObjectFile/PECOFF/ObjectFil
Author: kamil
Date: Tue Sep 20 17:26:29 2016
New Revision: 282032
URL: http://llvm.org/viewvc/llvm-project?rev=282032&view=rev
Log:
Unbreak the NetBSD build after recent changes
Similar to r281922 "Try to fix freebsd and android builds."
Replace .AppendArgument(cstr) with .AppendArgument(llvm::S
Author: zturner
Date: Tue Sep 20 17:15:07 2016
New Revision: 282029
URL: http://llvm.org/viewvc/llvm-project?rev=282029&view=rev
Log:
Enable clang attributes when using clang-cl.
Modified:
lldb/trunk/include/lldb/lldb-defines.h
Modified: lldb/trunk/include/lldb/lldb-defines.h
URL:
http://ll
Just a heads up, I put the wrong differential revision in the commit
message. Oh well. I submitted the other patch, not this one.
Can you rebase this patch on top of the triple / os patch? It doesn't
apply cleanly for me.
On Tue, Sep 20, 2016 at 1:53 PM Zachary Turner wrote:
> This revision
This revision was automatically updated to reflect the committed changes.
Closed by commit rL282013: [PECOFF] Use the COFF subsystem field when
determining the Triple. (authored by zturner).
Changed prior to commit:
https://reviews.llvm.org/D24284?vs=71855&id=71984#toc
Repository:
rL LLVM
h
Author: zturner
Date: Tue Sep 20 15:44:50 2016
New Revision: 282013
URL: http://llvm.org/viewvc/llvm-project?rev=282013&view=rev
Log:
[PECOFF] Use the COFF subsystem field when determining the Triple.
Patch by walter erquinigo
Differential revision: https://reviews.llvm.org/D24284
Modified:
Eugene.Zelenko added inline comments.
Comment at: source/Plugins/Process/Utility/RegisterInfos_x86_64.h:12
@@ -12,1 +11,3 @@
+#include
+#include
labath wrote:
> It's not a "C" include, if it's cstddef now. :) If you could you also move
> the headers to the en
labath accepted this revision.
Comment at: source/Plugins/Process/Utility/RegisterInfos_x86_64.h:12
@@ -12,1 +11,3 @@
+#include
+#include
It's not a "C" include, if it's cstddef now. :) If you could you also move the
headers to the end of the include list as
labath added inline comments.
Comment at:
source/Plugins/Process/Linux/NativeRegisterContextLinux_x86_64.cpp:805
@@ -827,2 +804,3 @@
+ if (m_xstate_type == XStateType::Invalid) {
if (const_cast(this)->ReadFPR().Fail())
return false;
Then I think we s
wallace added a comment.
I was using this patch as well https://reviews.llvm.org/D24530, which might be
the reason why it fails on your side. I'll double check, but I'm pretty sure
it's just that
https://reviews.llvm.org/D24284
___
lldb-commits ma
labath added inline comments.
Comment at: cmake/modules/AddLLDB.cmake:75
@@ -74,1 +74,3 @@
if (PARAM_SHARED)
+set(out_dir lib${LLVM_LIBDIR_SUFFIX})
+if(${name} STREQUAL "liblldb" AND LLDB_BUILD_FRAMEWORK)
I am wondering whether this wouldn't
zturner requested changes to this revision.
zturner added a comment.
This revision now requires changes to proceed.
When I run ninja check-lldb with this patch, every single test crashes. It's
crashing at ObjectFilePECOFF.cpp:583, which does this:
const char *symbol_name_cstr =
symtab_d
krytarowski added a subscriber: krytarowski.
krytarowski added a comment.
There are no debug registers supported right now on NetBSD and I was forced to
duplicate the code. It's on TODO and I prefer to streamline the kernel.
Repository:
rL LLVM
https://reviews.llvm.org/D24694
Author: enrico
Date: Tue Sep 20 13:26:30 2016
New Revision: 281993
URL: http://llvm.org/viewvc/llvm-project?rev=281993&view=rev
Log:
Make it so that one can register prefix matches as well as identical matches as
extra cases for NSDictionary data formatting
Modified:
lldb/trunk/source/Plugi
beanz added a comment.
I've tested this on OS X with and without `LLDB_BUILD_FRAMEWORK` set, and
check-lldb works in both cases. I would expect it to also work on Linux and
Windows. The change should be NFC if `LLDB_BUILD_FRAMEWORK=Off`.
Comment at: scripts/Python/finishSwigPy
valentinagiusti updated this revision to Diff 71949.
valentinagiusti added a comment.
Removed unnecessary header, corrected switch-case.
https://reviews.llvm.org/D24764
Files:
source/Plugins/Process/Linux/NativeRegisterContextLinux_x86_64.cpp
source/Plugins/Process/Linux/NativeRegisterConte
valentinagiusti marked an inline comment as done.
valentinagiusti added a comment.
Thanks for your review! Please find my answers inline.
Comment at:
source/Plugins/Process/Linux/NativeRegisterContextLinux_x86_64.cpp:807
@@ -827,2 +806,3 @@
+ if (m_xstate_type == XStateType::I
labath requested changes to this revision.
labath added a comment.
This revision now requires changes to proceed.
I am going to assume you know more about the exact details of the intel cpu's
than me, so I am not going comment on the technical details. The code seems
cleaner, so this looks like
zturner added inline comments.
Comment at:
source/Plugins/Process/Linux/NativeRegisterContextLinux_x86_64.cpp:818
@@ +817,3 @@
+ return true;
+ case RegSet::mpx: // Check if CPU has MPX and if there is kernel support, by
+// reading in the XCR0 area of X
ki.stfu added a comment.
yes
Repository:
rL LLVM
https://reviews.llvm.org/D24711
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
27 matches
Mail list logo