Re: ARC stable backport request

2016-01-25 Thread Jiri Slaby
On 12/01/2015, 09:30 AM, Vineet Gupta wrote: > Hi, > > Please add upstream commit 30b9dbee895ff ("ARC: Fix silly typo in MAINTAINERS > file") to stable releases. > > This depends on 9acdc911b55569145 ("MAINTAINERS: Add public mailing list for > ARC") > which was already marked for stable inclusi

[PATCH 3/4] exit_thread: accept a task parameter to be exited

2016-03-27 Thread Jiri Slaby
We need to call exit_thread from copy_process in a fail path. So make it accept task_struct as a parameter. Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan Kokshaysky Cc: Matt Turner Cc: Vineet Gupta Cc: Russell King Cc: Catalin Marinas Cc: Will Deacon Cc: Haavard Skinnemoen Cc

Re: [PATCH 3/4] exit_thread: accept a task parameter to be exited

2016-03-27 Thread Jiri Slaby
On 03/24/2016, 02:03 PM, Peter Zijlstra wrote: > On Thu, Mar 24, 2016 at 01:58:13PM +0100, Jiri Slaby wrote: >> void >> -exit_thread(void) >> +exit_thread(struct task_struct *me) >> { >> } > > task_struct arguments are called: tsk, task, p > 

[PATCH v2 2/4] exit_thread: remove empty bodies

2016-03-31 Thread Jiri Slaby
Define HAVE_EXIT_THREAD for archs which want to do something in exit_thread. For others, let's define exit_thread as an empty inline. This is a cleanup before we change the prototype of exit_thread to accept a task parameter. Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan Koksh

Re: ARC stable backport request

2016-05-30 Thread Jiri Slaby
On 05/25/2016, 01:43 PM, Vineet Gupta wrote: > Can we please backport a6416f57ce57fb390b "ARC: use ASL assembler mnemonic". > Newer binutils don't like ASL instruction and fail to build kernels prior to > v4.4 > which added this fix. Added to 3.12. Thanks. -- js suse labs

Re: ARC stable backport request

2016-08-02 Thread Jiri Slaby
13:31 2015 +0530 ARC: use ASL assembler mnemonic commit a6416f57ce57fb390b6ee30b12c01c29032a26af upstream. ARCompact and ARCv2 only have ASL, while binutils used to support LSL as a alias mnemonic. Newer binutils (upstream) don't want to do that so replace it. Signed-off-by:

[patch added to 3.12-stable] ARC: uaccess: get_user to zero out dest in cause of fault

2016-09-29 Thread Jiri Slaby
valds Cc: linux-snps-arc@lists.infradead.org Cc: linux-ker...@vger.kernel.org Signed-off-by: Vineet Gupta Signed-off-by: Al Viro Signed-off-by: Jiri Slaby --- arch/arc/include/asm/uaccess.h | 11 +-- 1 file changed, 9 insertions(+), 2 deletions(-) diff --git a/arch/arc/include/asm/uaccess

[PATCH 3.12 100/119] ARC: uaccess: get_user to zero out dest in cause of fault

2016-09-29 Thread Jiri Slaby
rc@lists.infradead.org Cc: linux-ker...@vger.kernel.org Signed-off-by: Vineet Gupta Signed-off-by: Al Viro Signed-off-by: Jiri Slaby --- arch/arc/include/asm/uaccess.h | 11 +-- 1 file changed, 9 insertions(+), 2 deletions(-) diff --git a/arch/arc/include/asm/uaccess.h b/arch/arc/in

[patch added to 3.12-stable] ARC: [arcompact] brown paper bag bug in unaligned access delay slot fixup

2017-02-16 Thread Jiri Slaby
delay slot") Cc: linux-ker...@vger.kernel.org Cc: linux-snps-arc@lists.infradead.org Signed-off-by: Vineet Gupta Signed-off-by: Linus Torvalds Signed-off-by: Jiri Slaby --- arch/arc/kernel/unaligned.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/arc/kernel/una

[PATCH 1/3] futex: remove duplicated code

2017-03-03 Thread Jiri Slaby
that s390 removed access_ok check in d12a29703 ("s390/uaccess: remove pointless access_ok() checks") as access_ok there returns true. We introduce it back to the helper for the sake of simplicity (it gets optimized away anyway). Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan

[PATCH 3.12 038/113] ARC: [arcompact] brown paper bag bug in unaligned access delay slot fixup

2017-03-06 Thread Jiri Slaby
linux-ker...@vger.kernel.org Cc: linux-snps-arc@lists.infradead.org Signed-off-by: Vineet Gupta Signed-off-by: Linus Torvalds Signed-off-by: Jiri Slaby --- arch/arc/kernel/unaligned.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/arc/kernel/unaligned.c b/arch/

[PATCH 1/1] futex: remove duplicated code

2017-05-15 Thread Jiri Slaby
that s390 removed access_ok check in d12a29703 ("s390/uaccess: remove pointless access_ok() checks") as access_ok there returns true. We introduce it back to the helper for the sake of simplicity (it gets optimized away anyway). Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan

Re: [PATCH 1/1] futex: remove duplicated code

2017-05-17 Thread Jiri Slaby
On 05/15/2017, 03:16 PM, Will Deacon wrote: > Whilst I think this is a good idea, the code in question actually results > in undefined behaviour per the C spec and is reported by UBSAN. Hi, yes, I know -- this patch was the 1st from the series of 3 which I sent a long time ago to fix that up too.

[PATCH 1/1] futex: remove duplicated code and fix UB

2017-06-21 Thread Jiri Slaby
k check in d12a29703 ("s390/uaccess: remove pointless access_ok() checks") as access_ok there returns true. We introduce it back to the helper for the sake of simplicity (it gets optimized away anyway). Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan Kokshaysky Cc: Matt Turn

Re: [PATCH 1/1] futex: remove duplicated code and fix UB

2017-06-26 Thread Jiri Slaby
On 06/23/2017, 09:51 AM, Thomas Gleixner wrote: > On Wed, 21 Jun 2017, Jiri Slaby wrote: >> diff --git a/arch/arm64/include/asm/futex.h b/arch/arm64/include/asm/futex.h >> index f32b42e8725d..5bb2fd4674e7 100644 >> --- a/arch/arm64/include/asm/futex.h >> +++ b/arc

[PATCH v2 1/1] futex: remove duplicated code and fix UB

2017-08-24 Thread Jiri Slaby
y (it gets optimized away anyway). [v2] - check also for negative values - wait for Will's fix to be in upstream Signed-off-by: Jiri Slaby Cc: Richard Henderson Cc: Ivan Kokshaysky Cc: Matt Turner Cc: Vineet Gupta Acked-by: Russell King Cc: Catalin Marinas Cc: Will Deacon Reviewed-by:

Re: [PATCH 4.9 27/33] futex: Remove duplicated code and fix undefined behaviour

2018-05-18 Thread Jiri Slaby
On 05/18/2018, 10:16 AM, Greg Kroah-Hartman wrote: > 4.9-stable review patch. If anyone has any objections, please let me know. > > -- > > From: Jiri Slaby > > commit 30d6e0a4190d37740e9447e4e4815f06992dd8c3 upstream. ... > --- a/kernel/futex.

Re: [RESEND PATCH v2 9/9] ath5k: Constify ioreadX() iomem argument (as in generic implementation)

2020-02-20 Thread Jiri Slaby
On 19. 02. 20, 18:50, Krzysztof Kozlowski wrote: > The ioreadX() helpers have inconsistent interface. On some architectures > void *__iomem address argument is a pointer to const, on some not. > > Implementations of ioreadX() do not modify the memory under the address > so they can be converted t

Re: [PATCH 6/7] drivers: Repace get_task_comm() with %pTN

2024-12-12 Thread Jiri Slaby
Cc: Jani Nikula Cc: Rodrigo Vivi Cc: Joonas Lahtinen Cc: Tvrtko Ursulin Cc: David Airlie Cc: Simona Vetter Cc: Karol Herbst Cc: Lyude Paul Cc: Danilo Krummrich Cc: Greg Kroah-Hartman Cc: Jiri Slaby --- drivers/accel/habanalabs/common/context.c | 5 ++--- .../accel/habanal

[PATCH v2 13/57] irqdomain: arc: Switch to irq_domain_create_linear()

2025-04-04 Thread Jiri Slaby (SUSE)
the users can likely use dev->fwnode directly instead of indirect of_fwnode_handle(dev->of_node). But dev->fwnode is not guaranteed to be set for all, so this has to be investigated on case to case basis (by people who can actually test with the HW). Signed-off-by: Jiri Slaby (SUSE) C