Re: [PATCH 17/67] microblaze: rename dma_direct to dma_microblaze

2018-01-04 Thread Christoph Hellwig
On Fri, Dec 29, 2017 at 09:11:56PM +1100, Julian Calaby wrote: > Hi Christoph, > > On Fri, Dec 29, 2017 at 7:18 PM, Christoph Hellwig wrote: > > This frees the dma_direct_* namespace for a generic implementation. > > Don't you mean "dma_nommu" not "dma_microblaze" in the subject line? Yes, than

Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_

2018-01-04 Thread Christoph Hellwig
On Wed, Jan 03, 2018 at 07:19:46PM +1100, Julian Calaby wrote: > If this is indeed a linear mapping, can we just remove this and > replace it with the new "generic" mapping being introduced by this > patchset? That is the long-term plan. But as the powerpc one includes support for non-coherent DM

Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_

2018-01-04 Thread Christoph Hellwig
On Tue, Jan 02, 2018 at 08:45:30PM +1100, Michael Ellerman wrote: > Christoph Hellwig writes: > > > We want to use the dma_direct_ namespace for a generic implementation, > > so rename powerpc to the second best choice: dma_nommu_. > > I'm not a fan of "nommu". Some of the users of direct ops *a

Re: [PATCH 27/67] dma-direct: add dma address sanity checks

2018-01-04 Thread Christoph Hellwig
On Fri, Dec 29, 2017 at 03:12:25PM +0100, Geert Uytterhoeven wrote: > > +check_addr(struct device *dev, dma_addr_t dma_addr, size_t size, > > + const char *caller) > > +{ > > + if (unlikely(dev && !dma_capable(dev, dma_addr, size))) { > > + if (*dev->dma_mask >= DM

Re: [PATCH 02/67] alpha: mark jensen as broken

2018-01-04 Thread Christoph Hellwig
On Tue, Jan 02, 2018 at 11:36:00AM +0100, Geert Uytterhoeven wrote: > Hi Christoph, > > On Fri, Dec 29, 2017 at 9:18 AM, Christoph Hellwig wrote: > > CONFIG_ALPHA_JENSEN has failed to compile since commit aca05038 > > ("alpha/dma: use common noop dma ops"), so mark it as broken. > > unknown revi

Re: [PATCH 30/67] dma-direct: retry allocations using GFP_DMA for small masks

2018-01-04 Thread Christoph Hellwig
On Tue, Jan 02, 2018 at 04:43:15PM +, Vladimir Murzin wrote: > On 29/12/17 08:18, Christoph Hellwig wrote: > > If we got back an allocation that wasn't inside the support coherent mask, > > retry the allocation using GFP_DMA. > > > > Based on the x86 code. > > > > Signed-off-by: Christoph Hel