Christoph Hellwig writes:
> We want to use the dma_direct_ namespace for a generic implementation,
> so rename powerpc to the second best choice: dma_nommu_.
I'm not a fan of "nommu". Some of the users of direct ops *are* using an
IOMMU, they're just setting up a 1:1 mapping once at init time, r
On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman wrote:
> Christoph Hellwig writes:
>
>> We want to use the dma_direct_ namespace for a generic implementation,
>> so rename powerpc to the second best choice: dma_nommu_.
>
> I'm not a fan of "nommu". Some of the users of direct ops *are* using an
Missing patch description explaining why this change is desirable.
On Fri, Dec 29, 2017 at 9:18 AM, Christoph Hellwig wrote:
> --- a/lib/dma-direct.c
> +++ b/lib/dma-direct.c
> @@ -39,7 +39,7 @@ static void *dma_direct_alloc(struct device *dev, size_t
> size,
> if (gfpflags_allow_blockin
We now have exports in both architecture code in in common code,
which causes a link failure when symbol versioning is eanbled, on
four architectures:
kernel/exit.o: In function `__crc_abort':
exit.c:(*ABS*+0xc0e2ec8b): multiple definition of `__crc_abort'
This removes the four architecture speci
Hi Christoph,
On Fri, Dec 29, 2017 at 9:18 AM, Christoph Hellwig wrote:
> CONFIG_ALPHA_JENSEN has failed to compile since commit aca05038
> ("alpha/dma: use common noop dma ops"), so mark it as broken.
unknown revision or path not in the working tree.
Ah, you dropped the leading "6":
6aca0503847
On Fri, Dec 29, 2017 at 9:18 AM, Christoph Hellwig wrote:
> Life the code from x86 so that we behave consistently. In the future we
> should probably warn if any of these is set.
>
> Signed-off-by: Christoph Hellwig
For m68k:
Acked-by: Geert Uytterhoeven
Gr{oetje,eeting}s,
On Fri, Dec 29, 2017 at 9:18 AM, Christoph Hellwig wrote:
> The current PCI_DMA_BUS_IS_PHYS decided if a dma implementation is bound
> by the dma mask in the device because it directly maps to a physical
> address range (modulo an offset in the device), or if it is virtualized
> by an iommu and ca
The missing 'volatile' keyword on the iounmap argument leads to lots of
harmless warnings in an allmodconfig build:
sound/pci/echoaudio/echoaudio.c:1879:10: warning: passing argument 1 of
'iounmap' discards 'volatile' qualifier f
pointer target type [-Wdiscarded-qualifiers]
Signed-off-by: Arnd B
On Tue, Jan 02, 2018 at 11:31:12AM +0100, Arnd Bergmann wrote:
> We now have exports in both architecture code in in common code,
> which causes a link failure when symbol versioning is eanbled, on
> four architectures:
>
> kernel/exit.o: In function `__crc_abort':
> exit.c:(*ABS*+0xc0e2ec8b): mul
Hi Arnd,
On Tue, Jan 02, 2018 at 11:31:12AM +0100, Arnd Bergmann wrote:
> We now have exports in both architecture code in in common code,
> which causes a link failure when symbol versioning is eanbled, on
> four architectures:
>
> kernel/exit.o: In function `__crc_abort':
> exit.c:(*ABS*+0xc0e2
On Tue, Jan 02, 2018 at 11:34:45AM +, Sudip Mukherjee wrote:
> Hi Arnd,
>
> On Tue, Jan 02, 2018 at 11:31:12AM +0100, Arnd Bergmann wrote:
> > We now have exports in both architecture code in in common code,
> > which causes a link failure when symbol versioning is eanbled, on
> > four archite
On Tue, Jan 02, 2018 at 11:38:29AM +, Russell King - ARM Linux wrote:
> On Tue, Jan 02, 2018 at 11:34:45AM +, Sudip Mukherjee wrote:
> > Hi Arnd,
> >
> > On Tue, Jan 02, 2018 at 11:31:12AM +0100, Arnd Bergmann wrote:
> > > We now have exports in both architecture code in in common code,
>
Hi Arnd,
On Tue, Jan 2, 2018 at 12:01 PM, Arnd Bergmann wrote:
> The missing 'volatile' keyword on the iounmap argument leads to lots of
> harmless warnings in an allmodconfig build:
>
> sound/pci/echoaudio/echoaudio.c:1879:10: warning: passing argument 1 of
> 'iounmap' discards 'volatile' quali
On 29/12/17 08:18, Christoph Hellwig wrote:
> The trivial direct mapping implementation already does a virtual to
> physical translation which isn't strictly a noop, and will soon learn
> to do non-direct but linear physical to dma translations through the
> device offset and a few small tricks. R
On 29/12/17 08:18, Christoph Hellwig wrote:
> This means it uses whatever linear remapping scheme that the architecture
> provides is used in the generic dma_direct ops.
>
> Signed-off-by: Christoph Hellwig
> ---
> lib/dma-direct.c | 18 +++---
> 1 file changed, 7 insertions(+), 11 d
On 29/12/17 08:18, Christoph Hellwig wrote:
> If we got back an allocation that wasn't inside the support coherent mask,
> retry the allocation using GFP_DMA.
>
> Based on the x86 code.
>
> Signed-off-by: Christoph Hellwig
> ---
> lib/dma-direct.c | 25 -
> 1 file change
On 29/12/17 08:18, Christoph Hellwig wrote:
> So that they don't need to indirect through the operation vector.
>
> Signed-off-by: Christoph Hellwig
> ---
> arch/arm/mm/dma-mapping-nommu.c | 9 +++--
> include/linux/dma-direct.h | 5 +
> lib/dma-direct.c| 6 +++---
>
Geert Uytterhoeven writes:
> On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman wrote:
>> Christoph Hellwig writes:
>>
>>> We want to use the dma_direct_ namespace for a generic implementation,
>>> so rename powerpc to the second best choice: dma_nommu_.
>>
>> I'm not a fan of "nommu". Some of t
Hi Michael,
On Wed, Jan 3, 2018 at 7:24 AM, Michael Ellerman wrote:
> Geert Uytterhoeven writes:
>
>> On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman
>> wrote:
>>> Christoph Hellwig writes:
>>>
We want to use the dma_direct_ namespace for a generic implementation,
so rename powerp
19 matches
Mail list logo