Re: [PATCH v2 00/13] arch, mm: reduce code duplication in mem_init()

2025-03-13 Thread Mark Brown
> * fix alignment in allocation of zero pages on s390 > * add Acked-by This resolves the issues for 32 bit arm, at least the v7 boards: Tested-by: Mark Brown My v5 and v6 boards are having issues but I think that's unrelated infrastructure (in one case definitely so). signature.as

Re: [PATCH 10/13] arch, mm: set high_memory in free_area_init()

2025-03-12 Thread Mark Brown
On Tue, Mar 11, 2025 at 10:41:28PM +0100, Geert Uytterhoeven wrote: > On Tue, 11 Mar 2025 at 22:33, Mark Brown wrote: > > [0.00] efi: UEFI not found. > > [0.00] cma: Reserved 64 MiB at 0x > > - I'd only been sampling the logs for the physical pl

Re: [PATCH 10/13] arch, mm: set high_memory in free_area_init()

2025-03-11 Thread Mark Brown
On Tue, Mar 11, 2025 at 11:06:56PM +0200, Mike Rapoport wrote: > On Tue, Mar 11, 2025 at 05:51:06PM +0000, Mark Brown wrote: > > This patch appears to be causing breakage on a number of 32 bit arm > > platforms, including qemu's virt-2.11,gic-version=3. Affected platforms >

Re: [PATCH 10/13] arch, mm: set high_memory in free_area_init()

2025-03-11 Thread Mark Brown
On Thu, Mar 06, 2025 at 08:51:20PM +0200, Mike Rapoport wrote: > From: "Mike Rapoport (Microsoft)" > > high_memory defines upper bound on the directly mapped memory. > This bound is defined by the beginning of ZONE_HIGHMEM when a system has > high memory and by the end of memory otherwise. > > A

[PATCH v2 3/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-04 Thread Mark Brown
uses a single page guard, this is also sufficient for arm64 where we either do single word pops and pushes or unconstrained writes. Architectures which do not have this feature will define VM_SHADOW_STACK to VM_NONE and hence be unaffected. Suggested-by: Rick Edgecombe Acked-by: Lorenzo Stoa

[PATCH v2 2/3] mm: Pass vm_flags to generic_get_unmapped_area()

2024-09-04 Thread Mark Brown
functional changes. Acked-by: Lorenzo Stoakes Reviewed-by: Liam R. Howlett Acked-by: Michael Ellerman Signed-off-by: Mark Brown --- arch/powerpc/mm/book3s64/slice.c | 4 ++-- include/linux/sched/mm.h | 4 ++-- mm/mmap.c| 10 ++ 3 files changed, 10

[PATCH v2 1/3] mm: Make arch_get_unmapped_area() take vm_flags by default

2024-09-04 Thread Mark Brown
lags. No functional changes. Acked-by: Lorenzo Stoakes Reviewed-by: Liam R. Howlett Acked-by: Helge Deller # parisc Signed-off-by: Mark Brown --- arch/alpha/kernel/osf_sys.c | 2 +- arch/arc/mm/mmap.c| 3 ++- arch/arm/mm/mmap.c| 7 --- ar

[PATCH v2 0/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-04 Thread Mark Brown
ion for the generic code seems worth it. Changes in v2: - Add comment to stack_guard_placement() - Build fixes for xtensa and MIPS. - Link to v1: https://lore.kernel.org/r/20240902-mm-generic-shadow-stack-guard-v1-0-9acda38b3...@kernel.org --- Mark Brown (3): mm: Make arch_get_unmapped_a

Re: [PATCH 3/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-03 Thread Mark Brown
On Tue, Sep 03, 2024 at 03:41:49PM -0400, Liam R. Howlett wrote: > * Mark Brown [240902 15:09]: > > +static inline unsigned long stack_guard_placement(vm_flags_t vm_flags) > > +{ > > + if (vm_flags & VM_SHADOW_STACK) > > + return PAGE_SIZE; > Is P

Re: [PATCH 3/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-03 Thread Mark Brown
On Tue, Sep 03, 2024 at 06:49:46PM +0100, Lorenzo Stoakes wrote: > On Mon, Sep 02, 2024 at 08:08:15PM GMT, Mark Brown wrote: > > On x86 there is a custom arch_get_unmapped_area() which was updated by the > > above commit to cover this case by specifying a start_gap for alloc

[PATCH 1/3] mm: Make arch_get_unmapped_area() take vm_flags by default

2024-09-02 Thread Mark Brown
lags. No functional changes. Signed-off-by: Mark Brown --- arch/alpha/kernel/osf_sys.c | 2 +- arch/arc/mm/mmap.c| 3 ++- arch/arm/mm/mmap.c| 7 --- arch/csky/abiv1/mmap.c| 3 ++- arch/loongarch/mm/mmap.c | 5 +++--

[PATCH 3/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-02 Thread Mark Brown
rchitectures which do not have this feature will define VM_SHADOW_STACK to VM_NONE and hence be unaffected. Suggested-by: Rick Edgecombe Signed-off-by: Mark Brown --- mm/mmap.c | 10 ++ 1 file changed, 10 insertions(+) diff --git a/mm/mmap.c b/mm/mmap.c index b06ba847c96e..902c482b6084 1

[PATCH 2/3] mm: Pass vm_flags to generic_get_unmapped_area()

2024-09-02 Thread Mark Brown
. Signed-off-by: Mark Brown --- arch/powerpc/mm/book3s64/slice.c | 4 ++-- include/linux/sched/mm.h | 4 ++-- mm/mmap.c| 10 ++ 3 files changed, 10 insertions(+), 8 deletions(-) diff --git a/arch/powerpc/mm/book3s64/slice.c b/arch/powerpc/mm/book3s64/slice.c

[PATCH 0/3] mm: Care about shadow stack guard gap when getting an unmapped area

2024-09-02 Thread Mark Brown
ion for the generic code seems worth it. Signed-off-by: Mark Brown --- Mark Brown (3): mm: Make arch_get_unmapped_area() take vm_flags by default mm: Pass vm_flags to generic_get_unmapped_area() mm: Care about shadow stack guard gap when getting an unmapped area arch/alp

Re: [PATCH 10/17] arm64: generate 64-bit syscall.tbl

2024-07-10 Thread Mark Brown
On Wed, Jul 10, 2024 at 10:57:25AM +0200, Arnd Bergmann wrote: > Thanks for the report! I just panicked a bit and thought I had > done something entirely wrong here, but after having a closer > look it turned out to be a silly typo: > -#include > +#include Doh, I should've spotted that even fr

Re: [PATCH 10/17] arm64: generate 64-bit syscall.tbl

2024-07-09 Thread Mark Brown
On Thu, Jul 04, 2024 at 04:36:04PM +0200, Arnd Bergmann wrote: > #define __ARCH_WANT_SYS_CLONE > +#define __ARCH_WANT_NEW_STAT > > -#ifndef __COMPAT_SYSCALL_NR > -#include > -#endif > +#include It looks like this is causing widespread build breakage in kselftest in -next for arm64, there are

Re: [PATCH 15/22] arch: vdso: consolidate gettime prototypes

2023-11-24 Thread Mark Brown
On Wed, Nov 08, 2023 at 01:58:36PM +0100, Arnd Bergmann wrote: > From: Arnd Bergmann > > The VDSO functions are defined as globals in the kernel sources but intended > to be called from userspace, so there is no need to declare them in a kernel > side header. This is in -next as commit 42874e4eb

Re: [PATCH v9 01/42] mm: Rename arch pte_mkwrite()'s to pte_mkwrite_novma()

2023-07-17 Thread Mark Brown
On Mon, Jul 17, 2023 at 03:55:50PM +, Edgecombe, Rick P wrote: > On Fri, 2023-07-14 at 23:57 +0100, Mark Brown wrote: > > The same issue seems to apply with the version that was in -next > > based > > on v6.4-rc4 too. > The version in your branch is not the same as t

Re: [PATCH v9 01/42] mm: Rename arch pte_mkwrite()'s to pte_mkwrite_novma()

2023-07-14 Thread Mark Brown
On Mon, Jun 12, 2023 at 05:10:27PM -0700, Rick Edgecombe wrote: > The x86 Shadow stack feature includes a new type of memory called shadow > stack. This shadow stack memory has some unusual properties, which requires > some core mm changes to function properly. This seems to break sparc64_defconfi

Re: [PATCH mm-unstable v1 04/26] arm/mm: support __HAVE_ARCH_PTE_SWP_EXCLUSIVE

2023-02-08 Thread Mark Brown
On Wed, Feb 08, 2023 at 03:12:06PM +0100, David Hildenbrand wrote: > On 07.02.23 01:32, Mark Brown wrote: > > Today's -next (and at least back to Friday, older logs are unclear - I > > only noticed -next issues today) fails to NFS boot on an AT91SAM9G20-EK > > (a

Re: [PATCH mm-unstable v1 04/26] arm/mm: support __HAVE_ARCH_PTE_SWP_EXCLUSIVE

2023-02-06 Thread Mark Brown
On Fri, Jan 13, 2023 at 06:10:04PM +0100, David Hildenbrand wrote: > Let's support __HAVE_ARCH_PTE_SWP_EXCLUSIVE by stealing one bit from the > offset. This reduces the maximum swap space per file to 64 GiB (was 128 > GiB). > > While at it drop the PTE_TYPE_FAULT from __swp_entry_to_pte() which is

Re: [PATCH V12] mm/debug: Add tests validating architecture page table helpers

2020-01-28 Thread Mark Brown
On Tue, Jan 28, 2020 at 02:12:56AM -0500, Qian Cai wrote: > > On Jan 28, 2020, at 1:13 AM, Christophe Leroy > > wrote: > > ppc32 an indecent / legacy platform ? Are you kidying ? > > Powerquicc II PRO for instance is fully supported by the > > manufacturer and widely used in many small networki

Applied "ASoC: dwc: Add irq parameter to DOCUMENTATION" to the asoc tree

2016-06-13 Thread Mark Brown
was added. Signed-off-by: Jose Abreu Acked-by: Rob Herring Cc: Carlos Palminha Cc: Mark Brown Cc: Liam Girdwood Cc: Jaroslav Kysela Cc: Takashi Iwai Cc: Rob Herring Cc: Alexey Brodkin Cc: linux-snps-arc@lists.infradead.org Cc: alsa-de...@alsa-project.org Cc: linux-ker...@vger.kernel.org Sig

Applied "ASoC: dwc: Add PIO PCM extension" to the asoc tree

2016-06-13 Thread Mark Brown
ark Brown Cc: Liam Girdwood Cc: Jaroslav Kysela Cc: Takashi Iwai Cc: Rob Herring Cc: Alexey Brodkin Cc: linux-snps-arc@lists.infradead.org Cc: alsa-de...@alsa-project.org Cc: linux-ker...@vger.kernel.org Signed-off-by: Mark Brown --- sound/soc/dwc/Kconfig | 9 ++ sound/soc/dwc/Makef

Re: [PATCH 1/2 v8] ASoC: dwc: Add PIO PCM extension

2016-06-07 Thread Mark Brown
On Mon, May 30, 2016 at 10:53:15AM +0100, Jose Abreu wrote: A few small things but this looks basically fine. > + if (isr[i] & 0x33) > + irq_valid = true; This checks for a mask of 0x33 but... > + > + /* > + * Check if TX fifo is empty. I

Re: [PATCH 3/4 v7] ASoC: dwc: Add PIO PCM extension

2016-05-25 Thread Mark Brown
On Wed, May 25, 2016 at 11:49:12AM +0100, Jose Abreu wrote: > Ok, will do that. I noticed the last I2S patch that you merged > ("ASoC: dwc: Add helper functions to disable/enable irqs") is not > in for-next yet. Should I base my work on 'topic/dwc' branch? We are in the merge window. No new non-

Re: [PATCH 3/4 v7] ASoC: dwc: Add PIO PCM extension

2016-05-25 Thread Mark Brown
On Wed, May 25, 2016 at 11:11:47AM +0100, Jose Abreu wrote: > I think I will take the second option. Something like this: > " > ret = snd_dmaengine_pcm_register(...) > if (ret == -EPROBE_DEFER) > return ret; > else > pio_register(...); > "? Sure. You should print a di

Re: [PATCH 3/4 v7] ASoC: dwc: Add PIO PCM extension

2016-05-24 Thread Mark Brown
On Tue, May 24, 2016 at 06:07:14PM +0100, Jose Abreu wrote: > On 24-05-2016 17:41, Mark Brown wrote: Please fix your mail client to word wrap within paragraphs at something substantially less than 80 columns. Doing this makes your messages much easier to read and reply to. > >>i

Re: [PATCH 3/4 v7] ASoC: dwc: Add PIO PCM extension

2016-05-24 Thread Mark Brown
On Mon, May 23, 2016 at 11:02:24AM +0100, Jose Abreu wrote: > +config SND_DESIGNWARE_PCM > + bool "PCM PIO extension for I2S driver" Why can't this be built as a module? > + > + return irq_valid ? IRQ_HANDLED : IRQ_NONE; Please write a normal if statement, the ternery operator doesn't h

Applied "ASoC: dwc: Add helper functions to disable/enable irqs" to the asoc tree

2016-05-23 Thread Mark Brown
I2S interrupts were added. Only the interrupts of the used channels are enabled. Also, there is no need to enable irqs at dw_i2s_config(), they are already enabled at startup. Signed-off-by: Jose Abreu Cc: Carlos Palminha Cc: Mark Brown Cc: Liam Girdwood Cc: Jaroslav Kysela Cc: Takashi Iwai Cc:

Re: [PATCH 2/4 v7] ASoC: dwc: Do not use devm_clk_get() if using platform data

2016-05-23 Thread Mark Brown
On Mon, May 23, 2016 at 11:02:23AM +0100, Jose Abreu wrote: > When using platform data the devm_clk_get() function is > called causing a probe failure if the clock is not > declared. As we can pass the clock handler by platform > data call only devm_clk_get() when platform data is not > used. No,

Re: [PATCH 1/2 v6] ASoC: dwc: Add custom PCM driver

2016-05-04 Thread Mark Brown
On Wed, Apr 27, 2016 at 11:05:19AM +0100, Jose Abreu wrote: > + for (i = 0; i < 4; i++) > + isr[i] = i2s_read_reg(dev->i2s_base, ISR(i)); > + > + i2s_clear_irqs(dev, SNDRV_PCM_STREAM_PLAYBACK); > + i2s_clear_irqs(dev, SNDRV_PCM_STREAM_CAPTURE); > + > + if (dev->use_dmae

Re: [PATCH 2/2 v6] ASoC: dwc: Update DOCUMENTATION for I2S Driver

2016-05-04 Thread Mark Brown
On Wed, Apr 27, 2016 at 06:37:47PM +0100, Jose Abreu wrote: > This patch updates documentation for the Designware I2S > driver. Why is the DOCUMENTATION being updated and why are we shouting about it? You need to describe what the change does so that it's possible to review if the change is doing

Re: [PATCH 1/2 v6] ASoC: dwc: Add custom PCM driver

2016-04-29 Thread Mark Brown
On Fri, Apr 29, 2016 at 10:02:59AM +0100, Jose Abreu wrote: > Hi Mark, > > Can you give me some comments regarding this patch? Am I following the right > track? This is the first time that I am using ALSA SoC so pardon me if I am > making some mistake. I would appreciate some kind of input. I test

Re: [PATCH 2/2 v6] ASoC: dwc: Update DOCUMENTATION for I2S Driver

2016-04-27 Thread Mark Brown
On Wed, Apr 27, 2016 at 06:32:42PM +0100, Jose Abreu wrote: > Hi Mark, > > Sorry. Follows bellow. > > On 27-04-2016 11:05, Jose Abreu wrote: I can't apply a quote of a patch, please resend. signature.asc Description: PGP signature ___ linux-snps-arc

Re: [PATCH 0/2 v6] Add I2S audio support for ARC AXS10x boards

2016-04-27 Thread Mark Brown
On Wed, Apr 27, 2016 at 11:05:18AM +0100, Jose Abreu wrote: > ARC AXS10x platforms consist of a mainboard with several peripherals. > One of those peripherals is an HDMI output port controlled by the ADV7511 > transmitter. > > This patch set adds I2S audio for the AXS10x platform. I don't seem to

Applied "ASoC: dwc: Use fifo depth to program FCR" to the asoc tree

2016-04-07 Thread Mark Brown
ifo configuration register instead of using hardcoded values. Signed-off-by: Jose Abreu Signed-off-by: Mark Brown --- sound/soc/dwc/designware_i2s.c | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git a/sound/soc/dwc/designware_i2s.c b/sound/soc/dwc/designware_i2s.c in

Re: [PATCH 5/5 v4] ASoC: dwc: Update DOCUMENTATION for I2S Driver

2016-04-07 Thread Mark Brown
On Thu, Apr 07, 2016 at 05:53:59PM +0100, Jose Abreu wrote: > + Optional properties: > + - snps,use-dmaengine: If set the driver will use ALSA DMA engine. If set > + it is required to use the properties 'dmas' and 'dma-names'. This is not a good interface, it's describing Linux internal APIs.

Re: [PATCH 3/3 v3] ASoC: dwc: Unmask I2S interrupts only for enabled channels

2016-04-05 Thread Mark Brown
On Tue, Apr 05, 2016 at 06:08:02PM +0100, Jose Abreu wrote: > There is no need to unmask all interrupts at I2S start. This > can cause performance issues in slower platforms. > > Unmask only the interrupts for the used channels. This appears to be completely unrelated to the other two patches in

Re: [PATCH 2/3 v2] ASoC: dwc: Add I2S HDMI audio support

2016-03-31 Thread Mark Brown
On Thu, Mar 31, 2016 at 10:37:20AM +0100, Jose Abreu wrote: > On 29-03-2016 19:22, Mark Brown wrote: > > If you want to add a new platform driver you need to add a new platform > > driver, not shove the code into an existing driver for a seperate IP. > I can separate the plat

Re: [PATCH 2/3 v2] ASoC: dwc: Add I2S HDMI audio support

2016-03-29 Thread Mark Brown
On Tue, Mar 29, 2016 at 07:03:01PM +0100, Jose Abreu wrote: > The major part of this patch is the adding of an ALSA platform driver so that > audio comes out of the box in AXS boards but we also added functionalities to > the i2s driver and performed one bug fix related with the mask/unmask of > i

Re: [PATCH 2/3 v2] ASoC: dwc: Add I2S HDMI audio support

2016-03-29 Thread Mark Brown
On Mon, Mar 28, 2016 at 03:36:10PM +0100, Jose Abreu wrote: > HDMI audio support was added to the AXS board using an > I2S cpu driver and a custom platform driver. > > The platform driver supports two channels @ 16 bits with > rates 32k, 44.1k and 48k. ALSA Simple audio card is used to > glue the

Re: [PATCH 0/3 v2] Add I2S/ADV7511 audio support for ARC AXS10x boards

2016-03-29 Thread Mark Brown
On Mon, Mar 28, 2016 at 03:36:08PM +0100, Jose Abreu wrote: > ARC AXS10x platforms consist of a mainboard with several peripherals. > One of those peripherals is an HDMI output port controlled by the ADV7511 > transmitter. I'm going to tell you the same thing I tell everyone else working on HDMI a