Re: [PATCH] mm/slab: rename CONFIG_SLAB to CONFIG_SLAB_DEPRECATED

2023-05-25 Thread Helge Deller
On 5/24/23 02:29, David Rientjes wrote: On Tue, 23 May 2023, Vlastimil Babka wrote: As discussed at LSF/MM [1] [2] and with no objections raised there, deprecate the SLAB allocator. Rename the user-visible option so that users with CONFIG_SLAB=y get a new prompt with explanation during make old

[RESEND PATCH 2/2] ARC: rename 16KSTACKS to DEBUG_STACKS

2023-05-25 Thread Min-Hua Chen
Rename 16KSTACKS to DEBUG_STACKS. arch/arc/Kconfig.debug says that the default stack size is 8KB and it will become 16KB stack if 16KSTACKS is set. However, the stack size is based on PAGE_SIZE, and it is configurable by CONFIG_ARC_PAGE_SIZE_16K or CONFIG_ARC_PAGE_SIZE_4K. When CONFIG_16KSTACKS=y

[RESEND PATCH 0/2] ARC: fix THREAD_SHIFT and rename 16KSTACKS

2023-05-25 Thread Min-Hua Chen
Hi, When I read the arch/arc code, I first noticed that the definition of THREAD_SHIFT looks incorrect and the description of 16KSTACKS looks confusing because there are multiple definitions of PAGE_SHIFT. So I submit these patches to address the issues I found. Min-Hua Chen (2): ARC: fix inco

[RESEND PATCH 1/2] ARC: fix incorrect THREAD_SHIFT definition

2023-05-25 Thread Min-Hua Chen
Current definition of THREAD_SHIFT is (PAGE_SHIFT << THREAD_SIZE_ORDER) It should be (PAGE_SHIFT + THREAD_SIZE_ORDER) because the following equation should hold: Say PAGE_SHIFT == 13 (as the default value in ARC) THREAD_SIZE_ORDER == 1 (as CONFIG_16KSTACKS=y) THREAD_SIZE == (1 << THREAD_SHIFT)

Re: [PATCH 00/21] dma-mapping: unify support for cache flushes

2023-05-25 Thread Lad, Prabhakar
Hi Arnd, On Mon, Mar 27, 2023 at 1:14 PM Arnd Bergmann wrote: > > From: Arnd Bergmann > > After a long discussion about adding SoC specific semantics for when > to flush caches in drivers/soc/ drivers that we determined to be > fundamentally flawed[1], I volunteered to try to move that logic int