Re: [PATCH 4/5] arch/kmap_atomic: Consolidate duplicate code

2020-04-26 Thread Christoph Hellwig
On Sun, Apr 26, 2020 at 06:16:30PM -0700, Ira Weiny wrote: > > That might require to support > > kmap_atomic_prot everywhere first, which sounds like a really good > > idea anyway, and would avoid the need for strange workaround in drm. > > Having a kmap_atomic_prot() seems like a good idea. But

Re: [PATCH 4/5] arch/kmap_atomic: Consolidate duplicate code

2020-04-26 Thread Ira Weiny
On Sun, Apr 26, 2020 at 12:26:42AM -0700, Christoph Hellwig wrote: > > diff --git a/arch/arc/mm/highmem.c b/arch/arc/mm/highmem.c > > index 4db13a6b9f3b..1cae4b911a33 100644 > > --- a/arch/arc/mm/highmem.c > > +++ b/arch/arc/mm/highmem.c > > @@ -53,11 +53,10 @@ void *kmap_atomic(struct page *page)

Re: [PATCH 2/5] arch/kmap: Remove redundant arch specific kmaps

2020-04-26 Thread Ira Weiny
On Sun, Apr 26, 2020 at 12:17:15AM -0700, Christoph Hellwig wrote: > On Sat, Apr 25, 2020 at 10:54:03PM -0700, ira.we...@intel.com wrote: > > From: Ira Weiny > > > > The kmap code for all the architectures is almost 100% identical. > > > > Lift the common code to the core. Use ARCH_HAS_KMAP to

Re: [PATCH 4/5] arch/kmap_atomic: Consolidate duplicate code

2020-04-26 Thread Christoph Hellwig
> diff --git a/arch/arc/mm/highmem.c b/arch/arc/mm/highmem.c > index 4db13a6b9f3b..1cae4b911a33 100644 > --- a/arch/arc/mm/highmem.c > +++ b/arch/arc/mm/highmem.c > @@ -53,11 +53,10 @@ void *kmap_atomic(struct page *page) > { > int idx, cpu_idx; > unsigned long vaddr; > + void *add

Re: [PATCH 2/5] arch/kmap: Remove redundant arch specific kmaps

2020-04-26 Thread Christoph Hellwig
On Sat, Apr 25, 2020 at 10:54:03PM -0700, ira.we...@intel.com wrote: > From: Ira Weiny > > The kmap code for all the architectures is almost 100% identical. > > Lift the common code to the core. Use ARCH_HAS_KMAP to indicate if an > arch needs a special kmap. Can you add a kmap_flush_tlb hook