Re: [PATCH 18/21] mm: rename free_area_init_node() to free_area_init_memoryless_node()

2020-04-22 Thread Mike Rapoport
On Thu, Apr 23, 2020 at 11:14:54AM +0800, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > The free_area_init_node() is only used by x86 to initialize a memory-less > > nodes. > > Make its name reflect this and drop all the function parameters excep

Re: [PATCH 17/21] mm: free_area_init: allow defining max_zone_pfn in descending order

2020-04-22 Thread Mike Rapoport
On Thu, Apr 23, 2020 at 10:57:20AM +0800, Baoquan He wrote: > On 04/23/20 at 10:53am, Baoquan He wrote: > > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > > From: Mike Rapoport > > > > > > Some architectures (e.g. ARC) have the ZONE_HIGHMEM zone below the > > > ZONE_NORMAL. Allowing free_area_i

Re: [PATCH 16/21] mm: remove early_pfn_in_nid() and CONFIG_NODES_SPAN_OTHER_NODES

2020-04-22 Thread Mike Rapoport
On Thu, Apr 23, 2020 at 09:13:12AM +0800, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > The commit f47ac088c406 ("mm: memmap_init: iterate over memblock regions > > This commit id should be a temporary one, will be changed when merged > into mai

Re: [PATCH 18/21] mm: rename free_area_init_node() to free_area_init_memoryless_node()

2020-04-22 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The free_area_init_node() is only used by x86 to initialize a memory-less > nodes. > Make its name reflect this and drop all the function parameters except node > ID as they are anyway zero. > > Signed-off-by: Mike Rapoport

Re: [PATCH 17/21] mm: free_area_init: allow defining max_zone_pfn in descending order

2020-04-22 Thread Baoquan He
On 04/23/20 at 10:53am, Baoquan He wrote: > On 04/12/20 at 10:48pm, Mike Rapoport wrote: > > From: Mike Rapoport > > > > Some architectures (e.g. ARC) have the ZONE_HIGHMEM zone below the > > ZONE_NORMAL. Allowing free_area_init() parse max_zone_pfn array even it is > > sorted in descending order

Re: [PATCH 17/21] mm: free_area_init: allow defining max_zone_pfn in descending order

2020-04-22 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > Some architectures (e.g. ARC) have the ZONE_HIGHMEM zone below the > ZONE_NORMAL. Allowing free_area_init() parse max_zone_pfn array even it is > sorted in descending order allows using free_area_init() on such > architectures

[PATCH v6 05/13] ARC: math soft float support

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/arc/bits/fenv.h | 77 +++ sysdeps/arc/nofpu/Implies | 1 + sysdeps/arc/nofpu/math-tests-exceptions.h | 27 sysdeps/arc/nofpu/math-tests-rounding.h | 27 sysdeps/arc/sfp-machine.h

[PATCH v6 06/13] ARC: hardware floating point support

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/arc/fpu/e_sqrt.c| 27 sysdeps/arc/fpu/e_sqrtf.c | 27 sysdeps/arc/fpu/fclrexcpt.c | 36 +++ sysdeps/arc/fpu/fegetenv.c | 37 +++ sysdeps/arc/fpu/fegetmode.c | 31 ++ sysdeps/arc/fpu/f

[PATCH v6 01/13] ARC: ABI Implementation

2020-04-22 Thread Vineet Gupta
This code deals with the ARC ABI. Signed-off-by: Vineet Gupta --- sysdeps/arc/__longjmp.S | 50 ++ sysdeps/arc/abort-instr.h | 2 + sysdeps/arc/bits/endianness.h | 15 +++ sysdeps/arc/bits/setjmp.h | 26 sysdeps/arc/bsd-_setjmp.S | 1 + sy

[PATCH v6 12/13] build-many-glibcs.py: Enable ARC builds

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- scripts/build-many-glibcs.py | 10 ++ 1 file changed, 10 insertions(+) diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py index 4832912b28b9..752da3657a01 100755 --- a/scripts/build-many-glibcs.py +++ b/scripts/build-many-glibcs.py @@

[PATCH v6 07/13] ARC: Linux Syscall Interface

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/unix/sysv/linux/arc/arch-syscall.h| 303 ++ sysdeps/unix/sysv/linux/arc/bits/timesize.h | 21 ++ sysdeps/unix/sysv/linux/arc/clone.S | 98 ++ .../unix/sysv/linux/arc/fixup-asm-unistd.h| 41 +++ sysdeps/unix/sysv/li

[PATCH v6 10/13] ARC: ABI lists

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/arc/fpu/libm-test-ulps| 1140 + sysdeps/arc/fpu/libm-test-ulps-name |1 + sysdeps/arc/nofpu/libm-test-ulps | 270 +++ sysdeps/arc/nofpu/libm-test-ulps-name |1 + sysdeps/unix/sysv/linux/arc/c++

[PATCH v6 02/13] ARC: startup and dynamic linking code

2020-04-22 Thread Vineet Gupta
Code for C runtime startup and dynamic loading including PLT layout. Signed-off-by: Vineet Gupta --- sysdeps/arc/bits/link.h | 52 ++ sysdeps/arc/dl-machine.h | 340 ++ sysdeps/arc/entry.h | 5 + sysdeps/arc/ldsodefs.h| 43 + sysdeps/a

[PATCH v6 00/13] glibc port to ARC processors

2020-04-22 Thread Vineet Gupta
Hi, This patchset implements glibc port to ARC HS48x processor from Synopsys. This still needs a couple of inflight 64-time, offset patches. g...@github.com:foss-for-synopsys-dwc-arc-processors/glibc.git upstream-v6 v6: * Dropped 11/14: merged upstream * _FPU_SETS() inline asm reworked

[PATCH v6 09/13] ARC: Linux Startup and Dynamic Loading

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/unix/sysv/linux/arc/dl-static.c | 84 + sysdeps/unix/sysv/linux/arc/ldsodefs.h | 32 ++ 2 files changed, 116 insertions(+) create mode 100644 sysdeps/unix/sysv/linux/arc/dl-static.c create mode 100644 sysdeps/unix/sysv/lin

[PATCH v6 03/13] ARC: Thread Local Storage support

2020-04-22 Thread Vineet Gupta
This includes all 4 TLS addressing models Signed-off-by: Vineet Gupta --- sysdeps/arc/dl-tls.h | 30 +++ sysdeps/arc/libc-tls.c | 27 ++ sysdeps/arc/nptl/tcb-offsets.sym | 11 +++ sysdeps/arc/nptl/tls.h | 150 +++ sysdeps/arc

[PATCH v6 04/13] ARC: Atomics and Locking primitives

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/arc/atomic-machine.h | 69 +++ sysdeps/arc/nptl/bits/semaphore.h | 32 ++ 2 files changed, 101 insertions(+) create mode 100644 sysdeps/arc/atomic-machine.h create mode 100644 sysdeps/arc/nptl/bits/semaphore.h

[PATCH v6 11/13] ARC: Build Infrastructure

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- config.h.in| 3 + sysdeps/arc/Implies| 3 + sysdeps/arc/Makefile | 21 +++ sysdeps/arc/Versions | 8 + sysdeps/arc/configure | 182 ++

[PATCH v6 08/13] ARC: Linux ABI

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- sysdeps/arc/nptl/pthreaddef.h | 32 +++ sysdeps/unix/sysv/linux/arc/bits/procfs.h | 35 +++ .../sysv/linux/arc/bits/types/__sigset_t.h| 12 +++ sysdeps/unix/sysv/linux/arc/getcontext.S | 63 + sysdeps/unix/sysv/linux

[PATCH v6 13/13] Documentation for ARC port

2020-04-22 Thread Vineet Gupta
Signed-off-by: Vineet Gupta --- NEWS| 9 + README | 1 + manual/install.texi | 4 3 files changed, 14 insertions(+) diff --git a/NEWS b/NEWS index 0e627b34057d..d59c1ffb96e1 100644 --- a/NEWS +++ b/NEWS @@ -15,6 +15,15 @@ Major new features: * New loc

Re: [PATCH 16/21] mm: remove early_pfn_in_nid() and CONFIG_NODES_SPAN_OTHER_NODES

2020-04-22 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The commit f47ac088c406 ("mm: memmap_init: iterate over memblock regions This commit id should be a temporary one, will be changed when merged into maintainer's tree and linus's tree. Only saying last patch plus the patch sub

Re: [PATCH 05/21] mm: use free_area_init() instead of free_area_init_nodes()

2020-04-22 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > The free_area_init() has effectively became a wrapper for > free_area_init_nodes() and there is no point of keeping it. Still > free_area_init() name is shorter and more general as it does not imply > necessity to initialize m

Re: [PATCH 04/21] mm: free_area_init: use maximal zone PFNs rather than zone sizes

2020-04-22 Thread Baoquan He
On 04/12/20 at 10:48pm, Mike Rapoport wrote: > From: Mike Rapoport > > Currently, architectures that use free_area_init() to initialize memory map > and node and zone structures need to calculate zone and hole sizes. We can > use free_area_init_nodes() instead and let it detect the zone boundarie

Re: [PATCH v3] Make any 32-bit time based syscalls unavailable for TIMESIZE==64

2020-04-22 Thread Vineet Gupta
On 4/18/20 9:50 AM, Florian Weimer wrote: > * Vineet Gupta via Libc-alpha: > >> >> If this is not suitable for common code, I'd still like to add this >> as part of ARC port to safe guard against future snafus. > > Have you tried to add the #undefs to fixup-asm-unistd.h? > See sysdeps/unix/sysv/l