[PATCH] ccp: ccp - add support for Green Sardine

2021-04-16 Thread Rijo Thomas
From: Devaraj Rangasamy Add a new PCI device entry for Green Sardine APU. Signed-off-by: Devaraj Rangasamy Tested-by: Babulu Ellune Signed-off-by: Rijo Thomas --- drivers/crypto/ccp/sp-pci.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/crypto/ccp/sp-pci.c b/drivers/crypto/ccp/

Re: [PATCH] crypto: hisilicon/hpre - fix unmapping invalid dma address

2021-04-16 Thread Herbert Xu
On Sat, Apr 10, 2021 at 05:49:17PM +0800, Hui Tang wrote: > Currently, an invalid dma address may be unmapped when calling > 'xx_data_clr_all' in error path, so check dma address of sqe in/out > whether it has been mapped before calling 'dma_free_coherent' or > 'dma_unmap_single'. > > An abnormal

Re: [PATCH v2] ecc: delete a useless function declaration

2021-04-16 Thread Herbert Xu
On Tue, Apr 06, 2021 at 10:32:59AM +0800, Meng Yu wrote: > This function declaration has been added in 'ecc_curve.h', > delete it in 'crypto/ecc.h'. > > Fixes: 4e6602916bc6(crypto: ecdsa - Add support for ECDSA ...) > Signed-off-by: Meng Yu > --- > > v1 -> v2: Modify the 'Fixes tag' from '14bb76

Re: [PATCH -next] crypto: geode -: use DEFINE_SPINLOCK() for spinlock

2021-04-16 Thread Herbert Xu
On Tue, Apr 06, 2021 at 08:00:03PM +0800, Huang Guobin wrote: > From: Guobin Huang > > spinlock can be initialized automatically with DEFINE_SPINLOCK() > rather than explicitly calling spin_lock_init(). > > Reported-by: Hulk Robot > Signed-off-by: Guobin Huang > --- > drivers/crypto/geode-aes

Re: [PATCH -next] crypto: ixp4xx -: use DEFINE_SPINLOCK() for spinlock

2021-04-16 Thread Herbert Xu
On Tue, Apr 06, 2021 at 08:02:57PM +0800, Huang Guobin wrote: > From: Guobin Huang > > spinlock can be initialized automatically with DEFINE_SPINLOCK() > rather than explicitly calling spin_lock_init(). > > Reported-by: Hulk Robot > Signed-off-by: Guobin Huang > --- > drivers/crypto/ixp4xx_cr

Re: [PATCH] crypto: hisilicon/qm - add stop queue by hardware

2021-04-16 Thread Herbert Xu
On Tue, Apr 06, 2021 at 08:56:02PM +0800, Weili Qian wrote: > Kunpeng930 could be able to stop queue by writing hardware registers, > which will trigger tasks in device to be flushed out. > > In order to be compatible with the kunpeng920 driver, add 'qm_hw_ops_v3' to > adapt Kunpeng930. And 'stop_

Re: [PATCH] crypto: arm64/aes-ce - deal with oversight in new CTR carry code

2021-04-16 Thread Herbert Xu
On Tue, Apr 06, 2021 at 04:25:23PM +0200, Ard Biesheuvel wrote: > The new carry handling code in the CTR driver can deal with a carry > occurring in the 4x/5x parallel code path, by using a computed goto to > jump into the carry sequence at the right place as to only apply the > carry to a subset o

Re: [PATCH] crypto: hisilicon/trng - add version to adapt new algorithm

2021-04-16 Thread Herbert Xu
On Wed, Apr 07, 2021 at 05:44:33PM +0800, Weili Qian wrote: > Kunpeng930 supports trng and prng, but Kunpeng920 only supports trng. > > Therefore, version information is added to ensure that prng is not > registered to Crypto subsystem on Kunpeng920. > > Signed-off-by: Weili Qian > --- > driver

Re: [PATCH -next 0/5] Remove redundant dev_err call

2021-04-16 Thread Herbert Xu
On Wed, Apr 07, 2021 at 10:18:14PM +0800, YueHaibing wrote: > This patchset remove some redundant dev_err calls > > YueHaibing (5): > crypto: atmel-tdes - Remove redundant dev_err call in > atmel_tdes_probe() > crypto: img-hash - Remove redundant dev_err call in img_hash_probe() > crypto

Re: [PATCH] crypto: cavium - remove unused including

2021-04-16 Thread Herbert Xu
On Thu, Apr 08, 2021 at 11:21:51AM +0800, Tian Tao wrote: > Remove including that don't need it. > > Signed-off-by: Tian Tao > Signed-off-by: Zhiqi Song > --- > drivers/crypto/cavium/zip/common.h | 1 - > 1 file changed, 1 deletion(-) Patch applied. Thanks. -- Email: Herbert Xu Home Page:

Re: [PATCH -next 1/7] crypto: sun4i-ss - Fix PM reference leak when pm_runtime_get_sync() fails

2021-04-16 Thread Herbert Xu
On Thu, Apr 08, 2021 at 03:18:31PM +0800, Shixin Liu wrote: > pm_runtime_get_sync will increment pm usage counter even it failed. > Forgetting to putting operation will result in reference leak here. > Fix it by replacing it with pm_runtime_resume_and_get to keep usage > counter balanced. > > Sign

Re: [PATCH 0/2] crypto: correct the use of print format

2021-04-16 Thread Herbert Xu
On Thu, Apr 08, 2021 at 06:23:49PM +0800, Kai Ye wrote: > According to Documentation/core-api/printk-formats.rst, > Use the correct print format. Printing an unsigned int value should use %u > instead of %d. Otherwise printk() might end up displaying negative numbers. > > Kai Ye (2): > crypto/at

Re: [PATCH v3 0/5] bug fix and clear coding style

2021-04-16 Thread Herbert Xu
On Fri, Apr 09, 2021 at 05:03:59PM +0800, Kai Ye wrote: > Fixup coding style such as delete unneeded variable > initialization. Add a comment for block size initialization. > Add a data cleared operation in sg buf unmap, and other misc fix. > > v1 -> v2: > 1. fix [PATCH v2] error in v1. > 2. v1

Re: [PATCH] crypto: qat - enable detection of accelerators hang

2021-04-16 Thread Herbert Xu
On Fri, Apr 09, 2021 at 02:56:19PM +0100, Giovanni Cabiddu wrote: > From: Wojciech Ziemba > > Enable the detection of hangs by setting watchdog timers (WDTs) on > generations that supports that feature. > > The default timeout value comes from HW specs. WTDs are reset each time > an accelerator

Re: [PATCH 0/3] crypto: hisilicon/hpre - add debug log

2021-04-16 Thread Herbert Xu
On Sat, Apr 10, 2021 at 05:46:58PM +0800, Hui Tang wrote: > This patchset adds the debug log and cleanup code style. > > Hui Tang (3): > crypto: hisilicon/hpre - delete the rudundant space after return > crypto: hisilicon/hpre - use the correct variable type > crypto: hisilicon/hpre - add de

Re: [PATCH] crypto: arm/curve25519 - Move '.fpu' after '.arch'

2021-04-16 Thread Herbert Xu
On Fri, Apr 09, 2021 at 03:11:55PM -0700, Nathan Chancellor wrote: > Debian's clang carries a patch that makes the default FPU mode > 'vfp3-d16' instead of 'neon' for 'armv7-a' to avoid generating NEON > instructions on hardware that does not support them: > > https://salsa.debian.org/pkg-llvm-tea

Re: [PATCH] crypto: crc32-generic - Use SPDX-License-Identifier

2021-04-16 Thread Herbert Xu
On Sat, Apr 10, 2021 at 10:30:16PM +0200, Christophe JAILLET wrote: > Use SPDX-License-Identifier: GPL-2.0-only, instead of hand writing it. > > This also removes a reference to http://www.xyratex.com which seems to be > down. > > Signed-off-by: Christophe JAILLET > --- > crypto/crc32_generic.c

Re: [PATCH v3] crypto: hisilicon/hpre - delete redundant log and return in advance

2021-04-16 Thread Herbert Xu
On Sat, Apr 10, 2021 at 05:50:32PM +0800, Hui Tang wrote: > 'hpre_cfg_by_dsm' has checked and printed error path internally. It is not > necessary to do it here, so remove it. > > It should return error immediately when return value of 'hpre_cfg_by_dsm' > is non-zero, and no need to execute the re

[PATCH 1/3] crypto: s5p-sss - simplify getting of_device_id match data

2021-04-16 Thread Krzysztof Kozlowski
Use of_device_get_match_data() to make the code slightly smaller. Signed-off-by: Krzysztof Kozlowski --- drivers/crypto/s5p-sss.c | 9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c index 8ed08130196f..d613bd557016 1006

[PATCH 2/3] crypto: s5p-sss - remove unneeded local variable initialization

2021-04-16 Thread Krzysztof Kozlowski
The initialization of 'err' local variable is not needed as it is shortly after overwritten. Addresses-Coverity: Unused value Signed-off-by: Krzysztof Kozlowski --- drivers/crypto/s5p-sss.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/s5p-sss.c b/drivers/cry

[PATCH 3/3] crypto: s5p-sss - consistently use local 'dev' variable in probe()

2021-04-16 Thread Krzysztof Kozlowski
For code readability, the probe() function uses 'dev' variable instead of '&pdev->dev', so update remaining places. Signed-off-by: Krzysztof Kozlowski --- drivers/crypto/s5p-sss.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5

[PATCH 1/1 v9] use crc32 instead of md5 for hibernation e820 integrity check

2021-04-16 Thread Chris von Recklinghausen
Hibernation fails on a system in fips mode because md5 is used for the e820 integrity check and is not available. Use crc32 instead. The check is intended to detect whether the E820 memory map provided by the firmware after cold boot unexpectedly differs from the one that was in use when the hiber

[PATCH 2/2] fsverity: relax build time dependency on CRYPTO_SHA256

2021-04-16 Thread Ard Biesheuvel
CONFIG_CRYPTO_SHA256 denotes the generic C implementation of the SHA-256 shash algorithm, which is selected as the default crypto shash provider for fsverity. However, fsverity has no strict link time dependency, and the same shash could be exposed by an optimized implementation, and arm64 has a nu

[PATCH 1/2] fscrypt: relax Kconfig dependencies for crypto API algorithms

2021-04-16 Thread Ard Biesheuvel
Even if FS encryption has strict functional dependencies on various crypto algorithms and chaining modes. those dependencies could potentially be satisified by other implementations than the generic ones, and no link time dependency exists on the 'depends on' claused defined by CONFIG_FS_ENCRYPTION

[PATCH 0/2] relax crypto Kconfig dependencies for fsverity/fscrypt

2021-04-16 Thread Ard Biesheuvel
Relax 'select' dependencies to 'imply' for crypto algorithms that are fulfilled only at runtime, and which may be implemented by other drivers than the generic ones implemented in C. This permits, e.g., arm64 builds to omit the generic CRYPTO_SHA256 and CRYPTO_AES drivers, both of which are superse