On 4/28/2015 2:50 AM, Martin K. Petersen wrote:
"Sagi" == Sagi Grimberg writes:
Sagi> The problem is that the HBA does not have the write_same
Sagi> functionality you introduce here, i.e. generate multiple same
Sagi> protection fields for a single data block.
Adding support to DIX would be pr
In the test manager, there are a number of if-statements with expressions of
the form !x == y that incur warnings with gcc-5 of the following form:
../crypto/testmgr.c: In function '__test_aead':
../crypto/testmgr.c:523:12: warning: logical not is only applied to the left
hand side of comparison
In testmgr, struct pcomp_testvec takes a non-const 'params' field, which is
pointed to a const deflate_comp_params or deflate_decomp_params object. With
gcc-5 this incurs the following warnings:
In file included from ../crypto/testmgr.c:44:0:
../crypto/testmgr.h:28736:13: warning: initialization
In commit 0b053c951829 ("lib: memzero_explicit: use barrier instead
of OPTIMIZER_HIDE_VAR"), we made memzero_explicit() more robust in
case LTO would decide to inline memzero_explicit() and eventually
find out it could be elimiated as dead store.
While using barrier() works well for the case of gc
On Sat, 2015-04-25 at 23:33 +0900, Akinobu Mita wrote:
> This introduces crc_t10dif_update() which enables to calculate CRC
> for a block which straddles multiple SG elements by calling multiple
> times.
>
> Signed-off-by: Akinobu Mita
> Cc: Tim Chen
> Cc: Herbert Xu
> Cc: "David S. Miller"
>
Herbert, David,
Any comment on the crypto driver implementation ?
I've had several reviews focused on:
1/ splitting the patch series into smaller subsets
2/ allowing for smoother transition from the old driver to the new one
I'll address (or have addressed) all of these comments, but I'd like to
> "Sagi" == Sagi Grimberg writes:
Sagi,
Sagi> I thought that WRITE_SAME with DIX would include PI for the block
Sagi> that is being sent over the wire, the initiator and target HBAs
Sagi> will verify the single block integrity and the target backend will
Sagi> expand the PI for the number of
> "Tim" == Tim Chen writes:
Tim> There are a lot of duplicated code between crc_t10dif_update and
Tim> crc_t10dif. The only difference is for the update function we
Tim> import the crc value. I will prefer that we consolidate the code
Tim> into a local inline function that crc_t10dif_update
Am Dienstag, 28. April 2015, 17:22:20 schrieb Daniel Borkmann:
Hi Daniel,
>In commit 0b053c951829 ("lib: memzero_explicit: use barrier instead
>of OPTIMIZER_HIDE_VAR"), we made memzero_explicit() more robust in
>case LTO would decide to inline memzero_explicit() and eventually
>find out it could
2015-04-29 2:38 GMT+09:00 Tim Chen :
> There are a lot of duplicated code between crc_t10dif_update and
> crc_t10dif. The only difference is for the update function
> we import the crc value. I will prefer that we consolidate the code
> into a local inline function that crc_t10dif_update and
> cr
On Tue, Apr 28, 2015 at 10:38:36AM -0700, Tim Chen wrote:
>
> + if (update) {
> + err = crypto_shash_import(&desc.shash, &crc);
> + BUG_ON(err);
You don't even have to make this conditional. Just always do
the import since it's just doing a memcpy anyway.
Che
11 matches
Mail list logo