RE: [PATCH v2 1/3] mm: Introduce page_size()

2019-09-21 Thread Weiny, Ira
> On Fri, Sep 20, 2019 at 04:28:48PM -0700, Andrew Morton wrote: > > On Tue, 23 Jul 2019 09:02:48 -0700 Matthew Wilcox > wrote: > > > > > On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > > > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > > > > b/drivers/crypto/chelsio/cht

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-09-20 Thread Matthew Wilcox
On Fri, Sep 20, 2019 at 04:28:48PM -0700, Andrew Morton wrote: > On Tue, 23 Jul 2019 09:02:48 -0700 Matthew Wilcox wrote: > > > On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > > > b/drivers/crypto/chelsio/chtls/chtls_io.

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-09-20 Thread Andrew Morton
On Tue, 23 Jul 2019 09:02:48 -0700 Matthew Wilcox wrote: > On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > > b/drivers/crypto/chelsio/chtls/chtls_io.c > > > index 551bca6fef24..925be5942895 100644 > > > --- a/drivers/crypt

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Tue, Jul 23, 2019 at 01:44:16PM -0700, Ira Weiny wrote: > > > Side note: why 2 checks for !page? > > > > Because page is assigned to after the first check ... > > Ah yea duh! Sorry it is a bit hard to follow. This is one of those users who really wants the VM to fall back automatically to an

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Ira Weiny
On Tue, Jul 23, 2019 at 11:14:13AM -0700, Matthew Wilcox wrote: > On Tue, Jul 23, 2019 at 10:58:38AM -0700, Ira Weiny wrote: > > > @@ -1092,7 +1092,7 @@ int chtls_sendmsg(struct sock *sk, struct msghdr > > > *msg, size_t size) > > > if (page && off == pg_size) { > > >

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Tue, Jul 23, 2019 at 10:58:38AM -0700, Ira Weiny wrote: > > @@ -1092,7 +1092,7 @@ int chtls_sendmsg(struct sock *sk, struct msghdr > > *msg, size_t size) > > if (page && off == pg_size) { > > put_page(page); > > TCP_PAG

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Ira Weiny
On Tue, Jul 23, 2019 at 09:02:48AM -0700, Matthew Wilcox wrote: > On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > > b/drivers/crypto/chelsio/chtls/chtls_io.c > > > index 551bca6fef24..925be5942895 100644 > > > --- a/drivers/

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > b/drivers/crypto/chelsio/chtls/chtls_io.c > > index 551bca6fef24..925be5942895 100644 > > --- a/drivers/crypto/chelsio/chtls/chtls_io.c > > +++ b/drivers/crypto/chelsio/chtls/cht