Hi Linus,
Could you apply this, please? There shouldn't be any functional change,
rather it's a switch to using combined bit-barrier ops and lesser barriers.
A better way to do this might be to provide set_bit_release(), but the end
result would be much the same.
Thanks,
David
---
From: Herbert
On Mon, May 12, 2025 at 01:01:50PM +0100, David Howells wrote:
>
> I can do unless Herbert wants to pass it through his tree?
I have no desire to do that :)
Thanks,
--
Email: Herbert Xu
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt
Jarkko Sakkinen wrote:
> > Acked-by: David Howells
>
> Reviewed-by: Jarkko Sakkinen
>
> David, are you going to pick this?
I can do unless Herbert wants to pass it through his tree?
David
On Mon, May 12, 2025 at 10:19:14AM +0100, David Howells wrote:
> Herbert Xu wrote:
>
> > Invert the FINAL_PUT bit so that test_bit_acquire and clear_bit_unlock
> > can be used instead of smp_mb.
> >
> > Signed-off-by: Herbert Xu
>
> Acked-by: David Howells
Reviewed-by: Jarkko Sakkinen
Davi
Herbert Xu wrote:
> Invert the FINAL_PUT bit so that test_bit_acquire and clear_bit_unlock
> can be used instead of smp_mb.
>
> Signed-off-by: Herbert Xu
Acked-by: David Howells
On Fri, May 09, 2025 at 05:34:09PM +0800, kernel test robot wrote:
>
> our bot applied this patch directly upon v6.15-rc5. could you let us know if
> this is a correct appliment?
Yes it is correct.
The patch was buggy, the test_bit_acquire should've been inverted too:
---8<---
Invert the FINAL_
this appliement.
kernel test robot noticed "refcount_t:underflow;use-after-free" on:
commit: a78cdfa4388ab9b210c804b92453f14bbe199cbf ("[v2 PATCH] KEYS: Invert
FINAL_PUT bit")
url:
https://github.com/intel-lab-lkp/linux/commits/Herbert-Xu/KEYS-Invert-FINAL_PUT-bit/2025050
On Sun, May 04, 2025 at 08:44:13AM +0100, David Howells wrote:
>
> You need __set_bit() or 1< Also, don't really like the name, but that's just bikeshedding. I think I'd
> lean more to your initial suggestion of KEY_FLAG_ALIVE.
I was going to do that but there is already a flag called
KEY_FLAG_D
Herbert Xu wrote:
> + key->flags |= KEY_FLAG_DONT_GC_YET;
You need __set_bit() or 1<
On Sun, May 04, 2025 at 08:35:57AM +0800, Herbert Xu wrote:
>
> Or even better, reverse the FINAL_PUT bit and call it ALIVE, so
> that you can use test_bit_acquire and clear_bit_unlock.
Something like:
---8<---
Invert the FINAL_PUT bit so that test_bit_acquire and clear_bit_unlock
can be used in
10 matches
Mail list logo