Re: [RFC] MAINTAINERS tag for cleanup robot

2020-11-22 Thread Matthew Wilcox
On Sun, Nov 22, 2020 at 06:46:46AM -0800, Tom Rix wrote: > > On 11/21/20 7:23 PM, Matthew Wilcox wrote: > > On Sat, Nov 21, 2020 at 08:50:58AM -0800, t...@redhat.com wrote: > >> The fixer review is > >> https://reviews.llvm.org/D91789 > >> > >> A

Re: [RFC] MAINTAINERS tag for cleanup robot

2020-11-21 Thread Matthew Wilcox
On Sat, Nov 21, 2020 at 08:50:58AM -0800, t...@redhat.com wrote: > The fixer review is > https://reviews.llvm.org/D91789 > > A run over allyesconfig for x86_64 finds 62 issues, 5 are false positives. > The false positives are caused by macros passed to other macros and by > some macro expansions t

Re: [Ocfs2-devel] [RFC] treewide: cleanup unreachable breaks

2020-10-18 Thread Matthew Wilcox
On Sun, Oct 18, 2020 at 12:13:35PM -0700, James Bottomley wrote: > On Sun, 2020-10-18 at 19:59 +0100, Matthew Wilcox wrote: > > On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > > > clang has a number of useful, new warnings see > > > https:

Re: [Ocfs2-devel] [RFC] treewide: cleanup unreachable breaks

2020-10-18 Thread Matthew Wilcox
On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > clang has a number of useful, new warnings see > https://urldefense.com/v3/__https://clang.llvm.org/docs/DiagnosticsReference.html__;!!GqivPVa7Brio!Krxz78O3RKcB9JBMVo_F98FupVhj_jxX60ddN6tKGEbv_cnooXc1nnBmchm-e_O9ieGnyQ$ > Please

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 01:31:57PM +0200, Michal Hocko wrote: > On Wed 17-06-20 04:08:20, Matthew Wilcox wrote: > > If you call vfree() under > > a spinlock, you're in trouble. in_atomic() only knows if we hold a > > spinlock for CONFIG_PREEMPT, so it's not safe

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 09:12:12AM +0200, Michal Hocko wrote: > On Tue 16-06-20 17:37:11, Matthew Wilcox wrote: > > Not just performance critical, but correctness critical. Since kvfree() > > may allocate from the vmalloc allocator, I really think that kvfree() > > sh

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 01:01:30AM +0200, David Sterba wrote: > On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: > > > v4: > > > - Break out the memzero_explicit() change as suggested by Dan Carpenter > > > so that it can

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread Matthew Wilcox
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > To this larger audience and last week without reply: > https://lore.kernel.org/lkml/573b3fbd5927c643920e1364230c296b23e7584d.ca...@perches.com/ > > Are there _any_ fastpath uses of kfree or vfree? I worked on adding a 'free' a couple

Re: BUG: sleeping function called from invalid context in crypto_drop_spawn

2020-06-04 Thread Matthew Wilcox
On Thu, Jun 04, 2020 at 05:40:31PM -0700, Eric Biggers wrote: > +Cc linux-crypto. crypto_free_shash() is being called in atomic context; > perhaps that should be allowed? kfree() can be called in atomic context. Although vfree() cannot (which i personally hate ...) > On Thu, Jun 04, 2020 at 05:

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-09-20 Thread Matthew Wilcox
On Fri, Sep 20, 2019 at 04:28:48PM -0700, Andrew Morton wrote: > On Tue, 23 Jul 2019 09:02:48 -0700 Matthew Wilcox wrote: > > > On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > >

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Tue, Jul 23, 2019 at 01:44:16PM -0700, Ira Weiny wrote: > > > Side note: why 2 checks for !page? > > > > Because page is assigned to after the first check ... > > Ah yea duh! Sorry it is a bit hard to follow. This is one of those users who really wants the VM to fall back automatically to an

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Tue, Jul 23, 2019 at 10:58:38AM -0700, Ira Weiny wrote: > > @@ -1092,7 +1092,7 @@ int chtls_sendmsg(struct sock *sk, struct msghdr > > *msg, size_t size) > > if (page && off == pg_size) { > > put_page(page); > > TCP_PAG

Re: [PATCH v2 1/3] mm: Introduce page_size()

2019-07-23 Thread Matthew Wilcox
On Mon, Jul 22, 2019 at 05:43:07PM -0700, Ira Weiny wrote: > > diff --git a/drivers/crypto/chelsio/chtls/chtls_io.c > > b/drivers/crypto/chelsio/chtls/chtls_io.c > > index 551bca6fef24..925be5942895 100644 > > --- a/drivers/crypto/chelsio/chtls/chtls_io.c > > +++ b/drivers/crypto/chelsio/chtls/cht