[PATCH 1/2] crypto: hisilicon/qm - remove sizeof(char)

2025-05-03 Thread Ethan Carter Edwards
`sizeof(char)` evaluates to 1. Remove the churn. Signed-off-by: Ethan Carter Edwards --- drivers/crypto/hisilicon/qm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/hisilicon/qm.c b/drivers/crypto/hisilicon/qm.c index

[PATCH 0/2] crypto: hisilicon/qm - memory allocation cleanups

2025-05-03 Thread Ethan Carter Edwards
This series contains two small cleanups to improve code quality and readability. One removes a sizeof(char) piece of code (because it evaluates to 1 anyways) and one switches to the helper function devm_kcalloc. Signed-off-by: Ethan Carter Edwards --- Ethan Carter Edwards (2): crypto

[PATCH 2/2] crypto: hisilicon/qm - replace devm_kzalloc with devm_kcalloc

2025-05-03 Thread Ethan Carter Edwards
Replace devm_kzalloc that has an internal multiplication with devm_kcalloc to improve code readability and safety from overflows. Signed-off-by: Ethan Carter Edwards --- drivers/crypto/hisilicon/qm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/hisilicon

[PATCH] crypto: axis/artpec6: change from kzalloc to kcalloc in artpec6_crypto_probe()

2025-03-08 Thread Ethan Carter Edwards
/linux/issues/162 [1] Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments Signed-off-by: Ethan Carter Edwards --- drivers/crypto/axis/artpec6_crypto.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers