On Wed, 26 Aug 2020 at 14:10, Herbert Xu wrote:
> On Wed, Aug 26, 2020 at 01:59:53PM +0200, Ard Biesheuvel wrote:
> > On Wed, 26 Aug 2020 at 13:50, Herbert Xu
> > wrote:
> > >
> > > On Wed, Aug 26, 2020 at 12:40:14PM +0200, Ard Biesheuvel wrote:
> > > >
> > > > It would be helpful if someone cou
HI,
On 11 August 2017 at 02:48, Mat Martineau
wrote:
> The last round of reviews for AF_ALG akcipher left off at an impasse around
> a year ago: the consensus was that hardware key support was needed, but that
> requirement was in conflict with the "always have a software fallback" rule
> for the
Hi Stephan,
On 16 June 2016 at 17:38, Stephan Mueller wrote:
>> This isn't an issue with AF_ALG, I should have changed the subject
>> line perhaps. In this case it's an inconsistency between some
>> implementations and the documentation (header comment). It affects
>> users accessing the cipher
Hi Stephan,
On 16 June 2016 at 10:05, Stephan Mueller wrote:
> Am Dienstag, 14. Juni 2016, 09:42:34 schrieb Andrew Zaborowski:
>
> Hi Andrew,
>
>> >
>> > I think we have agreed on dropping the length enforcement at the interface
>> > level.
>>
>&
Hi Stephan,
On 14 June 2016 at 07:12, Stephan Mueller wrote:
> Am Dienstag, 14. Juni 2016, 00:16:11 schrieb Andrew Zaborowski:
>> On 8 June 2016 at 21:14, Mat Martineau
>>
>> wrote:
>> > On Wed, 8 Jun 2016, Stephan Mueller wrote:
>> >> What is your
Hi,
On 8 June 2016 at 21:14, Mat Martineau
wrote:
> On Wed, 8 Jun 2016, Stephan Mueller wrote:
>> What is your concern?
> Userspace must allocate larger buffers than it knows are necessary for
> expected results.
>
> It looks like the software rsa implementation handles shorter output buffers
> o
Hi David,
On 23 February 2016 at 11:55, David Howells wrote:
> Andrew Zaborowski wrote:
>
>> AIUI Tadeusz is proposing adding the hashing as a new feature. Note
>> though that the hash paremeter won't make sense for the encrypt,
>> decrypt or verify operatio
Hi,
On 22 February 2016 at 23:28, David Howells wrote:
> Tadeusz Struk wrote:
>
>> I wonder if this should be merged with the crypto/rsa-pkcs1pad.c template
>> that we already have. Looks like the two do the same padding now.
I think that'd be a good thing to do.
>> Should we merge then and pa
Avoid the s390 compile "warning: 'pkcs1pad_encrypt_sign_complete'
uses dynamic stack allocation" reported by kbuild test robot. Don't
use a flat zero-filled buffer, instead zero the contents of the SGL.
Signed-off-by: Andrew Zaborowski
---
c
ertificate work in the kernel or the userspace, and I also hear
that it is likely implemented by hardware RSA in which case hardware
implementations of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
v2: rename rsa-padding.c to rsa-pkcs1pad.c,
use a memset instead
Add a struct akcipher_instance and struct akcipher_spawn similar to
how AEAD declares them and the macros for converting to/from
crypto_instance/crypto_spawn. Also add register functions to
avoid exposing crypto_akcipher_type.
Signed-off-by: Andrew Zaborowski
---
v2: no changes since v1
v3
ertificate work in the kernel or the userspace, and I also hear
that it is likely implemented by hardware RSA in which case hardware
implementations of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
v2: rename rsa-padding.c to rsa-pkcs1pad.c,
use a memset instead
Add a struct akcipher_instance and struct akcipher_spawn similar to
how AEAD declares them and the macros for converting to/from
crypto_instance/crypto_spawn. Also add register functions to
avoid exposing crypto_akcipher_type.
Signed-off-by: Andrew Zaborowski
---
v2: no changes since v1
v3
Add a struct akcipher_instance and struct akcipher_spawn similar to
how AEAD declares them and the macros for converting to/from
crypto_instance/crypto_spawn. Also add register functions to
avoid exposing crypto_akcipher_type.
Signed-off-by: Andrew Zaborowski
---
v2: no changes since v1
v3
ertificate work in the kernel or the userspace, and I also hear
that it is likely implemented by hardware RSA in which case hardware
implementations of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
v2: rename rsa-padding.c to rsa-pkcs1pad.c,
use a memset instead
obtained more easily through crypto_akcipher_maxsize
change the operations to only require as big a buffer as actually needed
if the caller has that information. The semantics for request->dst_len
don't change.
Signed-off-by: Andrew Zaborowski
---
No changes since v1
---
crypto/rs
size needed and return -EOVERFLOW to signal when buffer too short.
Signed-off-by: Andrew Zaborowski
---
No changes since v1
---
lib/mpi/mpicoder.c | 21 +
1 file changed, 17 insertions(+), 4 deletions(-)
diff --git a/lib/mpi/mpicoder.c b/lib/mpi/mpicoder.c
index c7e0a70..07
ertificate work in the kernel or the userspace, and I also hear
that it is likely implemented by hardware RSA in which case hardware
implementations of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
v2: rename rsa-padding.c to rsa-pkcs1pad.c,
use a memset instead
Add a struct akcipher_instance and struct akcipher_spawn similar to
how AEAD declares them and the macros for converting to/from
crypto_instance/crypto_spawn. Also add register functions to
avoid exposing crypto_akcipher_type.
Signed-off-by: Andrew Zaborowski
---
v2: no changes since v1
v3
Signed-off-by: Andrew Zaborowski
---
These are some notes about the template structs that can take some
head-scratching to figure out from the code. Please check that this is
the current intended use.
---
Documentation/crypto/api-intro.txt | 40 ++
1 file
Expose crypto_akcipher_type like other crypto types are exposed to be
used from outside akcipher.c. Add a struct akcipher_instance similar to
aead_instance with just the right size for an akcipher template
instance, and two macros for converting to/from crypto_instance.
Signed-off-by: Andrew
ertificate work in the kernel or the userspace, and I also hear
that it is likely implemented by hardware RSA in which case hardware
implementations of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
v2: rename rsa-padding.c to rsa-pkcs1pad.c,
use a memset instead
obtained more easily through crypto_akcipher_maxsize
change the operations to only require as big a buffer as actually needed
if the caller has that information. The semantics for request->dst_len
don't change.
Signed-off-by: Andrew Zaborowski
---
No changes since v1
---
crypto/rs
size needed and return -EOVERFLOW to signal when buffer too short.
Signed-off-by: Andrew Zaborowski
---
No changes since v1
---
lib/mpi/mpicoder.c | 21 +
1 file changed, 17 insertions(+), 4 deletions(-)
diff --git a/lib/mpi/mpicoder.c b/lib/mpi/mpicoder.c
index c7e0a70..07
_type like
other crypto types are exposed to be used from outside modules.
Signed-off-by: Andrew Zaborowski
---
crypto/akcipher.c | 16 +++-
include/crypto/algapi.h | 1 +
2 files changed, 16 insertions(+), 1 deletion(-)
diff --git a/crypto/akcipher.c b/crypto/akcipher.c
obtained more easily through crypto_akcipher_maxsize
change the operations to only require as big a buffer as actually needed
if the caller has that information. The semantics for request->dst_len
don't change.
Signed-off-by: Andrew Zaborowski
---
crypto/rsa.c | 24 ---
ertificate work in the kernel or the userspace, and also I hear
that it is likely implemented by hardware RSA in which case an
implementation of the whole of pkcs1pad(rsa) can be provided.
Signed-off-by: Andrew Zaborowski
---
crypto/Makefile | 1 +
crypto/rsa-pkcs1pad.c
size needed and return -EOVERFLOW to signal when buffer too short.
Signed-off-by: Andrew Zaborowski
---
lib/mpi/mpicoder.c | 21 +
1 file changed, 17 insertions(+), 4 deletions(-)
diff --git a/lib/mpi/mpicoder.c b/lib/mpi/mpicoder.c
index c7e0a70..074d2df 100644
--- a/li
ertificate work in the kernel or the userspace, and also I hear
that it is likely implemented by hardware RSA in which case an
implementation of the whole "pkcs1pad(rsa)" can be provided.
Signed-off-by: Andrew Zaborowski
---
crypto/Makefile | 1 +
crypto/rsa-padd
_type like
other crypto types are exposed to be used from outside modules.
Signed-off-by: Andrew Zaborowski
---
crypto/akcipher.c | 16 +++-
include/crypto/algapi.h | 1 +
2 files changed, 16 insertions(+), 1 deletion(-)
diff --git a/crypto/akcipher.c b/crypto/akcipher.c
obtained more easily through crypto_akcipher_maxsize
change the operations to only require as big a buffer as actually needed
if the caller has that information. The semantics for request->dst_len
don't change.
Signed-off-by: Andrew Zaborowski
---
crypto/rsa.c | 24 ---
size needed and return -EOVERFLOW to signal when buffer too short.
Signed-off-by: Andrew Zaborowski
---
lib/mpi/mpicoder.c | 21 +
1 file changed, 17 insertions(+), 4 deletions(-)
diff --git a/lib/mpi/mpicoder.c b/lib/mpi/mpicoder.c
index c7e0a70..074d2df 100644
--- a/li
t;compat" in their implementations for
shash or blkcipher. If they are to be added for akcipher it should
probably be a separate patch.
Signed-off-by: Andrew Zaborowski
---
crypto/Makefile | 1 +
crypto/akcipher.c | 16 +-
crypto/rsa-p
33 matches
Mail list logo