Re: [PATCH] crypto: using size_add() for kmalloc()

2025-04-20 Thread Su Hui
On 2025/4/21 13:51, Su Hui wrote: It's safer to use size_add() to replace open-coded aithmetic in allocator arguments, because size_add() can prevent possible overflow problem. Signed-off-by: Su Hui --- include/crypto/aead.h | 3 ++- include/crypto/akcipher.h | 4 +++- include/crypto/kp

[PATCH] crypto: using size_add() for kmalloc()

2025-04-20 Thread Su Hui
It's safer to use size_add() to replace open-coded aithmetic in allocator arguments, because size_add() can prevent possible overflow problem. Signed-off-by: Su Hui --- include/crypto/aead.h | 3 ++- include/crypto/akcipher.h | 4 +++- include/crypto/kpp.h | 3 ++- 3 files changed, 7 in

Re: [PATCH v8 0/5] Add Loongson Security Engine chip driver

2025-04-20 Thread Huacai Chen
Hi, Qunqin, On Fri, Apr 18, 2025 at 5:33 PM Qunqin Zhao wrote: > > The Loongson Security Engine chip supports RNG, SM2, SM3 and SM4 > accelerator engines. Each engine have its own DMA buffer provided > by the controller. The kernel cannot directly send commands to the > engine and must first send