Re: [PATCH V2 4/4] crypto: Add Xilinx AES driver

2019-09-01 Thread Corentin Labbe
On Sun, Sep 01, 2019 at 07:24:58PM +0530, Kalyani Akula wrote: > This patch adds AES driver support for the Xilinx > ZynqMP SoC. > > Signed-off-by: Kalyani Akula > --- Hello I have some comment below > drivers/crypto/Kconfig | 11 ++ > drivers/crypto/Makefile | 1 + > driv

Re: [RFC/RFT v4 5/5] KEYS: trusted: Add generic trusted keys framework

2019-09-01 Thread Sumit Garg
On Fri, 30 Aug 2019 at 22:54, Jarkko Sakkinen wrote: > > On Fri, Aug 30, 2019 at 08:20:31PM +0300, Jarkko Sakkinen wrote: > > On Fri, Aug 30, 2019 at 02:49:31PM +0530, Sumit Garg wrote: > > > Any comments/feedback on this patch before I send next version of TEE > > > patch-set with this patch incl

[PATCH 7/9] crypto: n2 - Rename arrays to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename the sha*_init arrays to n2_sha*_init so that they do not conflict with the functions declared in crypto/sha256.h. Also rename md5_init to n2_md5_init for consistency. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- drivers/cryp

[PATCH 8/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h

2019-09-01 Thread Hans de Goede
The generic sha256 implementation from lib/crypto/sha256.c uses data structs defined in crypto/sha.h, so lets move the function prototypes there too. Signed-off-by: Hans de Goede --- arch/s390/purgatory/purgatory.c | 2 +- arch/x86/purgatory/purgatory.c | 2 +- crypto/sha256_generic.c

[PATCH 9/9] crypto: sha256 - Remove sha256/224_init code duplication

2019-09-01 Thread Hans de Goede
lib/crypto/sha256.c and include/crypto/sha256_base.h define 99% identical functions to init a sha256_state struct for sha224 or sha256 use. This commit moves the functions from lib/crypto/sha256.c to include/crypto/sha.h (making them static inline) and makes the sha224/256_base_init static inline

[PATCH 6/9] crypto: chelsio - Rename arrays to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename the sha*_init arrays to chcr_sha*_init so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- drivers/crypto/chelsio/chcr_algo.h | 20 ++-- 1

[PATCH 5/9] crypto: ccree - Rename arrays to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename the algo_init arrays to cc_algo_init so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- drivers/crypto/ccree/cc_hash.c | 153 +

[PATCH 4/9] crypto: x86 - Rename functions to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename static / file-local functions so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- arch/x86/crypto/sha256_ssse3_glue.c | 12 ++-- 1 file changed, 6

[PATCH 2/9] crypto: arm64 - Rename functions to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename static / file-local functions so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- arch/arm64/crypto/sha256-glue.c | 24 1 file cha

[PATCH 1/9] crypto: arm - Rename functions to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename static / file-local functions so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- arch/arm/crypto/sha256_glue.c | 8 arch/arm/crypto/sha256_

[PATCH 3/9] crypto: s390 - Rename functions to avoid conflict with crypto/sha256.h

2019-09-01 Thread Hans de Goede
Rename static / file-local functions so that they do not conflict with the functions declared in crypto/sha256.h. This is a preparation patch for folding crypto/sha256.h into crypto/sha.h. Signed-off-by: Hans de Goede --- arch/s390/crypto/sha256_s390.c | 8 1 file changed, 4 insertions

[PATCH 0/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h

2019-09-01 Thread Hans de Goede
Hi All, As promised here is a follow-up series to my earlier sha256 series. Note I have only compiled and tested this series on x86_64 !! All changes to architecture specific code on other archs have not even been tested to compile! With that said most of these changes were done using my editor

How to use nonce in DRBG functions.

2019-09-01 Thread Bhat, Jayalakshmi Manjunath
Hi All, I am trying to implement DRBG CAVS test harness function for Linux Kernel crypto DRBG with the following requirements. 1. Derivate function is enabled. 2. prediction resistance is not enabled 3. Entropy input length is 256 4. Nonce lengt

[PATCH V2 0/4] Add Xilinx's ZynqMP AES driver support

2019-09-01 Thread Kalyani Akula
This patch set adds support for - dt-binding docs for Xilinx ZynqMP AES driver - Adds device tree node for ZynqMP AES driver - Adds communication layer support for aes in zynqmp.c - Adds Xilinx ZynqMP driver for AES Algorithm V2 Changes : - Converted RFC PATCH to PATCH - Removed ALG_SET_KEY_TYPE t

[PATCH V2 3/4] firmware: xilinx: Add ZynqMP aes API for AES functionality

2019-09-01 Thread Kalyani Akula
Add ZynqMP firmware AES API to perform encryption/decryption of given data. Signed-off-by: Kalyani Akula --- drivers/firmware/xilinx/zynqmp.c | 23 +++ include/linux/firmware/xlnx-zynqmp.h | 2 ++ 2 files changed, 25 insertions(+) diff --git a/drivers/firmware/xilinx/zy

[PATCH V2 4/4] crypto: Add Xilinx AES driver

2019-09-01 Thread Kalyani Akula
This patch adds AES driver support for the Xilinx ZynqMP SoC. Signed-off-by: Kalyani Akula --- drivers/crypto/Kconfig | 11 ++ drivers/crypto/Makefile | 1 + drivers/crypto/zynqmp-aes-gcm.c | 297 3 files changed, 309 insertions(+) cr

[PATCH V2 2/4] ARM64: zynqmp: Add Xilinix AES node.

2019-09-01 Thread Kalyani Akula
This patch adds a AES DT node for Xilinx ZynqMP SoC. Signed-off-by: Kalyani Akula --- arch/arm64/boot/dts/xilinx/zynqmp.dtsi | 4 1 file changed, 4 insertions(+) diff --git a/arch/arm64/boot/dts/xilinx/zynqmp.dtsi b/arch/arm64/boot/dts/xilinx/zynqmp.dtsi index 9aa6734..b41febc 100644 ---

[PATCH V2 1/4] dt-bindings: crypto: Add bindings for ZynqMP AES driver

2019-09-01 Thread Kalyani Akula
Add documentation to describe Xilinx ZynqMP AES driver bindings. Signed-off-by: Kalyani Akula --- Documentation/devicetree/bindings/crypto/xlnx,zynqmp-aes.txt | 12 1 file changed, 12 insertions(+) create mode 100644 Documentation/devicetree/bindings/crypto/xlnx,zynqmp-aes.txt dif