From: Atul Gupta
Date: Thu, 9 Nov 2017 16:59:01 +0530
> register xfrmdev_ops callbacks, Send IPsec tunneled data
> to HW for inline processing.
> The driver use hardware crypto accelerator to encrypt and
> generate ICV for the transmitted packet in Inline mode.
>
> Signed-off-by: Atul Gupta
>
These cleanups look nice. Thanks.
I hope you do a mass remove of likely/unlikely in a patch soon.
Whenever, I see one of those in a + line I always have to remind myself
that you're planning to do it in a later patch.
regards,
dan carpenter
Hi,
On 11/12/2017 06:26 PM, Horia Geantă wrote:
-sg[0] - (1 entry) reserved for associated data, filled outside
sg_init_aead()
Let's fill the sg[0] with aad inside sg_init_aead()!
Cheers,
ta
Hi,
On 10/10/2017 01:21 PM, Robert Baronescu wrote:
In case buffer length is a multiple of PAGE_SIZE,
the S/G table is incorrectly generated.
Fix this by handling buflen = k * PAGE_SIZE separately.
Signed-off-by: Robert Baronescu
---
crypto/tcrypt.c | 6 --
1 file changed, 4 insertions(
On Mon, 2017-11-13 at 14:45 +, Gilad Ben-Yossef wrote:
> Remove uneeded cast from writel_relaxed parameter.
[]
> diff --git a/drivers/staging/ccree/ssi_request_mgr.c
> b/drivers/staging/ccree/ssi_request_mgr.c
[]
> @@ -167,13 +167,13 @@ static inline void enqueue_seq(
> int i;
>
>
On Mon, 13 Nov 2017 09:44:06 +
Radu Andrei Alexe wrote:
> On 11/10/2017 6:44 PM, Kim Phillips wrote:
> > On Fri, 10 Nov 2017 08:02:01 +
> > Radu Andrei Alexe wrote:
> >
> >> On 11/9/2017 6:34 PM, Kim Phillips wrote:
> >>> On Thu, 9 Nov 2017 11:54:13 +
> >>> Radu Andrei Alexe wrote:
On Mon, 13 Nov 2017 08:32:24 +
Horia Geantă wrote:
> On 11/10/2017 6:44 PM, Kim Phillips wrote:
> > On Fri, 10 Nov 2017 08:02:01 +
> > Radu Andrei Alexe wrote:
> [snip]>> 2. I wanted this driver to be tracked by the dma engine team.
> They have
> >> the right expertise to provide adequat
Attn:
I am wondering why You haven't respond to my email for some days now.
reference to my client's contract balance payment of (11.7M,USD)
Kindly get back to me for more details.
Best Regards
Amos Kalonzo
Allocation by instance is preferred to allocation by type.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_sram_mgr.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ccree/ssi_sram_mgr.c
b/drivers/staging/ccree/ssi_sram_mgr.c
index 2263433..b714
Fix a bunch of comment typos.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_hash.c| 2 +-
drivers/staging/ccree/ssi_hash.h| 2 +-
drivers/staging/ccree/ssi_ivgen.c | 2 +-
drivers/staging/ccree/ssi_request_mgr.c | 2 +-
drivers/staging/ccree/ssi_request_mgr.
Move logical continuations to first line for readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/drivers/staging/ccree/ssi_buffer_mgr.c
index
Remove unnecessary parentheses in if statements across the driver.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 36 +-
drivers/staging/ccree/ssi_buffer_mgr.c | 28 +-
drivers/staging/ccree/ssi_cipher.c |
The driver was using open coded MIN/MAX macros to
compute fixed defines. Remove them and use bigger
value always instead.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.h | 2 +-
drivers/staging/ccree/ssi_driver.h | 3 ---
drivers/staging/ccree/ssi_hash.c | 2 +-
3 files
Remove uneeded empty lines that crept in to code.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 1 -
drivers/staging/ccree/ssi_hash.c | 1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/drivers/staging/ccree/ssi_buff
The driver was issuing a write memory barrier per each
HW descriptor written but these descriptors are written
in groups and we really only need one per group.
White at it, document memory barrier reason.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 13 +
Document spinlock usage to protect against concurrent
access to HW register which must occur a single
request at a time.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/staging/ccree/ssi_request_mgr.c
b/d
Remove uneeded cast from writel_relaxed parameter.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/ccree/ssi_request_mgr.c
b/drivers/staging/ccree/ssi_request_mgr.c
index
Fix code ident not following the coding style.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_cipher.c | 2 +-
drivers/staging/ccree/ssi_sysfs.c | 6 --
2 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ccree/ssi_cipher.c
b/drivers/staging/ccree/
Make help string static const
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_sysfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ccree/ssi_sysfs.c
b/drivers/staging/ccree/ssi_sysfs.c
index 5d39f15..8d50382 100644
--- a/drivers/staging/ccree
After commit b2b49ccbdd54
("PM: Kconfig: Set PM_RUNTIME if PM_SLEEP is selected")
PM_RUNTIME is always set if PM is set, so #ifdef blocks
depending on CONFIG_PM_RUNTIME may now be changed to depend on
CONFIG_PM.
Replace CONFIG_PM_RUNTIME with CONFIG_PM.
Signed-off-by: Gilad Ben-Yossef
---
drive
The ccree driver did not adhere to the kernel max 80 chars per line limit
making the code hard to follow. Fix this by breaking long lines and
in some cases, moving comments to a separate line from code.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c| 152 +++
Remove no longer definitions of enums and forward declaration of functions
dealing with sysfs interface of the long removed ccree cycle counter.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_sysfs.h | 23 ---
1 file changed, 23 deletions(-)
diff --git a/drive
Remove unneeded wrapper function to simplify code.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_hash.c | 21 ++---
1 file changed, 6 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/staging/ccree/ssi_hash.c
index afdc44e..a2
Refactor the queue handling loop using local variables for better
code readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 16 +++-
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/ccree/ssi_request_mgr.c
b/drivers/
Rename the insanely long ssi_ahash_get_larval_digest_sram_addr() func
to cc_larval_digest_addr() for better code readability
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_aead.c | 7 +++
drivers/staging/ccree/ssi_hash.c | 13 ++---
drivers/staging/ccree/ssi_hash.h |
Rename the too long SSI_MAX_HASH_OPAD_TMP_KEYS_SIZE
to SSI_MAX_OPAD_KEYS_SIZE for better code readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_hash.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/stag
Field monitor_null_cycles of struct drvdata was not being used.
Remove it.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_driver.h | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/ccree/ssi_driver.h
b/drivers/staging/ccree/ssi_driver.h
index 7c266ff..ff9f5aa
When the driver would try to queue commands to the HW FIFO but ran out of
slots it would use msleep as a delay until the FIFO would clear. This is
messy and not accurate.
Replace the msleep with a proper completion on the event of command
completion which should indicate at least one slot is free.
Refactor cc_map_aead_request() to use local vars for addresses
for better readability of code.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 64 +++---
1 file changed, 29 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/ccree
The CC_REG_NAME macro is unused. Drop it.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/cc_hw_queue_defs.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/ccree/cc_hw_queue_defs.h
b/drivers/staging/ccree/cc_hw_queue_defs.h
index 2ae0f65..c5aaa79 100644
--- a/dri
Replace GET_DMA_BUFFER_TYPE with an inline function
variant with type checking.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_buffer_mgr.c | 27 ++-
1 file changed, 18 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/ccree/ssi_buffer_mgr.c
b/dr
Replace open coded register writing loop with a for.
Further simplify code by using a local var to precompute
the register address for readability.
Signed-off-by: Gilad Ben-Yossef
---
drivers/staging/ccree/ssi_request_mgr.c | 16 +---
1 file changed, 9 insertions(+), 7 deletions(-)
Another set of cleanup patches.
This set goes on top of the previous fixes and cleanups patch set
sent to the list.
With this set of patches checkpatch now only reports one false
warning and a warning on device tree string being undocumented.
Gilad Ben-Yossef (24):
staging: ccree: fix typos
Hello Dear...
I know that this message will come to you as a surprise. I hoped that
you will not expose or betray this trust and confident that I am about
to repose on you, my name is M, Shakour Rosarita. I am 19 years old
Girl, female, from Tartu Syria, (never married) 61 kg, white in
complexion,
Hi Herbert,
Can you check if this patchset (removed the AEAD part as you suggested +
libkcapi test OK as suggested by Corentin) can be applied now?
BR
Fabien
On 07/11/17 15:40, Fabien DESSENNE wrote:
>
> On 22/10/17 09:26, Corentin Labbe wrote:
>> On Thu, Oct 19, 2017 at 05:10:30PM +0200, Fab
On 11/10/2017 6:44 PM, Kim Phillips wrote:
> On Fri, 10 Nov 2017 08:02:01 +
> Radu Andrei Alexe wrote:
>
>> On 11/9/2017 6:34 PM, Kim Phillips wrote:
>>> On Thu, 9 Nov 2017 11:54:13 +
>>> Radu Andrei Alexe wrote:
The next patch version will create the platform device dynamically at
On 11/10/2017 6:44 PM, Kim Phillips wrote:
> On Fri, 10 Nov 2017 08:02:01 +
> Radu Andrei Alexe wrote:
[snip]>> 2. I wanted this driver to be tracked by the dma engine team.
They have
>> the right expertise to provide adequate feedback. If all the code was in
>> the crypto directory they woul
37 matches
Mail list logo