[PATCH 2/2] crypto/nx: Do not initialize workmem allocation

2017-09-24 Thread Haren Myneni
[PATCH 2/2] crypto/nx: Do not initialize workmem allocation We are using percpu send window on P9 NX (powerNV) instead of opening / closing per each crypto session. Means txwin is removed from workmem. So we do not need to initialize workmem for each request. Signed-off-by: Haren Myneni --- dri

[PATCH 1/2] crypto/nx: Use percpu send window for NX requests

2017-09-24 Thread Haren Myneni
[PATCH 1/2] crypto/nx: Use percpu send window for NX requests For P9 NX, the send window is opened for each crypto session and closed upon free. But VAS supports 64K windows per chip for all coprocessors including in user space support. So there is a possibility of not getting the window for kerne

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Herbert Xu
On Mon, Sep 25, 2017 at 07:22:26AM +0200, Johannes Berg wrote: > > The code moves to crypto/ though, and I'm not even sure I can vouch for > the Makefile choice there. Thanks, I missed that. I don't think this belongs in crypto. This proposed helper is only useful for wireless so it should stay

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Johannes Berg
On Mon, 2017-09-25 at 12:56 +0800, Herbert Xu wrote: > On Sun, Sep 24, 2017 at 07:42:46PM +0200, Johannes Berg wrote: > > > > Unrelated to this, I'm not sure whose tree this should go through - > > probably Herbert's (or DaveM's with his ACK? not sure if there's a > > crypto tree?) or so? > > Sin

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Herbert Xu
On Sun, Sep 24, 2017 at 07:42:46PM +0200, Johannes Berg wrote: > > Unrelated to this, I'm not sure whose tree this should go through - > probably Herbert's (or DaveM's with his ACK? not sure if there's a > crypto tree?) or so? Since you're just rearranging code invoking the crypto API, rather than

[PATCH 3.18 11/42] [PATCH - RESEND] crypto: AF_ALG - remove SGL terminator indicator when chaining

2017-09-24 Thread Greg Kroah-Hartman
3.18-stable review patch. If anyone has any objections, please let me know. -- From: Stephan Mueller Fixed differently upstream as commit 2d97591ef43d ("crypto: af_alg - consolidation of duplicate code") The SGL is MAX_SGL_ENTS + 1 in size. The last SG entry is used for the c

[PATCH 4.4 27/66] [PATCH - RESEND] crypto: AF_ALG - remove SGL terminator indicator when chaining

2017-09-24 Thread Greg Kroah-Hartman
4.4-stable review patch. If anyone has any objections, please let me know. -- From: Stephan Mueller Fixed differently upstream as commit 2d97591ef43d ("crypto: af_alg - consolidation of duplicate code") The SGL is MAX_SGL_ENTS + 1 in size. The last SG entry is used for the ch

[PATCH 4.9 27/77] [PATCH - RESEND] crypto: AF_ALG - remove SGL terminator indicator when chaining

2017-09-24 Thread Greg Kroah-Hartman
4.9-stable review patch. If anyone has any objections, please let me know. -- From: Stephan Mueller Fixed differently upstream as commit 2d97591ef43d ("crypto: af_alg - consolidation of duplicate code") The SGL is MAX_SGL_ENTS + 1 in size. The last SG entry is used for the ch

[PATCH 4.13 034/109] [PATCH - RESEND] crypto: AF_ALG - remove SGL terminator indicator when chaining

2017-09-24 Thread Greg Kroah-Hartman
4.13-stable review patch. If anyone has any objections, please let me know. -- From: Stephan Mueller Fixed differently upstream as commit 2d97591ef43d ("crypto: af_alg - consolidation of duplicate code") The SGL is MAX_SGL_ENTS + 1 in size. The last SG entry is used for the c

Re: [RFC PATCH 0/2] let the crypto subsystem generate the ecc privkey

2017-09-24 Thread Marcel Holtmann
Hi Tudor, > That Bluetooth SMP knows about the private key is pointless, since the > detection of debug key usage is actually via the public key portion. > With this patch set, the Bluetooth SMP will stop keeping a copy of the > ecdh private key, except when using debug keys. This way we let the >

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Xiang Gao
2017-09-24 13:42 GMT-04:00 Johannes Berg : > On Sun, 2017-09-24 at 13:21 -0400, Xiang Gao wrote: >> >> Do you mean to put more characters each line in the description >> > Huh, sorry, no - my bad. I was thinking of the code, not the > description at all. Oh yes, these indentation do looks ugly. Th

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Johannes Berg
On Sun, 2017-09-24 at 13:21 -0400, Xiang Gao wrote: > > Do you mean to put more characters each line in the description > Huh, sorry, no - my bad. I was thinking of the code, not the description at all. For example here: > -int ieee80211_aes_gcm_encrypt(struct crypto_aead *tfm, u8 *j_0, u8 *aad

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Xiang Gao
2017-09-24 11:05 GMT-04:00 Johannes Berg : > On Sun, 2017-09-24 at 01:40 -0400, Xiang Gao wrote: >> Currently, the aes_ccm.c and aes_gcm.c are almost line by line >> copy of each other. This patch reduce code redundancy by moving >> the code in these two files to crypto/aead_api.c to make it a >> h

Re: [PATCH] mac80211: aead api to reduce redundancy

2017-09-24 Thread Johannes Berg
On Sun, 2017-09-24 at 01:40 -0400, Xiang Gao wrote: > Currently, the aes_ccm.c and aes_gcm.c are almost line by line > copy of each other. This patch reduce code redundancy by moving > the code in these two files to crypto/aead_api.c to make it a > higher level aead api. The aes_ccm.c and aes_gcm.c

Re: [PATCH] staging:ccree Fix avoid externs in .c files

2017-09-24 Thread Gilad Ben-Yossef
On Thu, Sep 21, 2017 at 9:43 AM, Janani Sankara Babu wrote: > This patch solves the warning shown by the checkpatch script > WARNING: externs should be avoided in .c files I'm afraid here too the feedback is the same - you are working on the Linus master tree, therefore you are seeing things that

Re: [PATCH] staging:ccree Fix use BIT macro

2017-09-24 Thread Gilad Ben-Yossef
Hi Janani, On Thu, Sep 21, 2017 at 9:39 AM, Janani Sankara Babu wrote: > This patch is created to solve the following warning shown by the checkpatch > script Warning: Replace all occurences of (1< > Signed-off-by: Janani Sankara Babu Thank you for the patch - unfortunately, such a fix s alread