[PATCH] crypto: nx-sha256/512: respect sg limit bounds when building sg lists

2015-08-07 Thread Jan Stancek
Commit 000851119e80 changed sha256/512 update functions to pass more data to nx_build_sg_list(), which ends with sg list overflows and usually with update functions failing for data larger than max_sg_len * NX_PAGE_SIZE. This happens because: - both "total" and "to_process" are updated, which lead

Re: [PATCH 6/6] scatterlist: use sg_phys()

2015-08-07 Thread Dan Williams
On Fri, Aug 7, 2015 at 9:15 AM, Christoph Hellwig wrote: > From: Dan Williams > > Coccinelle cleanup to replace open coded sg to physical address > translations. This is in preparation for introducing scatterlists that > reference __pfn_t. > > // sg_phys.cocci: convert usage page_to_phys(sg_page

RE

2015-08-07 Thread Info
Contact Mr.Pedro Quezada for your Donation US$ 2 Million Dollars Donation -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

[PATCH 5/5] PCI: Add quirk for Intel DH895xCC VF PCI config erratum

2015-08-07 Thread Tadeusz Struk
The PCI capabilities list for Intel DH895xCC VFs (device id 0x0443) with QuickAssist Technology is prematurely terminated in hardware. Workaround the issue by hard-coding the known expected next capability pointer and saving the PCIE cap into internal buffer. Patch generated against cryptodev-2.6

[PATCH 2/5] crypto: qat - Add support for SRIOV

2015-08-07 Thread Tadeusz Struk
Add code that enables SRIOV on dh895xcc devices. Signed-off-by: Tadeusz Struk --- drivers/crypto/qat/qat_common/Makefile |1 drivers/crypto/qat/qat_common/adf_accel_devices.h | 37 ++ drivers/crypto/qat/qat_common/adf_aer.c|3 drivers/crypto/qat/qat_common/ad

[PATCH 0/5] crypto: qat - Add support for SRIOV

2015-08-07 Thread Tadeusz Struk
The following series adds SRIOV support for qat dh895xcc HW accelerator. First patch moves admin code and hw arbiter code that can be reused by PF and VF to common code in qat/qat_common/ Second patch enables SRIOV support on dh895xcc PF. Third patch adds dh895xcc VF specific code. Fourth patch add

[PATCH 4/5] crypto: qat - Add FW const table

2015-08-07 Thread Tadeusz Struk
Some VF drivers need FW const table, so the PF driver needs to load it. Signed-off-by: Tadeusz Struk --- drivers/crypto/qat/qat_common/adf_admin.c | 107 + 1 file changed, 106 insertions(+), 1 deletion(-) diff --git a/drivers/crypto/qat/qat_common/adf_admin.c b/dri

[PATCH 3/5] crypto: qat - Add qat dh895xcc VF driver

2015-08-07 Thread Tadeusz Struk
Add code specific for the dh895xcc virtual function. Signed-off-by: Tadeusz Struk --- drivers/crypto/qat/Kconfig | 11 + drivers/crypto/qat/Makefile|1 drivers/crypto/qat/qat_dh895xccvf/Makefile |5 .../qat/qat_dh895xccvf/adf_dh

[PATCH 1/5] crypto: qat - Move adf admin and adf hw arbitrer to common code

2015-08-07 Thread Tadeusz Struk
Adf admin and HW arbiter function can be used by dh895xcc specific code well as the new dh895xccvf and future devices so moving them to qat_common so that they can be shared. Signed-off-by: Tadeusz Struk --- drivers/crypto/qat/qat_common/Makefile |2 drivers/crypto/qat/qat_commo

[PATCH 3/6] crypto: replace scatterwalk_sg_chain with sg_chain

2015-08-07 Thread Christoph Hellwig
From: Dan Williams Signed-off-by: Dan Williams [hch: split from a larger patch by Dan] Signed-off-by: Christoph Hellwig --- crypto/algif_skcipher.c | 2 +- crypto/ccm.c | 8 crypto/gcm.c | 4 ++-- drivers/crypto/bfin_crc.c| 3 +-- drivers/c

scatterlist cleanups

2015-08-07 Thread Christoph Hellwig
This series contains various scatterlist cleanups. It makes the chained scatterlist helpers generally available, even if a architecture doesn't allow a DMA mapping for it, and changes two callers to make use of this as well as cleans up various opencoded access to scatterlist internals. A large p

[PATCH 5/6] crypto/omap-sham: remove an open coded access to ->page_link

2015-08-07 Thread Christoph Hellwig
Signed-off-by: Dan Williams [hch: split from a larger patch by Dan] Signed-off-by: Christoph Hellwig --- drivers/crypto/omap-sham.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/omap-sham.c b/drivers/crypto/omap-sham.c index b2024c95..48adb2a 100644 --- a/dri

[PATCH 2/6] target/rd: always chain S/G list

2015-08-07 Thread Christoph Hellwig
The rd sg lists are never passed to hardware, so use S/G chaining unonditionally. Signed-off-by: Christoph Hellwig --- drivers/target/target_core_rd.c | 44 - 1 file changed, 44 deletions(-) diff --git a/drivers/target/target_core_rd.c b/drivers/target/ta

[PATCH 6/6] scatterlist: use sg_phys()

2015-08-07 Thread Christoph Hellwig
From: Dan Williams Coccinelle cleanup to replace open coded sg to physical address translations. This is in preparation for introducing scatterlists that reference __pfn_t. // sg_phys.cocci: convert usage page_to_phys(sg_page(sg)) to sg_phys(sg) // usage: make coccicheck COCCI=sg_phys.cocci MOD

[PATCH 4/6] scatterlist: remove open coded sg_unmark_end instances

2015-08-07 Thread Christoph Hellwig
From: Dan Williams Signed-off-by: Dan Williams [hch: split from a larger patch by Dan] Signed-off-by: Christoph Hellwig --- block/blk-merge.c| 2 +- drivers/mmc/card/queue.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/block/blk-merge.c b/block/blk-merge.c i

[PATCH 1/6] scatterlist: allow limited chaining without ARCH_HAS_SG_CHAIN

2015-08-07 Thread Christoph Hellwig
There are a couple of uses of struct scatterlist that never go to the dma_map_sg() helper and thus don't care about ARCH_HAS_SG_CHAIN which indicates that we can map chained S/G list. The most important one is the crypto code, which currently has to open code a few helpers to always allow chaining

Re: [PATCH v2 05/14] crypto: caam - Change kmalloc to kzalloc to avoid residual data

2015-08-07 Thread Herbert Xu
On Wed, Aug 05, 2015 at 11:28:39AM -0700, Victoria Milhoan wrote: > Since fields must be ORed in to operate correctly using any order of > operations, changed allocations of the combination of extended > descriptor structs + hardware scatterlists to use kzalloc() instead > of kmalloc(), so as to en

Re: [PATCH] crypto: doc - make URL into hyperlink

2015-08-07 Thread Stephan Mueller
Am Donnerstag, 6. August 2015, 14:49:00 schrieb Brian Norris: Hi Brian, >The HTML output works a little nicer that way. > >Signed-off-by: Brian Norris Thank you. Ciao Stephan -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majord...@vger.k

crypto: authencesn - Convert to new AEAD interface

2015-08-07 Thread Herbert Xu
This patch converts authencesn to the new AEAD interface. Signed-off-by: Herbert Xu diff --git a/crypto/authencesn.c b/crypto/authencesn.c index a3da677..c30393e 100644 --- a/crypto/authencesn.c +++ b/crypto/authencesn.c @@ -4,6 +4,7 @@ * * Copyright (C) 2010 secunet Security Networks AG

[PATCH 09/31] crypto: use kmemdup rather than duplicating its implementation

2015-08-07 Thread Andrzej Hajda
The patch was generated using fixed coccinelle semantic patch scripts/coccinelle/api/memdup.cocci [1]. [1]: http://permalink.gmane.org/gmane.linux.kernel/2014320 Signed-off-by: Andrzej Hajda --- crypto/echainiv.c | 7 ++- crypto/seqiv.c| 6 ++ 2 files changed, 4 insertions(+), 9 del

Re: [PATCH 09/31] crypto: use kmemdup rather than duplicating its implementation

2015-08-07 Thread Herbert Xu
On Fri, Aug 07, 2015 at 09:59:15AM +0200, Andrzej Hajda wrote: > The patch was generated using fixed coccinelle semantic patch > scripts/coccinelle/api/memdup.cocci [1]. > > [1]: http://permalink.gmane.org/gmane.linux.kernel/2014320 > > Signed-off-by: Andrzej Hajda Actually I think you've ident

crypto: authencesn - Fix breakage with new ESP code

2015-08-07 Thread Herbert Xu
The ESP code has been updated to generate a completely linear AD SG list. This unfortunately broke authencesn which expects the AD to be divided into at least three parts. This patch fixes it to cope with the new format. Later we will fix it properly to accept arbitrary input and not rely on the

Re: [GIT PULL] ASN.1 fixes

2015-08-07 Thread David Howells
James Morris wrote: > Pulled to my -next branch, but it's too late really for 4.2, for this > class of bugfix. Thanks. That'll do. David -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majord...@vger.kernel.org More majordomo info at htt