On Sat, Jul 10, 2021 at 11:42:28AM -0400, Craig Andrews wrote:
> Gentoo currently has a number of packages required to run a bitcoin node
> in its tree, including:
> * net-libs/libbitcoinconsensus
> * net-p2p/bitcoin-qt
> * net-p2p/bitcoind
>
> In version 0.21.1, bitcoin included a consensus algo
Hey All,
I'm responding again because I saw that I left Luke off of my original
message and I cleaned up my steps a bit.
We talked about this on the irc channel, and several of us feel that you
don't need anything special in the ebuild at all, you can do this via
package.mask and a newsitem.
I s
To update everyone involved in this, please read my last comment on the
pr. Basically, this can be treated like a test version by adding it to
package.mask with an appropriate message then maybe publishing a
newsitem if the maintainer wants it to be known by other users.
William
signature.asc
D
Change the _R0 suffix on these variable names to _ECLASS.
Signed-off-by: William Hubbs
---
eclass/lua-single.eclass | 10 +++---
eclass/lua-utils.eclass | 8
eclass/lua.eclass| 12 +---
3 files changed, 12 insertions(+), 18 deletions(-)
diff --git a/eclass/lua
On Sun, Jul 11, 2021 at 03:53:31PM +0200, Thomas Deutschmann wrote:
> Hi,
>
> TL;DR:
>
> Given that William said in the meanwhile, he sees no future for
> opentmpfiles [1] and that nobody else, including me, is interested in
> stepping up, things have changed.
Add this reference as well if you
On Mon, Jul 12, 2021 at 11:24:42AM +0100, Marek Szuba wrote:
> On 2021-07-10 22:55, William Hubbs wrote:
>
> > Change the _R0 suffix on these variable names to _ECLASS.
>
> Since my question in response to the previous round of this has yet to
> be answered, I repeat: are t
# William Hubbs (2021-07-17)
# Does not build and has multiple open bugs including a security issue.
# Dead upstream (last release in 2006).
# Removal in 30 days (2021-08-16) (bug #602594).
app-accessibility/eflite
Thanks,
William
signature.asc
Description: PGP signature
On Thu, Aug 05, 2021 at 05:57:06PM -0700, Alec Warner wrote:
> On Thu, Aug 5, 2021 at 2:44 PM Georgy Yakovlev wrote:
> >
> > Hi,
> >
> > We've been collecting more and more container related packages in
> > app-emulation/*
> >
> > What do you think about finally moving those packages to separate
On Thu, Aug 12, 2021 at 12:39:33AM +0800, WANG Xuerui wrote:
> I'm planning to take ARCH=loongarch for the port; and support the LP64 ABI
> first. I'd like to support both LP64 and ILP32 ABIs, but that's not a
> priority.
>
> The ABI flag might be named "ABI_LOONGARCH" but that's IMO a bit long (
I spoke with several people on the #gentoo-hardened channel and no one
knows of any place where these profiles are being used.
I'll apply this patch early on Aug 16 UTC if no one objects.
William Hubbs (1):
profiles/hardened: remove the legasy musl profiles
profiles/hardened/linux/musl
Signed-off-by: William Hubbs
---
profiles/hardened/linux/musl/eapi | 1 -
profiles/hardened/linux/musl/make.defaults | 5 -
profiles/hardened/linux/musl/mips/eapi | 1 -
profiles/hardened/linux/musl/mips/mipsel/eapi | 1 -
profiles/hardened/linux/musl/mips
On Tue, Aug 17, 2021 at 02:54:19PM -0400, Anthony G. Basile wrote:
> On 8/17/21 2:24 PM, Aaron Bauman wrote:
> > On Tue, Aug 17, 2021 at 01:27:45PM -0400, Mike Gilbert wrote:
> >> On Tue, Aug 17, 2021 at 7:40 AM Anthony G. Basile
> >> wrote:
> >>>
> >>> Hi everyone,
> >>>
> >>> Can I get feedback
Use the compile and install subcommands of meson instead of calling
ninja. This allows for the possibility of a different back end.
Signed-off-by: William Hubbs
---
eclass/meson.eclass | 24 +---
1 file changed, 21 insertions(+), 3 deletions(-)
diff --git a/eclass
Use the compile and install subcommands of meson instead of calling
ninja. This allows for the possibility of a different back end.
Signed-off-by: William Hubbs
---
eclass/meson.eclass | 22 +++---
1 file changed, 19 insertions(+), 3 deletions(-)
diff --git a/eclass
Use the compile and install subcommands of meson instead of calling
ninja. This allows for the possibility of a different back end.
Stop using the NINJAOPTS variable.
Signed-off-by: William Hubbs
---
eclass/meson.eclass | 20 +++-
1 file changed, 15 insertions(+), 5 deletions
ned-off-by: William Hubbs
---
eclass/meson.eclass | 21 ++---
1 file changed, 14 insertions(+), 7 deletions(-)
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index 2a563e367c6..a14d7412b56 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -379,7 +379,13 @@ meson_src
- Drop the unused emesontestargs variable.
- Use the compile and install subcommands of meson instead of calling
ninja. This allows for the possibility of a different back end.
- Stop using the NINJAOPTS variable.
- Add --num-processes to "meson test" call regardless of whether MAKEOPTS
is s
On Wed, Aug 25, 2021 at 10:27:54AM -0500, William Hubbs wrote:
> - Remove extraneous whitespace.
This will be removed from the commit message before I add the patch to
the tree, and a sign-off will be added.
Thanks,
William
signature.asc
Description: PGP signature
On Wed, Aug 25, 2021 at 11:16:40AM -0500, William Hubbs wrote:
> On Wed, Aug 25, 2021 at 10:27:54AM -0500, William Hubbs wrote:
> > - Remove extraneous whitespace.
>
> This will be removed from the commit message before I add the patch to
> the tree, and a sign-off will be adde
As of go 1.16, --mod=readonly is the default, so we don't need to
specify it.
https://golang.org/ref/mod#build-commands
https://golang.org/doc/go1.16
Signed-off-by: William Hubbs
---
eclass/go-module.eclass | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/ecla
w the removal.
William Hubbs (9):
app-admin/vault: drop calls to go-module_pkg_postinst
app-metrics/blackbox_exporter: drop calls to go-module_pkg_postinst
app-misc/pet: drop calls to go-module_pkg_postinst
net-dns/coredns: drop calls to go-module_pkg_postinst
net-dns/dnscrypt-proxy: drop cal
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
app-admin/vault/vault-1.5.9.ebuild | 5 -
app-admin/vault/vault-1.6.5.ebuild | 5 -
app-admin/vault/vault-1.7.3.ebuild | 5 -
app-admin/vault/vault-1.8.1.ebuild | 5 -
4 files changed, 20 deletions
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.45.ebuild | 1 -
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.0.ebuild | 1 -
net-dns/dnscrypt-proxy/dnscrypt-proxy-.ebuild | 1 -
3 files changed, 3 deletions(-)
diff
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
app-misc/pet/pet-0.3.6-r1.ebuild | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/app-misc/pet/pet-0.3.6-r1.ebuild b/app-misc/pet/pet-0.3.6-r1.ebuild
index 09f5ee655f7..4beff9649cc 100644
--- a
Signed-off-by: William Hubbs
---
eclass/go-module.eclass | 17 +
1 file changed, 1 insertion(+), 16 deletions(-)
diff --git a/eclass/go-module.eclass b/eclass/go-module.eclass
index 053861a1a18..3f6e07fad2f 100644
--- a/eclass/go-module.eclass
+++ b/eclass/go-module.eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3
---
www-servers/caddy/caddy-2.3.0-r1.ebuild | 1 -
www-servers/caddy/caddy-2.4.2.ebuild| 1 -
2 files changed, 2 deletions(-)
diff --git a/www-servers/caddy/caddy-2.3.0-r1.ebuild
b/www-servers/caddy/caddy-2.3.0-r1.ebuild
index 32da8be5fb0..05fac
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
net-dns/coredns/coredns-1.8.3.ebuild | 1 -
1 file changed, 1 deletion(-)
diff --git a/net-dns/coredns/coredns-1.8.3.ebuild
b/net-dns/coredns/coredns-1.8.3.ebuild
index 14b4e4767af..184cef43304 100644
--- a/net-dns
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
net-vpn/riseup-vpn/riseup-vpn-0.21.6.ebuild | 1 -
1 file changed, 1 deletion(-)
diff --git a/net-vpn/riseup-vpn/riseup-vpn-0.21.6.ebuild
b/net-vpn/riseup-vpn/riseup-vpn-0.21.6.ebuild
index c2c5eb8da77..3b22b5554ae
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
www-apps/gitea/gitea-1.14.6.ebuild | 1 -
www-apps/gitea/gitea-.ebuild | 1 -
2 files changed, 2 deletions(-)
diff --git a/www-apps/gitea/gitea-1.14.6.ebuild
b/www-apps/gitea/gitea-1.14.6.ebuild
index
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: William Hubbs
---
.../blackbox_exporter/blackbox_exporter-0.19.0.ebuild| 5 -
1 file changed, 5 deletions(-)
diff --git a/app-metrics/blackbox_exporter/blackbox_exporter-0.19.0.ebuild
b/app-metrics/blackbox_exporter
On Sat, Aug 28, 2021 at 06:35:06PM +0200, Michał Górny wrote:
> Hi,
>
> I've been informed of a slight inconsistency in package manager behavior
> that affects combining EXPORT_FUNCTIONS with inherit (by ionic, thanks
> for the report!). Please consider the three following snippets:
...
> 1.
On Sat, Aug 28, 2021 at 08:12:53PM -0500, William Hubbs wrote:
> As of go 1.16, --mod=readonly is the default, so we don't need to
> specify it.
> https://golang.org/ref/mod#build-commands
> https://golang.org/doc/go1.16
>
> Signed-off-by: William Hubbs
> ---
>
On Sun, Aug 29, 2021 at 11:33:17AM -0500, William Hubbs wrote:
> It seems to me that we don't need this function any longer since the go
> ebuild displays a message when it is upgraded or downgraded explaining
> how to rebuild go packages, so I would like to remove it.
>
&g
On Wed, Sep 29, 2021 at 12:52:52AM +0200, Sebastian Pipping wrote:
> Hi!
>
> docker-compose upstream has apparently re-written docker-compose in
> Golang from scratch. While I'm happy to keep maintaining the current
> python-based someone to take over Go packaging of docker-compose >=2.0.0 in Ge
On Thu, Oct 14, 2021 at 03:40:02PM +0200, Marek Szuba wrote:
> Dear everyone,
>
> Following some private discussions, I feel quite strongly now that it
> would both considerably improve certain processes and make our use of
> limited manpower more efficient were we to further reduce the number o
On Mon, Nov 15, 2021 at 09:36:32AM +0300, Eray Aslan wrote:
> On Sun, Nov 14, 2021 at 09:15:36PM +0100, Thomas Deutschmann wrote:
> > On 2021-11-11 11:59, Ulrich Mueller wrote:
> > > We could:
> > >
> > > - Open some part of the range between 500 and 1000. For example,
> > >500..799, which wou
On Sun, Nov 28, 2021 at 11:06:36AM +0100, Ulrich Mueller wrote:
> >>>>> On Sun, 28 Nov 2021, William Hubbs wrote:
>
> > On Mon, Nov 15, 2021 at 09:36:32AM +0300, Eray Aslan wrote:
> >> 1/ Static allocation does not really solve a problem. Not really not
>
On Sun, Nov 28, 2021 at 11:23:16AM -0800, Zac Medico wrote:
> On 11/21/21 02:57, Florian Schmaus wrote:
> > Following the pattern found in other eclasses, add GO_OPTIONAL to the
> > go-module eclass. This allows to inherit the eclass without pulling
> > its dependencies. See, e.g., bug #775779 for
On Sun, Nov 28, 2021 at 02:57:39PM -0500, Michael Orlitzky wrote:
> On 2021-11-28 11:06:36, Ulrich Mueller wrote:
> >
> > While the rationale for static allocation that made it into GLEP 81 [1]
> > is rather weak, several people had argued in favour of it on the mailing
> > list [2].
> >
>
> We
On Sun, Nov 28, 2021 at 08:15:13PM +0100, Michał Górny wrote:
> On Sun, 2021-11-28 at 13:06 -0600, William Hubbs wrote:
> > On Sun, Nov 28, 2021 at 11:06:36AM +0100, Ulrich Mueller wrote:
> > > > > > > > On Sun, 28 Nov 2021, William Hubbs wrote:
> > >
On Sun, Nov 28, 2021 at 02:42:23PM -0600, Gordon Pettey wrote:
> On Sun, Nov 28, 2021 at 2:27 PM William Hubbs wrote:
>
> > On Sun, Nov 28, 2021 at 02:57:39PM -0500, Michael Orlitzky wrote:
> > > We don't even do static allocation.
>
> > There are a few exce
On Sun, Nov 28, 2021 at 02:46:24PM -0600, William Hubbs wrote:
> On Sun, Nov 28, 2021 at 08:15:13PM +0100, Michał Górny wrote:
> > On Sun, 2021-11-28 at 13:06 -0600, William Hubbs wrote:
> > > On Sun, Nov 28, 2021 at 11:06:36AM +0100, Ulrich Mueller wrote:
> > > >
All,
I want to discuss why we ban -1 as the ACCT_USER_ID and ACCT_GROUP_ID setting
for all acct-user and acct-group packages in ::gentoo.
Here are my thoughts about it.
- As Gordon pointed out, it isn't necessary for us to care about UIDS/GIDS
most of the time.
- I realize that our settings a
# William Hubbs (2021-11-30)
# Dead upstream, no releases since 2015
# Bug #770619; masked for removal on 2021-12-30.
net-vpn/badvpn
Thanks,
William
signature.asc
Description: PGP signature
Signed-off-by: William Hubbs
---
eclass/tmpfiles.eclass | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/eclass/tmpfiles.eclass b/eclass/tmpfiles.eclass
index b9238a6434a..7a0e2cb7265 100644
--- a/eclass/tmpfiles.eclass
+++ b/eclass/tmpfiles.eclass
@@ -8,7 +8,7
On Tue, Nov 30, 2021 at 12:59:18PM +0100, Ulrich Mueller wrote:
> > On Tue, 30 Nov 2021, James Cloos wrote:
>
> > "UM" == Ulrich Mueller writes:
> UM> Also, why would one allocate UIDs in the 500..999 range (1000 is fine,
> UM> actually)? Gentoo always had UID_MIN=1000 and SYS_UID_MAX=999
This is in the tree.
Thanks,
William
signature.asc
Description: PGP signature
This is committed.
Thanks,
William
signature.asc
Description: PGP signature
# William Hubbs (2021-12-15)
# This is a go module and is included in projects directly.
# Bug #819639; masked for removal on 2022-12-15.
dev-go/blackfriday
Thanks,
William
signature.asc
Description: PGP signature
Resending this to fix the date.
# William Hubbs (2021-12-15)
# This is a go module and is included in projects directly.
# Bug #819639; masked for removal on 2022-01-15.
dev-go/blackfriday
Thanks,
William
>
signature.asc
Description: PGP signature
1401 - 1450 of 1450 matches
Mail list logo