It is a de-facto standard to use deselect=() and/or ignore=() arrays
to pass arguments to epytest. Let's make the function take them
automatically without requiring unsafe hacks such as:
epytest ${deselect[@]/#/--deselect }
Signed-off-by: Michał Górny
---
eclass/python-utils-r1.eclass | 11
On 2021-08-10 06:17, Mikle Kolyada wrote:
I will take those as yubikey is my daily use now
And I'll co-maintain them, both for the same reason as zlogene and
because I maintain two YubiKey-related packages (as well as one for
SoloKeys which depends on fido2) already.
--
Marecki
OpenPGP_
On 10/08/2021 10.31, Andreas Sturmlechner wrote:
On Montag, 9. August 2021 20:32:07 CEST Florian Schmaus wrote:
+if ${_DEFINE_XDG_SRC_PREPARE}; then
You don't need an extra variable for that:
if [[ ${EAPI} == [567] ]]; then
Thanks for the suggestion, but I prefer the current approach.
It a
On Mittwoch, 11. August 2021 13:54:19 CEST Florian Schmaus wrote:
> On 10/08/2021 10.31, Andreas Sturmlechner wrote:
> > On Montag, 9. August 2021 20:32:07 CEST Florian Schmaus wrote:
> >> +if ${_DEFINE_XDG_SRC_PREPARE}; then
> >
> > You don't need an extra variable for that:
> >
> > if [[ ${EAPI
# app-office/plan
Broken with gcc >=10, even the latest upstream release fails with
gcc-11. Unmaintained. Removal in ~30 days. #739904
# dev-libs/caliper
A library without revdeps, broken for a long time. No maintainer reply.
Package not updated in Gentoo since 2016 even though upstream is still
a
Small cleanup, small documentation improvements and EAPI 8 support.
Stephan Hartmann (3):
chromium-2.eclass: remove GYP support
chromium-2.eclass: update documentation
chromium-2.eclass: enable EAPI 8
eclass/chromium-2.eclass | 53 +++-
1 file changed, 1
Chromium project replaced GYP with GN in 2016 and nothing in
::gentoo is using GYP.
Signed-off-by: Stephan Hartmann
---
eclass/chromium-2.eclass | 36
1 file changed, 36 deletions(-)
diff --git a/eclass/chromium-2.eclass b/eclass/chromium-2.eclass
index 54df
Signed-off-by: Stephan Hartmann
---
eclass/chromium-2.eclass | 13 -
1 file changed, 12 insertions(+), 1 deletion(-)
diff --git a/eclass/chromium-2.eclass b/eclass/chromium-2.eclass
index 2543078df79..b97a31e614e 100644
--- a/eclass/chromium-2.eclass
+++ b/eclass/chromium-2.eclass
@@
Signed-off-by: Stephan Hartmann
---
eclass/chromium-2.eclass | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/eclass/chromium-2.eclass b/eclass/chromium-2.eclass
index b97a31e614e..2800934537f 100644
--- a/eclass/chromium-2.eclass
+++ b/eclass/chromium-2.eclass
@@ -6,11 +6,
Hi everyone,
I'm your average Gentoo user who obviously thought his sleeping time is more
than enough, and just decided to start porting Gentoo to LoongArch. As this
is such a niche architecture with no upstreamed support so far, I'm posting
this to announce my intent and gather advice on how to
On Thu, Aug 12, 2021 at 12:39:33AM +0800, WANG Xuerui wrote:
> I'm planning to take ARCH=loongarch for the port; and support the LP64 ABI
> first. I'd like to support both LP64 and ILP32 ABIs, but that's not a
> priority.
>
> The ABI flag might be named "ABI_LOONGARCH" but that's IMO a bit long (
On Wed, 2021-08-11 at 09:49 +0200, Michał Górny wrote:
> It is a de-facto standard to use deselect=() and/or ignore=() arrays
> to pass arguments to epytest. Let's make the function take them
> automatically without requiring unsafe hacks such as:
>
> epytest ${deselect[@]/#/--deselect }
>
>
On 8/12/21 02:13, William Hubbs wrote:
On Thu, Aug 12, 2021 at 12:39:33AM +0800, WANG Xuerui wrote:
I'm planning to take ARCH=loongarch for the port; and support the LP64 ABI
first. I'd like to support both LP64 and ILP32 ABIs, but that's not a
priority.
The ABI flag might be named "ABI_LOONGAR
On Thu, 2021-08-12 at 09:21 +0800, WANG Xuerui wrote:
> On 8/12/21 02:13, William Hubbs wrote:
>
> > On Thu, Aug 12, 2021 at 12:39:33AM +0800, WANG Xuerui wrote:
> > > I'm planning to take ARCH=loongarch for the port; and support the LP64 ABI
> > > first. I'd like to support both LP64 and ILP32 AB
> On Thu, 12 Aug 2021, Michał Górny wrote:
> On Thu, 2021-08-12 at 09:21 +0800, WANG Xuerui wrote:
>> I would say this is mostly aesthetic matter, because we have equally
>> long ARCH names like "microblaze" or "openrisc" too. From a user's
>> perspective I'd personally prefer "loong" to sav
Hey, the following package is up for grabs:
games-util/xboxdrv
Haven't used this in years. Last upstream release was in 2015. Even
upstream recommends to use the kernel built-in XPAD module. This package
has one scons-related bug open, and it was recently broken by a scons
update. Upstream started
16 matches
Mail list logo