17.01.2013 00:43, Paul Varner wrote:
> Here is where the bikeshedding begins:
> 1. What variable name do we prefer? REVDEP_DEFAULT_OPTS or
> REVDEP_EMERGE_DEFAULT_OPTS
REVDEP_REBUILD_DEFAULT_OPTS seems fine, IMO.
> 2. What behavior do we want? append to EMERGE_DEFAULT_OPTS or replace
> EMERGE_DEF
On Wed, Jan 16, 2013, at 03:57 PM, Ian Stakenvicius wrote:
[...]
> +1 on the replace.
+1
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256
On 16/01/13 03:43 PM, Paul Varner wrote:
> All:
>
> Time for some bikeshedding :)
>
> For the gentoolkit-0.3.0 series, I removed any filtering of emerge
> options set in EMERGE_DEFAULT_OPS for revdep-rebuild. This has
> caused some people to comp
On Wed, Jan 16, 2013 at 3:43 PM, Paul Varner wrote:
> 2. What behavior do we want? append to EMERGE_DEFAULT_OPTS or replace
> EMERGE_DEFAULT_OPTS
Replace is probably better. You can always manually append if you
want to, but it is much harder to remove unless portage has logic to
handle a invers
All:
Time for some bikeshedding :)
For the gentoolkit-0.3.0 series, I removed any filtering of emerge
options set in EMERGE_DEFAULT_OPS for revdep-rebuild. This has caused
some people to complain because some of the flags in their
EMERGE_DEFAULT_OPTS are not suitable for a revdep-rebuild run.
I