[gentoo-dev] Re: controlling src_test

2007-10-04 Thread Ryan Hill
Ryan Hill wrote: > > here's a crappy little script to automate it. > here's take two. if someone could tell me a simple way to get the category given a package name, including a way to detect ambiguous names, i could drop the dependency on app-portage/udept. anyways it now supports disabling m

[gentoo-dev] Re: controlling src_test

2007-10-04 Thread Ryan Hill
Alin Năstac wrote: > Ryan Hill wrote: >> NEWFEATURES= >> >> for f in ${FEATURES}; do >> if [[ ! $f == "test" ]]; then >> NEWFEATURES="${NEWFEATURES} $f" >> fi >> done >> >> FEATURES="${NEWFEATURES}" >> >> > There is a simpler way to remove a word from an environment variable: > F

Re: [gentoo-dev] Re: controlling src_test

2007-10-04 Thread Rémi Cardona
Ryan Hill wrote: > here's a crappy little script to automate it. This is really cool. /me had somehow missed the lesson on /etc/portage/env Cheers :) Rémi -- [EMAIL PROTECTED] mailing list

Re: [gentoo-dev] Re: controlling src_test

2007-10-04 Thread Chris Gianelloni
On Thu, 2007-10-04 at 13:47 -0600, Ryan Hill wrote: > > I usually disable tests on a per-package basis using /etc/portage/env > > entries. > > > > [EMAIL PROTECTED] ~ $ cat /etc/portage/env/sci-libs/fftw > > NEWFEATURES= > > > > for f in ${FEATURES}; do > > if [[ ! $f == "test" ]]; then > >

[gentoo-dev] Re: controlling src_test

2007-10-04 Thread Ryan Hill
Ryan Hill wrote: > Rémi Cardona wrote: >> Ravi Pinjala a écrit : >>> I, for one, would like to be able to control whether or not to run tests >>> that take a huge amount of time to run. Some test suites are >>> ridiculously comprehensive, and if we could have an option to disable >>> only those

Re: [gentoo-dev] Re: controlling src_test

2007-10-04 Thread Alin Năstac
Ryan Hill wrote: > NEWFEATURES= > > for f in ${FEATURES}; do > if [[ ! $f == "test" ]]; then > NEWFEATURES="${NEWFEATURES} $f" > fi > done > > FEATURES="${NEWFEATURES}" > > There is a simpler way to remove a word from an environment variable: FEATURES=" ${FEATURES}" # make sure e

[gentoo-dev] Re: controlling src_test

2007-10-04 Thread Ryan Hill
Rémi Cardona wrote: > Ravi Pinjala a écrit : >> I, for one, would like to be able to control whether or not to run tests >> that take a huge amount of time to run. Some test suites are >> ridiculously comprehensive, and if we could have an option to disable >> only those, or even run a reduced tes