where, do we need to add it?
>I guess I don’t mind it for future use, but just checking that it was
>deliberate.
It is deliberate - I thought it may be useful to have for future use.
BR,
- Vladimir Miloserdov
> else:
> assert False
Might be a good idea to rename "fn" -> "get_err", "i" -> "error_type_counter",
"k" -> "error_message", "errors" -> "grouped_errors" to make it easier to
understand.
You can also simplify "entry" construction like this:
entry = {
'type': error_type_counter,
'msg': error_message,
'count': len(grouped_errors)
}
BR,
- Vladimir Miloserdov