[PATCH] Add missing INCLUDE_DEFAULTS_MUSL_LOCAL

2015-10-21 Thread Doug Evans
Heya. I happened to notice local prefixes not working with musl. Fixes thusly. 2015-10-21 Doug Evans * config/linux.h (INCLUDE_DEFAULTS): Add INCLUDE_DEFAULTS_MUSL_LOCAL. Index: config/linux.h === --- config/linux.h

Re: [PATCH] Add missing INCLUDE_DEFAULTS_MUSL_LOCAL

2015-10-23 Thread Doug Evans
On Fri, Oct 23, 2015 at 10:08 AM, Bernd Schmidt wrote: > > On 10/21/2015 09:00 PM, Doug Evans wrote: >> >> I happened to notice local prefixes not working with musl. >> Fixes thusly. > > >> Index: config/linux.h >> ===

Re: [PATCH] Add missing INCLUDE_DEFAULTS_MUSL_LOCAL

2015-10-26 Thread Doug Evans
On Fri, Oct 23, 2015 at 11:34 AM, Szabolcs Nagy wrote: > On 23/10/15 18:39, Doug Evans wrote: >> >> On Fri, Oct 23, 2015 at 10:08 AM, Bernd Schmidt >> wrote: >>> >>> >>> On 10/21/2015 09:00 PM, Doug Evans wrote: >>>> >>>> &g

[PATCH] libstdc++: Fix libstdc++/67440: pretty-printing of a const set fails

2015-11-16 Thread Doug Evans
Hi. Apologies for the delay. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67440 Tested with current trunk. 2015-11-16 Doug Evans PR libstdc++/67440 * python/libstdcxx/v6/printers.py (find_type): Handle "const" in type name. * testsui

Re: [PATCH] libstdc++: Fix libstdc++/67440: pretty-printing of a const set fails

2015-11-25 Thread Doug Evans
On Wed, Nov 25, 2015 at 9:29 AM, Alan Lawrence wrote: > On 16/11/15 21:04, Doug Evans wrote: >> >> Hi. >> >> Apologies for the delay. >> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67440 >> >> Tested with current trunk. >> >&g

Re: [PATCH] [libstdc++/65839] whatis support for xmethods

2015-05-26 Thread Doug Evans
On Wed, Apr 29, 2015 at 11:14 AM, Jonathan Wakely wrote: > On 29/04/15 10:57 -0700, Doug Evans wrote: >> >> On Tue, Apr 28, 2015 at 5:16 AM, Jonathan Wakely >> wrote: >>> >>> On 27/04/15 15:44 -0700, Doug Evans wrote: >>>> >>>> >

Re: [PATCH] [libstdc++] Add operator-> xmethod to std::unique_ptr

2015-05-26 Thread Doug Evans
On Thu, Apr 30, 2015 at 12:09 PM, Jonathan Wakely wrote: > On 30/04/15 11:19 -0700, Doug Evans wrote: >> >> Hi. >> >> This patch adds operator-> xmethod support for std::unique_ptr. >> >> Regression tested on amd64-linux. >> >> Ok to commit? > > > OK, thanks. Committed, thanks.

[PATCH] libstdc++: Fix list.cc xmethods test.

2015-04-27 Thread Doug Evans
Hi. While we should eventually get the xmethods to handle cxx11, this patch fixes the current failure. The xmethod matcher doesn't currently handle __cxx11 in the type name. Adding cxx11 support can be a follow up patch. Ok to commit? 2015-04-27 Doug Evans * testsuite/li

[PATCH] [libstdc++/65839] whatis support for xmethods

2015-04-27 Thread Doug Evans
Hi. This patch is the counterpart to this patch to fix libstdc++/65839, gdb/18285. https://sourceware.org/ml/gdb-patches/2015-04/msg00947.html Regression tested on amd64-linux with/without a patched gdb. Without a patched gdb the new tests fail, but that's good. 2015-04-27 Doug

[PATCH] libstdc++: Add operator-> support to unique_ptr xmethod.

2015-04-27 Thread Doug Evans
-27 Doug Evans * python/libstdcxx/v6/xmethods.py (UniquePtrMethodsMatcher): Add operator->. * testsuite/libstdc++-xmethods/unique_ptr.cc: Add tests for operator->. --- ./python/libstdcxx/v6/xmethods.py= 2015-04-27 10:46:52.0 -0700 +++ ./python/libstdcxx/v6/xm

Re: [PATCH] libstdc++: Fix list.cc xmethods test.

2015-04-29 Thread Doug Evans
On Mon, Apr 27, 2015 at 3:41 PM, Jonathan Wakely wrote: > On 27 April 2015 at 23:33, Doug Evans wrote: >> Hi. >> >> While we should eventually get the xmethods to handle cxx11, >> this patch fixes the current failure. >> The xmethod matcher doesn't cur

[PATCH] Use consistent naming in libstdcxx/v6/xmethods.py

2015-04-29 Thread Doug Evans
Hi. This patch splits out from the patch for 65839 the consistent naming suggested here. https://gcc.gnu.org/ml/libstdc++/2015-04/msg00155.html Regression tested on amd64-linux. Ok to commit? 2015-04-29 Doug Evans Use consistent naming for value type attributes. * python

Re: [PATCH] [libstdc++/65839] whatis support for xmethods

2015-04-29 Thread Doug Evans
On Tue, Apr 28, 2015 at 5:16 AM, Jonathan Wakely wrote: > On 27/04/15 15:44 -0700, Doug Evans wrote: >> >> PR libstdc++/65839 >> * python/libstdcxx/v6/xmethods.py (get_bool_type): New function. >> Replace all lookups of "bool" with this

[PATCH] [libstdc++] Add operator-> xmethod to std::unique_ptr

2015-04-30 Thread Doug Evans
Hi. This patch adds operator-> xmethod support for std::unique_ptr. Regression tested on amd64-linux. Ok to commit? 2015-04-30 Doug Evans * python/libstdcxx/v6/xmethods.py (UniquePtrMethodsMatcher): Add operator-> support. * testsuite/libstdc++-xm

Re: [patch+7.9] compile: Filter out -fpreprocessed

2015-02-03 Thread Doug Evans
On Fri, Jan 16, 2015 at 2:42 PM, Jan Kratochvil wrote: > [...] > It is wrong that gcc puts -fpreprocessed into DW_AT_producer - I may post a > gcc > patch for it. Hi. I wasn't aware there are now rules for what can and cannot go in DW_AT_producer. DW_AT_producer has gone from being informational

Re: [patch+7.9] compile: Filter out -fpreprocessed

2015-02-04 Thread Doug Evans
On Tue, Feb 3, 2015 at 11:10 AM, Mark Wielaard wrote: > On Tue, 2015-02-03 at 19:59 +0100, Jan Kratochvil wrote: >> On Tue, 03 Feb 2015 19:50:40 +0100, Doug Evans wrote: >> > On Fri, Jan 16, 2015 at 2:42 PM, Jan Kratochvil >> > wrote: >> > > [...] >>

Re: [PATCH 09/36] floatformat.h: Wrap in extern "C".

2015-02-14 Thread Doug Evans
On Mon, Feb 9, 2015 at 3:49 PM, Pedro Alves wrote: > On 02/09/2015 11:35 PM, Andrew Pinski wrote: >> On Mon, Feb 9, 2015 at 3:20 PM, Pedro Alves wrote: >>> Just like libiberty.h. So that C++ programs, such as GDB when built >>> as a C++ program, can use it. >> >> Why is not needed for GCC buildi

Re: [PATCH 09/36] floatformat.h: Wrap in extern "C".

2015-02-14 Thread Doug Evans
On Sat, Feb 14, 2015 at 10:36 AM, Pedro Alves wrote: > On 02/14/2015 05:29 PM, Doug Evans wrote: >> On Mon, Feb 9, 2015 at 3:49 PM, Pedro Alves wrote: >>> On 02/09/2015 11:35 PM, Andrew Pinski wrote: >>>> Why is not needed for GCC building with C++ compiler? >>

[RFA 1/8] validate_failures.py: add TestResult ordinal

2012-11-24 Thread Doug Evans
appearance. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Record ordinal with TestResult. --- validate_failures.py= 2012-11-19 11:47:29.997632548 -0800 +++ validate_failures.py2012-11-24 13:19:22.183836303 -0800 @@ -91,9 +91,12 @@ class

[RFA 2/8] validate_failures.py: use target_alias

2012-11-24 Thread Doug Evans
Hi. This second patch uses "target_alias" instead of "target" in the help text, and makes some minor whitespace changes. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Use instead of . Minor whitespace changes. ---

[RFA 3/8] validate_failures.py: pass options.results for clean build case

2012-11-24 Thread Doug Evans
I'm being conservative and not adding an option if I don't have to.] Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py (CompareBuilds): Pass options.results to GetSumFiles for clean build. --- validate_failures.py= 2012-11-19 11:4

[RFA 4/8] validate_failures.py: rename --manifest to --manifest_path

2012-11-24 Thread Doug Evans
Hi. This fourth patch renames option --manifest to --manifest_path. I have a later patch that adds a --manifest_name option, making "--manifest" too confusing/ambiguous. Ok to check in? [I still have to update invocations that use --manifest, but that's a separate patch.] 2012-11

[RFA 5/8] validate_failures.py: make options a global

2012-11-24 Thread Doug Evans
Hi. This fifth patch makes options a global variable. As validate_failures.py becomes more complex, passing it around everywhere becomes cumbersome with no real gain. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Make options a global variable

[RFA 6/8] validate_failures.py: remove pass/fail from GetBuildData

2012-11-24 Thread Doug Evans
Hi. This sixth patch simplifies calls to GetBuildData. It never returns false and always terminates the process with an error message (which is fine by me). Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Remove pass/fail indicator from

[RFA 7/8] validate_failures.py: New options --manifest_subdir, --manifest_name

2012-11-24 Thread Doug Evans
Hi. This seventh patch adds new options --manifest_subdir, --manifest_name. Useful when using validate_failures.py with a different tool, instead of gcc. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: New options --manifest_subdir

[RFA 8/8] validate_failures.py: New directives @include, @remove.

2012-11-24 Thread Doug Evans
27;ve found it useful.] Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Add support for @include, @remove directives in manifest files. --- validate_failures.py.manifest-subdir-name 2012-11-24 13:54:03.263761546 -0800 +++ validate_failur

Re: [RFA 3/8] validate_failures.py: pass options.results for clean build case

2012-11-28 Thread Doug Evans
On Sun, Nov 25, 2012 at 7:40 AM, Diego Novillo wrote: > On Sat, Nov 24, 2012 at 5:47 PM, Doug Evans wrote: >> >> Hi. >> This third patch passes options.results to GetSumFiles when fetching the >> results >> for the clean build. >> It is useful in my use

Re: [RFA 3/8] validate_failures.py: pass options.results for clean build case

2012-11-28 Thread Doug Evans
On Wed, Nov 28, 2012 at 12:35 PM, Diego Novillo wrote: > On Wed, Nov 28, 2012 at 1:55 PM, Doug Evans wrote: > >> In gdb-land, parallel make check runs collect all the subdirectory >> .sum files and reconstruct testsuite/${tool}.sum. >> >> There's more than on

Re: [RFA 4/8] validate_failures.py: rename --manifest to --manifest_path

2012-11-29 Thread Doug Evans
Diego Novillo writes: > On Sat, Nov 24, 2012 at 5:50 PM, Doug Evans wrote: > > Hi. > > This fourth patch renames option --manifest to --manifest_path. > > I have a later patch that adds a --manifest_name option, making > > "--manifest" > > too co

Re: [RFA 7/8] validate_failures.py: New options --manifest_subdir, --manifest_name

2012-11-29 Thread Doug Evans
Diego Novillo writes: > On Sat, Nov 24, 2012 at 5:58 PM, Doug Evans wrote: > > Hi. > > This seventh patch adds new options --manifest_subdir, --manifest_name. > > Useful when using validate_failures.py with a different tool, instead of > > gcc. > > > &g

Re: [google gcc-4_8] Remove DW_AT_GNU_addr_base from skeleton type unit DIEs

2014-02-11 Thread Doug Evans
On Tue, Feb 11, 2014 at 3:55 PM, Cary Coutant wrote: > Remove DW_AT_GNU_addr_base from skeleton type unit DIEs. > > GCC currently adds a DW_AT_GNU_addr_base attribute to skeleton type unit > DIEs, even though it's not needed there. By removing it, we can save > the 8 bytes that a DW_FORM_addr take

Re: [RFA] timeval-utils.c for libiberty

2011-11-02 Thread Doug Evans
On Wed, Sep 28, 2011 at 11:21 AM, Ian Lance Taylor wrote: > On Mon, Sep 19, 2011 at 5:52 PM, Doug Evans wrote: >> >> 2011-09-19  Doug Evans   >> >>        include/ >>        * timeval-utils.h: New file. >> >>        libiberty/ >>        *

[RFA] dwarf2.def (DW_OP): Add DW_OP_GNU_const_index.

2012-06-14 Thread Doug Evans
Hi. Ok to commit? 2012-06-14 Doug Evans * dwarf2.def (DW_OP): Add DW_OP_GNU_const_index. Index: dwarf2.def === --- dwarf2.def (revision 188634) +++ dwarf2.def (working copy) @@ -588,6 +588,7 @@ DW_OP

Re: [RFA] dwarf2.def (DW_OP): Add DW_OP_GNU_const_index.

2012-06-18 Thread Doug Evans
Ping. On Thu, Jun 14, 2012 at 12:48 PM, Doug Evans wrote: > Hi. > > Ok to commit? > > 2012-06-14  Doug Evans   > >        * dwarf2.def (DW_OP): Add DW_OP_GNU_const_index. > > Index: dwarf2.def > =

[RFA libiberty, gdb] Add hashtab support to filename_ncmp.c and use it in gdb.

2012-07-09 Thread Doug Evans
couldn't find any in gdb,binutils,gcc. Technically speaking, it's also possible that adding the #include "hashtab.h" to filenames.h could introduce a build failure (e.g., some file has a static symbol that collides with one used in hashtab.h). I'm hoping that's

Re: [RFA libiberty, gdb] Add hashtab support to filename_ncmp.c and use it in gdb.

2012-07-09 Thread Doug Evans
[- gdb, + gdb-patches] On Mon, Jul 9, 2012 at 11:51 AM, Steven Bosscher wrote: > On Mon, Jul 9, 2012 at 8:10 PM, Doug Evans wrote: >> Hi. >> >> filename_seen in gdb does a linear search, this patch changes it >> to use a hash table. >> >> Ok to check in

Re: [RFA libiberty, gdb] Add hashtab support to filename_ncmp.c and use it in gdb.

2012-07-13 Thread Doug Evans
Hi. "ping" [for the libiberty part] [The gdb part needs to be updated due to recent changes there, but I'm going to wait until the libiberty part is approved.] On Mon, Jul 9, 2012 at 11:10 AM, Doug Evans wrote: > Hi. > > filename_seen in gdb does a linear search, this p

Re: [RFA libiberty, gdb] Add hashtab support to filename_ncmp.c and use it in gdb.

2012-07-13 Thread Doug Evans
On Fri, Jul 13, 2012 at 12:21 PM, DJ Delorie wrote: > > I think it's confusing to have filename_cmp and filename_eq that do > basically the same thing. Perhaps filename_eq should be > filename_cmp_v or filename_cmp_hash or something, to indicate that > it's *supposed* to be the same functionality

Re: [RFA libiberty, gdb] Add hashtab support to filename_ncmp.c and use it in gdb.

2012-07-13 Thread Doug Evans
On Fri, Jul 13, 2012 at 12:47 PM, Eli Zaretskii wrote: >> Date: Fri, 13 Jul 2012 12:36:44 -0700 >> From: Doug Evans >> Cc: gcc-patches@gcc.gnu.org, gdb-patc...@sourceware.org >> >> On Fri, Jul 13, 2012 at 12:21 PM, DJ Delorie wrote: >> > >> >

[RFA] leb128.h: New file.

2012-05-14 Thread Doug Evans
Hi. This patch creates leb128.h which contains a few functions for reading leb128 values. They're in a header as static inlines because they can be speed critical. I've only included what I need in GDB. Ok to check in? 2012-05-14 Doug Evans * leb128.h: New file. Index

Re: [RFA] leb128.h: New file.

2012-05-17 Thread Doug Evans
without having to apply ugly casts. Ok to check in? 2012-05-17 Doug Evans * leb128.h: New file. Index: leb128.h === RCS file: leb128.h diff -N leb128.h --- /dev/null 1 Jan 1970 00:00:00 - +++ leb128.h17 May 2012 18:23

Re: [RFA] leb128.h: New file.

2012-05-20 Thread Doug Evans
Ping. On Thu, May 17, 2012 at 11:29 AM, Doug Evans wrote: > Hi. > > This is a slightly modified version of my previous patch. > > ref: http://gcc.gnu.org/ml/gcc-patches/2012-05/msg00962.html > > The only change is to make the result of the functions an int > instead of

Re: [RFA] leb128.h: New file.

2012-05-21 Thread Doug Evans
On Mon, May 21, 2012 at 10:08 AM, Ian Lance Taylor wrote: > d...@google.com (Doug Evans) writes: > >> 2012-05-17  Doug Evans   >> >>       * leb128.h: New file. > > I'm not entirely sure about the use of int64_t to hold the result.  Do > we want to let this i

[RFA] timeval-utils.c for libiberty

2011-09-19 Thread Doug Evans
Hi. This patch adds two functions, timeval_add and timeval_sub, to libiberty. GDB has use for them in a few places and since they're general purpose I wish to check them into libiberty. Ok to check in? 2011-09-19 Doug Evans include/ * timeval-utils.h: New

[RFA] Add libiberty/argv.c:countargv

2011-09-20 Thread Doug Evans
Hi. Part of the abstraction of an argv is a count of the number elements. This patch adds countargv which I have use for in gdb. Ok to check in? 2011-09-20 Doug Evans include/ * libiberty.h (countargv): Declare. libiberty/ * argv.c (countargv): New function

Re: [RFA] timeval-utils.c for libiberty

2011-09-26 Thread Doug Evans
On Mon, Sep 19, 2011 at 5:52 PM, Doug Evans wrote: > Hi. > > This patch adds two functions, timeval_add and timeval_sub, > to libiberty.  GDB has use for them in a few places and since > they're general purpose I wish to check them into libiberty. > > Ok to check in?

Re: [RFA] Add libiberty/argv.c:countargv

2011-09-26 Thread Doug Evans
On Tue, Sep 20, 2011 at 11:23 AM, Doug Evans wrote: > Hi. > > Part of the abstraction of an argv is a count of the number elements. > This patch adds countargv which I have use for in gdb. > > Ok to check in? > > 2011-09-20  Doug Evans   > >        include/ >

[patch, gcc RFA] dg-extract-results.sh: Handle KFAILs.

2012-03-14 Thread Doug Evans
if there are no objections. Any reason not to apply it to the gcc tree as well? 2012-03-14 Doug Evans * dg-extract-results.sh: Handle KFAILs. Index: dg-extract-results.sh === RCS file: /cvs/src/src/gdb/testsuite/dg-extra

Re: RFA: consolidate DWARF strings into libiberty

2012-03-19 Thread Doug Evans
On Thu, Mar 15, 2012 at 12:02 PM, Tom Tromey wrote: >> "DJ" == DJ Delorie writes: > > Tom> Finally, there is already stuff in libiberty not related to > Tom> portability.  E.g., hashtab or the demangler. > > DJ> Yeah, I know, hence my "Should I give up that premise?" > > Yeah. > > I am not su

Re: RFA: consolidate DWARF strings into libiberty

2012-03-19 Thread Doug Evans
On Mon, Mar 19, 2012 at 9:09 AM, Doug Evans wrote: > On Thu, Mar 15, 2012 at 12:02 PM, Tom Tromey wrote: >>>>>>> "DJ" == DJ Delorie writes: >> >> Tom> Finally, there is already stuff in libiberty not related to >> Tom> portability.  E.g

Mirror gcc/contrib -> src/contrib? [was Re: [patch, gcc RFA] dg-extract-results.sh: Handle KFAILs.]

2012-04-06 Thread Doug Evans
On Thu, Mar 15, 2012 at 11:54 AM, Mike Stump wrote: > On Mar 15, 2012, at 11:09 AM, Pedro Alves wrote: >> Still, kfail is standard DejaGnu, not a GDB invention.  It'd be nice not to >> need to fork the script for this. > > The change is fine for the gcc tree. Committed (to the gcc tree, already i

Re: Mirror gcc/contrib -> src/contrib? [was Re: [patch, gcc RFA] dg-extract-results.sh: Handle KFAILs.]

2012-04-09 Thread Doug Evans
On Mon, Apr 9, 2012 at 7:43 AM, Tom Tromey wrote: >>>>>> "Doug" == Doug Evans writes: > > Doug> On Thu, Mar 15, 2012 at 11:54 AM, Mike Stump > wroteDoug> btw, is there any interest in mirroring gcc/contrib -> src/contrib? > Doug> [instead of

[RFA] dwarf2.h (dwarf_location_atom): Add DW_OP_GNU_addr_index.

2012-04-18 Thread Doug Evans
Hi. This patch adds DW_OP_GNU_addr_index to dwarf2.h. Ok to commit? 2012-04-18 Doug Evans * dwarf2.h (dwarf_location_atom): Add DW_OP_GNU_addr_index. Index: include/dwarf2.h === RCS file: /cvs/src/src/include/dwarf2.h

Re: [RFA] dwarf2.h (dwarf_location_atom): Add DW_OP_GNU_addr_index.

2012-04-25 Thread Doug Evans
On Wed, Apr 18, 2012 at 12:11 PM, Doug Evans wrote: > Hi. > > This patch adds DW_OP_GNU_addr_index to dwarf2.h. > > Ok to commit? > > 2012-04-18  Doug Evans   > >        * dwarf2.h (dwarf_location_atom): Add DW_OP_GNU_addr_index.