Ping: [PATCH 5/6] PowerPC: Switch to dense math names for all MMA operations.

2023-10-25 Thread Michael Meissner
Ping patch. | Date: Wed, 18 Oct 2023 20:04:44 -0400 | From: Michael Meissner | Subject: [PATCH 5/6] PowerPC: Switch to dense math names for all MMA operations. | Message-ID: https://gcc.gnu.org/pipermail/gcc-patches/2023-October/633515.html -- Michael Meissner, IBM PO Box 98, Ayer, Massachus

Ping: [PATCH 6/6] PowerPC: Add support for 1,024 bit DMR registers.

2023-10-25 Thread Michael Meissner
Ping patch. | Date: Wed, 18 Oct 2023 20:06:20 -0400 | From: Michael Meissner | Subject: [PATCH 6/6] PowerPC: Add support for 1,024 bit DMR registers. | Message-ID: https://gcc.gnu.org/pipermail/gcc-patches/2023-October/633516.html -- Michael Meissner, IBM PO Box 98, Ayer, Massachusetts, USA,

Re: [PATCH] c++/modules: fix up recent testcases

2023-10-25 Thread Nathan Sidwell
Patrick, thanks for noticing this, and this is a suitable workaround for another bug. We should either be emitting the definition of that member function in the object file of its containing function. Or it should be implicitly inline. I know in module perview the in-class defined member fun

Re: [PATCH] c++/modules: fix up recent testcases

2023-10-25 Thread Jason Merrill
On 10/25/23 14:32, Patrick Palka wrote: Tested on x86_64-pc-linux-gnu, does this look OK for trunk? Declaring get() inline seems necessary to avoid link failure: /usr/bin/ld: /tmp/ccwdv6Co.o: in function `g3@pr105322.Decltype()': decltype-1_b.C:(.text._ZW8pr105322W8Decltype2g3v[_ZW8pr105

Re: [PATCH v2 3/4] build: Add libgrust as compilation modules

2023-10-25 Thread Thomas Schwinge
Hi! On 2023-10-25T13:06:48+0200, Arthur Cohen wrote: > From: Pierre-Emmanuel Patry > > Define the libgrust directory as a host compilation module as well as > for targets. I don't see a response to Richard's comments:

Re: [PATCH] internal-fn: Add VCOND_MASK_LEN.

2023-10-25 Thread Richard Sandiford
Robin Dapp writes: >> At first, this seemed like an odd place to fold away the length. >> AFAIK the length in res_op is inherited directly from the original >> operation, and so it isn't any more redundant after the fold than >> it was before. But I suppose the reason for doing it here is that >>

Re: HELP: Will the reordering happen? Re: [V3][PATCH 0/3] New attribute "counted_by" to annotate bounds for C99 FAM(PR108896)

2023-10-25 Thread Kees Cook
On Tue, Oct 24, 2023 at 07:51:55PM -0400, Siddhesh Poyarekar wrote: > Yes, that's the tradeoff. However, maybe this is the point where Kees jumps > in and say the kernel doesn't really care as much or something like that :) "I only care about -O2" :) -- Kees Cook

Re: HELP: Will the reordering happen? Re: [V3][PATCH 0/3] New attribute "counted_by" to annotate bounds for C99 FAM(PR108896)

2023-10-25 Thread Kees Cook
On Wed, Oct 25, 2023 at 01:27:29PM +, Qing Zhao wrote: > A. Add an additional argument, the size parameter, to __bdos, > A.1, during FE; > A.2, during gimplification phase; I just wanted to clarify that this is all just an "internal" detail, yes? i.e. the __bdos() used by in C cod

[PATCH] internal-fn: Add VCOND_MASK_LEN.

2023-10-25 Thread 钟居哲
>> Which one is right? Hi, Richard. Let me explain this situation. Both situations are possible. It's depending on the 'ELSE' value whether it is unitialized value. For reduction case: for (int i = 0; i < n; i++) result += a[i] The trailing elements should be well-defined, keep the original

Re: HELP: Will the reordering happen? Re: [V3][PATCH 0/3] New attribute "counted_by" to annotate bounds for C99 FAM(PR108896)

2023-10-25 Thread Qing Zhao
> On Oct 25, 2023, at 6:06 PM, Kees Cook wrote: > > On Wed, Oct 25, 2023 at 01:27:29PM +, Qing Zhao wrote: >> A. Add an additional argument, the size parameter, to __bdos, >> A.1, during FE; >> A.2, during gimplification phase; > > I just wanted to clarify that this is all just

Re: [PATCH] internal-fn: Add VCOND_MASK_LEN.

2023-10-25 Thread Richard Sandiford
钟居哲 writes: >>> Which one is right? > Hi, Richard. Let me explain this situation. > > Both situations are possible. It's depending on the 'ELSE' value whether it > is unitialized value. > > For reduction case: > > for (int i = 0; i < n; i++) > result += a[i] > > The trailing elements should be

Re: HELP: Will the reordering happen? Re: [V3][PATCH 0/3] New attribute "counted_by" to annotate bounds for C99 FAM(PR108896)

2023-10-25 Thread Kees Cook
On Wed, Oct 25, 2023 at 10:27:41PM +, Qing Zhao wrote: > > > > On Oct 25, 2023, at 6:06 PM, Kees Cook wrote: > > > > On Wed, Oct 25, 2023 at 01:27:29PM +, Qing Zhao wrote: > >> A. Add an additional argument, the size parameter, to __bdos, > >> A.1, during FE; > >> A.2, during

Re: Re: [PATCH] internal-fn: Add VCOND_MASK_LEN.

2023-10-25 Thread 钟居哲
Yeah. I think Robin may need this : TREE_CODE (else_val) == SSA_NAAME && SSA_NAME_IS_DEFAULT_DEF (else_val) && VAR_P (SSA_NAME_VAR (else_val)) to differentiate whether the ELSE VALUE is uninitialized SSA or not. juzhe.zh...@rivai.ai From: Richard Sandiford Date: 2023-10-26 06:32 To: 钟居哲 C

Re: PR111754

2023-10-25 Thread Richard Sandiford
Prathamesh Kulkarni writes: > On Wed, 25 Oct 2023 at 02:58, Richard Sandiford > wrote: >> >> Hi, >> >> Sorry the slow review. I clearly didn't think this through properly >> when doing the review of the original patch, so I wanted to spend >> some time working on the code to get a better underst

Re: [PATCH] bpf: Improvements in CO-RE builtins implementation.

2023-10-25 Thread David Faust
On 10/25/23 11:51, Cupertino Miranda wrote: > Hi everyone, > > This patch contains some more recent improvements to BPF CO-RE builtins. > Please find further details of the changes on the patch header. > > Looking forward for your review and comments. > > Best regards, > Cupertino Miranda Hi

Re: [PATCH] bpf: Improvements in CO-RE builtins implementation.

2023-10-25 Thread Cupertino Miranda
Hi David, Thanks for the comments. I have just realized that I introduced several errors in the patch by mistake right before I sent it. Like the missing "*". Apologies, I will revise it and send a new patch in a moment. Thanks, Cupertino David Faust writes: > On 10/25/23 11:51, Cupertino Mi

Re: [RFC] RISC-V: elide sign extend when expanding cmp_and_jump

2023-10-25 Thread Vineet Gupta
On 10/24/23 22:01, Vineet Gupta wrote: RV64 comapre and branch instructions only support 64-bit operands. The backend unconditionally generates zero/sign extend at Expand time for compare and branch operands even if they are already as such e.g. function args which ABI guarantees to be sign-exten

[PATCH] RISC-V: Pass abi to g++ rvv testsuite

2023-10-25 Thread Patrick O'Neill
On rv32gcv testcases like g++.target/riscv/rvv/base/bug-22.C fail with: FAIL: g++.target/riscv/rvv/base/bug-22.C (test for excess errors) Excess errors: cc1plus: error: ABI requires '-march=rv32' This patch adds the -mabi argument to g++ rvv tests. gcc/testsuite/ChangeLog: * g++.target/r

Re: Re: [PATCH] RISC-V: Add AVL propagation PASS for RVV auto-vectorization

2023-10-25 Thread juzhe.zh...@rivai.ai
FAIL: gcc.dg/vect/costmodel/riscv/rvv/dynamic-lmul4-5.c -O3 -ftree-vectorize --param riscv-autovec-lmul=dynamic  scan-assembler e32,m4 FAIL: gcc.dg/vect/costmodel/riscv/rvv/dynamic-lmul8-2.c -O3 -ftree-vectorize --param riscv-autovec-lmul=dynamic  scan-assembler e32,m8 These 2 FAILs are bogus. T

[PATCH V2 1/2] Pass type of comparison operands instead of comparison result to truth_type_for in build_vec_cmp.

2023-10-25 Thread liuhongt
>I think it's indeed on purpose that the result of v1 < v2 is a signed >integer vector type. >But build_vec_cmp should not use the truth type for the result but instead the >truth type for the comparison, so Change build_vec_cmp in both c/c++, also notice for jit part, it already uses type of comp

[PATCH V2 2/2] Support vec_cmpmn/vcondmn for v2hf/v4hf.

2023-10-25 Thread liuhongt
>vcond and vcondeq shouldn't be necessary if there's >vcond_mask and vcmp support which is the "modern" >way of handling vcond. Unless the ISA really can do >compare and select with a single instruction. The V2 patch remove vcond/vcondu from the initial version[1], but there're many optimizations

Re: Re: [PATCH] RISC-V: Add AVL propagation PASS for RVV auto-vectorization

2023-10-25 Thread juzhe.zh...@rivai.ai
I think it's QEMU issue: line 15: 1520161 Aborted                 (core dumped) QEMU_CPU="$(march-to-cpu-opt --get-riscv-tag $1)" qemu-riscv$xlen -r 5.10 "${qemu_args[@]}" -L ${RISC_V_SYSROOT} "$@" FAIL: gcc.target/riscv/rvv/autovec/gather-scatter/mask_gather_load_run-11.c execution test I use

[RFC] RISC-V: Support -mcmodel=large.

2023-10-25 Thread KuanLin Chen
This is a RFC patch for large code model implementation. gcc/ChangeLog: * gcc/config/riscv/predicates.md(move_operand): Check SYMBOL_REF and LABEL_REF type. (call_insn_operand): Support for CM_Large. (pcrel_symbol_operand): New. * gcc/config/riscv/riscv-c.cc (riscv_cpu_cpp_builtins): Add builtin_d

[PATCH v2] VECT: Remove the type size restriction of vectorizer

2023-10-25 Thread pan2 . li
From: Pan Li Update in v2: * Fix one ICE of type assertion. * Adjust some test cases for aarch64 sve and riscv vector. Original log: The vectoriable_call has one restriction of the size of data type. Aka DF to DI is allowed but SF to DI isn't. You may see below message when try to vectorize fu

[PATCH] libgcov: Fix gcov overlap bugs of divide to 0

2023-10-25 Thread Xionghu Luo
Fix the long lasting issue of `gcov-tool overlap xxx yyy`, divide to 0 caused the output shows a lot of nans, another problem is the counts in file are never acculated leads to incorrect results. Signed-off-by: Xionghu Luo libgcc/ChangeLog: * libgcov-util.c (compute_one_gcov): Avoid di

[PATCH] DOC: Update COND_LEN document

2023-10-25 Thread Juzhe-Zhong
As Richard's suggested. We need to adapt doc for cond_len operations. gcc/ChangeLog: * doc/md.texi: Update document. --- gcc/doc/md.texi | 2 ++ 1 file changed, 2 insertions(+) diff --git a/gcc/doc/md.texi b/gcc/doc/md.texi index daa318ee3da..dd2c26edf7b 100644 --- a/gcc/doc/md.texi ++

Re: [PATCH] Ignore case of header line in dg-extract-results.py

2023-10-25 Thread Alexandre Oliva
On Oct 24, 2023, Paul Iannetta wrote: > * dg-extract-results.py: Make the test_run regex case > insensitive. It looks reasonable to me, but I'm not sure this is a change I'm entitled to approve. Thanks! -- Alexandre Oliva, happy hackerhttps://FSFLA.org/blogs/lxo/

Re: [PATCH] Ignore case of header line in dg-extract-results.py

2023-10-25 Thread Jeff Law
On 10/25/23 22:09, Alexandre Oliva wrote: On Oct 24, 2023, Paul Iannetta wrote: * dg-extract-results.py: Make the test_run regex case insensitive. It looks reasonable to me, but I'm not sure this is a change I'm entitled to approve. Thanks! Even so, I trust your judgme

Re: PR111754

2023-10-25 Thread Prathamesh Kulkarni
On Thu, 26 Oct 2023 at 04:09, Richard Sandiford wrote: > > Prathamesh Kulkarni writes: > > On Wed, 25 Oct 2023 at 02:58, Richard Sandiford > > wrote: > >> > >> Hi, > >> > >> Sorry the slow review. I clearly didn't think this through properly > >> when doing the review of the original patch, so

[PATCH][_Hashtable] Use RAII to restore Rehash state

2023-10-25 Thread François Dumont
    libstdc++: [_Hashtable] Use RAII type to manage rehash functor state     Replace usage of __try/__catch with a RAII type to restore rehash functor     state when needed.     libstdc++-v3/ChangeLog:     * include/bits/hashtable_policy.h (_RehashStateGuard): New.     (_Inser

Re: HELP: Will the reordering happen? Re: [V3][PATCH 0/3] New attribute "counted_by" to annotate bounds for C99 FAM(PR108896)

2023-10-25 Thread Jakub Jelinek
On Wed, Oct 25, 2023 at 07:03:43PM +, Qing Zhao wrote: > For the code generation impact: > > turning the original x.buf > to a builtin function call > __builtin_with_access_and_size(x,buf, x.L,-1) > > might inhibit some optimizations from happening before the builtin is > evaluated into obj

Re: [PATCH v4] Introduce strub: machine-independent stack scrubbing

2023-10-25 Thread Alexandre Oliva
Ping? https://gcc.gnu.org/pipermail/gcc-patches/2023-October/633675.html I'm combining the gcc/ipa-strub.cc bits from https://gcc.gnu.org/pipermail/gcc-patches/2023-October/633526.html -- Alexandre Oliva, happy hackerhttps://FSFLA.org/blogs/lxo/ Free Software Activist

Re: [PATCH] rename make_eh_edges to make_eh_edge

2023-10-25 Thread Alexandre Oliva
On Oct 20, 2023, Richard Biener wrote: > OK. Thanks. >> * tree-eh.h (make_eh_edges): Rename to... >> (make_eh_edge): ... this. >> * tree-eh.cc: Likewise. Adjust all callers. Ugh, "Adjust all callers" is no longer enough, all files need to be mentioned explicitly. So I'm pushing it with:

<    1   2