On Wed, Jan 4, 2023 at 9:54 AM Jose E. Marchesi via Gcc-patches
wrote:
>
>
> ping.
> Would this be a good approach for fixing the issue?
adding the is_libcall bit enlarges rtx_def by 8 bytes - there's no room for more
bits here.
I really wonder how other targets avoid the issue you are pointing
On Mon, Jan 09, 2023 at 09:05:26AM +0100, Richard Biener wrote:
> On Wed, Jan 4, 2023 at 9:54 AM Jose E. Marchesi via Gcc-patches
> wrote:
> >
> >
> > ping.
> > Would this be a good approach for fixing the issue?
>
> adding the is_libcall bit enlarges rtx_def by 8 bytes - there's no room for
> m
Hi!
The last testcase in this patch ICEs, because
maybe_init_list_as_range -> maybe_init_list_as_array
calls maybe_constant_init in:
/* Don't do this if the conversion would be constant. */
Hi!
On powerpc64le-linux, the following patch fixes
-FAIL: gcc.dg/c2x-stdarg-4.c execution test
-FAIL: gcc.dg/torture/c2x-stdarg-split-1a.c -O0 execution test
-FAIL: gcc.dg/torture/c2x-stdarg-split-1a.c -O1 execution test
-FAIL: gcc.dg/torture/c2x-stdarg-split-1a.c -O2 execution test
-FAI
Hi.
After the new hash_set checking code, we face an issue where deleted value
is added to a hash_set. Fix it.
Patch can bootstrap on x86_64-linux-gnu and survives regression tests.
Ready to be installed?
Thanks,
Martin
PR lto/108330
gcc/ChangeLog:
* lto-cgraph.cc (compute_lt
We now properly optimize this testcase and no longer diagnose
a bogus uninit use.
Tested on x86_64-unknown-linux-gnu, pushed.
PR tree-optimization/101912
* gcc.dg/uninit-pr101912.c: New testcase.
---
gcc/testsuite/gcc.dg/uninit-pr101912.c | 21 +
1 file change
When the CFG has not merged equal PHI defs in a switch stmt the
cost model from switch conversion gets off and we prefer a
jump table over branches. The following fixes that by recording
cases that will be merged later and more appropriately counting
unique values.
Bootstrapped and tested on x86_
On 1/7/23 14:12, John David Anglin wrote:
Tested on trunk and gcc-12 with hppa64-hp-hpux11.11.
ah, I see that is the use that was unprotected, ok.
Okay?
Dave
---
Fix compilation of server.cc on hpux.
Select and FD_ISSET are declared in sys/time.h on most versions
of hpux. As a result, H
On Mon, 9 Jan 2023, Jakub Jelinek wrote:
> Hi!
>
> On powerpc64le-linux, the following patch fixes
> -FAIL: gcc.dg/c2x-stdarg-4.c execution test
> -FAIL: gcc.dg/torture/c2x-stdarg-split-1a.c -O0 execution test
> -FAIL: gcc.dg/torture/c2x-stdarg-split-1a.c -O1 execution test
> -FAIL: gcc.dg/
On Mon, Jan 9, 2023 at 11:53 AM Martin Liška wrote:
>
> Hi.
>
> After the new hash_set checking code, we face an issue where deleted value
> is added to a hash_set. Fix it.
>
> Patch can bootstrap on x86_64-linux-gnu and survives regression tests.
>
> Ready to be installed?
OK
> Thanks,
> Martin
On Fri, 23 Dec 2022 04:13:03 -0800
Julian Brown wrote:
> This patch adds support for "declare mapper" directives (and the
> "mapper" modifier on "map" clauses) for C. As for C++, arrays of
> custom-mapped objects are not supported yet.
Here's a small follow-up for this one.
Re-tested (with pre
The following addresses a long standing issue with not preserving
accesses to non-volatile objects through volatile qualified
pointers in the case that object gets expanded to a register. The
fix is to treat accesses to an object with a volatile qualified
access as forcing that object to memory.
On Sun, Jan 8, 2023 at 5:21 PM Thomas Koenig wrote:
>
> Hi Richard,
>
> >> Am 08.01.2023 um 14:31 schrieb Paul Richard Thomas via Fortran
> >> :
> >>
> >> Hi Thomas,
> >>
> >> Following your off-line explanation that the seemingly empty looking
> >> assembly line forces an effective reload from
On Mon, Jan 9, 2023 at 10:58 AM Jakub Jelinek wrote:
>
> On Mon, Jan 09, 2023 at 09:05:26AM +0100, Richard Biener wrote:
> > On Wed, Jan 4, 2023 at 9:54 AM Jose E. Marchesi via Gcc-patches
> > wrote:
> > >
> > >
> > > ping.
> > > Would this be a good approach for fixing the issue?
> >
> > adding
On Mon, Jan 09, 2023 at 02:04:48PM +0100, Richard Biener via Gcc-patches wrote:
> On Mon, Jan 9, 2023 at 10:58 AM Jakub Jelinek wrote:
> >
> > On Mon, Jan 09, 2023 at 09:05:26AM +0100, Richard Biener wrote:
> > > On Wed, Jan 4, 2023 at 9:54 AM Jose E. Marchesi via Gcc-patches
> > > wrote:
> > > >
The result of a POPCOUNT operation in RTL should have the same mode
as its operand. This corrects the specification of popcount in
the nvptx backend, splitting the current generic define_insn into
two, one for popcountsi2 and the other for popcountdi2 (the latter
with an explicit truncate).
This
On 1/9/23 02:57, Jakub Jelinek via Gcc-patches wrote:
On Mon, Jan 09, 2023 at 09:05:26AM +0100, Richard Biener wrote:
On Wed, Jan 4, 2023 at 9:54 AM Jose E. Marchesi via Gcc-patches
wrote:
ping.
Would this be a good approach for fixing the issue?
adding the is_libcall bit enlarges rtx_d
The early out for user-id handling indicated commutative
rather than not commutative.
Bootstrapped and tested on x86_64-unkown-linux-gnu, pushed.
PR middle-end/108209
* genmatch.cc (commutative_op): Fix return value for
user-id with non-commutative first replacement.
---
From: Eric Botcazou
The expansion of (class-wide) interface objects generates a temporary that
holds the actual data and the objects are rewritten as the renaming of the
dereference at the interface tag present in it. These temporaries may need
to be finalized and this is currently done through t
From: Eric Botcazou
The "then" arm of these nested if-statements is trivially unreachable.
gcc/ada/
* exp_ch7.adb (Make_Adjust_Call): Remove unreachable statement.
(Make_Final_Call): Likewise.
Tested on x86_64-pc-linux-gnu, committed on master.
---
gcc/ada/exp_ch7.adb | 12 ++
Andrea Corallo via Gcc-patches writes:
> Richard Earnshaw writes:
>
>> On 27/09/2022 16:24, Kyrylo Tkachov via Gcc-patches wrote:
>>>
-Original Message-
From: Andrea Corallo
Sent: Tuesday, September 27, 2022 11:06 AM
To: Kyrylo Tkachov
Cc: Andrea Corallo via G
This patch addresses PR rtl-optimization/107991, which is a P2 regression
where GCC currently requires more "mov" instructions than GCC 7.
The x86's two address ISA creates some interesting challenges for reload.
For example, the tricky "x = y - x" usually needs to be implemented on x86
as
> On Jan 9, 2023, at 2:11 AM, Richard Biener wrote:
>
> On Thu, 22 Dec 2022, Qing Zhao wrote:
>
>>
>>
>>> On Dec 22, 2022, at 2:09 AM, Richard Biener wrote:
>>>
>>> On Wed, 21 Dec 2022, Qing Zhao wrote:
>>>
Hi, Richard,
Thanks a lot for your comments.
> On Dec 21
The astute among you may have noticed that I in fact sent no patches.
This is for two reasons--
1. Google did something behind the scenes and broke git send-email for me again
2. Thanks to Iain Sandoe, the build now completes, and he provided a
couple other fixes as well. There are still a coupl
On 1/6/23 19:23, Jonathan Wakely wrote:
Seems to me that GCC code should just use nullptr directly not redefine NULL.
Sure, but that would lead to a huge patch which would rename NULL to nullptr,
right?
Martin
On 1/6/23 17:50, Martin Jambor wrote:
Hi,
On Fri, Jan 06 2023, Martin Liška wrote:
Hi Martin
+ key.unit_offset = unit_offset;
+ ipa_param_body_replacement *res
+= std::lower_bound (m_replacements.begin (), m_replacements.end (), key,
+ [] (const ipa_param_body_repl
On Mon, 9 Jan 2023 at 15:17, Martin Liška wrote:
>
> On 1/6/23 19:23, Jonathan Wakely wrote:
> > Seems to me that GCC code should just use nullptr directly not redefine
> > NULL.
>
> Sure, but that would lead to a huge patch which would rename NULL to nullptr,
> right?
Yeah, which can probably
Tested on x86_64-pc-linux-gnu, committed on trunk
gcc/ada/
* accessibility.adb, accessibility.ads, ada_get_targ.adb: Update
copyright year.
* adabkend.adb, adabkend.ads, adadecode.c, adadecode.h, adaint.c:
Likewise.
* adaint.h, affinity.c, ali-util.adb, ali-util.ads, a
Hi Richard,
There is no reliable way to get this correct at the moment and if there
were good and easy ways to get this working they'd be implemented already.
OK, I then withdraw the patch (and have unassigned myself from the PR).
Best regards
Thomas
On Wed, 5 Oct 2022, Patrick Palka wrote:
> On Thu, 7 Jul 2022, Jonathan Wakely via Gcc-patches wrote:
>
> > This adds a new built-in to replace the recursive class template
> > instantiations done by traits such as std::tuple_element and
> > std::variant_alternative. The purpose is to select the
On 09/01/2023 14:58, Andrea Corallo via Gcc-patches wrote:
Andrea Corallo via Gcc-patches writes:
Richard Earnshaw writes:
On 27/09/2022 16:24, Kyrylo Tkachov via Gcc-patches wrote:
-Original Message-
From: Andrea Corallo
Sent: Tuesday, September 27, 2022 11:06 AM
To: Kyrylo
On Mon, Jan 9, 2023 at 4:01 PM Roger Sayle wrote:
>
>
> This patch addresses PR rtl-optimization/107991, which is a P2 regression
> where GCC currently requires more "mov" instructions than GCC 7.
>
> The x86's two address ISA creates some interesting challenges for reload.
> For example, the tric
On 09/01/2023 14:58, Andrea Corallo via Gcc-patches wrote:
Andrea Corallo via Gcc-patches writes:
Richard Earnshaw writes:
On 27/09/2022 16:24, Kyrylo Tkachov via Gcc-patches wrote:
-Original Message-
From: Andrea Corallo
Sent: Tuesday, September 27, 2022 11:06 AM
To: Kyrylo
Hi!
I'd like to ping a few pending patches:
https://gcc.gnu.org/pipermail/gcc-patches/2022-November/606973.html
- PR107465 - c-family: Fix up -Wsign-compare BIT_NOT_EXPR handling
https://gcc.gnu.org/pipermail/gcc-patches/2022-November/607104.html
- PR107465 - c-family: Incremental fix for -W
On 09/01/2023 16:48, Richard Earnshaw via Gcc-patches wrote:
On 09/01/2023 14:58, Andrea Corallo via Gcc-patches wrote:
Andrea Corallo via Gcc-patches writes:
Richard Earnshaw writes:
On 27/09/2022 16:24, Kyrylo Tkachov via Gcc-patches wrote:
-Original Message-
From: Andrea
Friendly ping
On Mon, Dec 26, 2022 at 12:34 PM Flavio Cruz wrote:
> Tested by building a toolchain and compiling gnumach for x86_64 [1].
> This is the basic version without unwind support which I think is only
> required to
> implement exceptions.
>
> [1] https://github.com/flavioc/cross-hurd/bl
On Mon, 9 Jan 2023, Patrick Palka wrote:
> On Wed, 5 Oct 2022, Patrick Palka wrote:
>
> > On Thu, 7 Jul 2022, Jonathan Wakely via Gcc-patches wrote:
> >
> > > This adds a new built-in to replace the recursive class template
> > > instantiations done by traits such as std::tuple_element and
> > >
This patch fixes PR rtl-optimization/106421, an ICE-on-valid (but
undefined) regression. The fix, as proposed by Richard Biener, is to
defend against BLOCK_FOR_INSN returning NULL in cprop's bypass_block.
This patch has been tested on x86_64-pc-linux-gnu with make bootstrap
and make -k check, bo
> fixed now.
> bootstrapped successfully!
Thanks for fixing it. Another way out is to hide the Win32 API by defining
__GTHREAD_HIDE_WIN32API like libstdc++ does in its header files.
--
Eric Botcazou
The C rule against modifiable objects with static storage duration in
inline definitions should apply to compound literals (using the C2x
feature of storage-class specifiers for compound literals) just as to
variables. Add a call to record_inline_static for compound literals
to make sure this case
Hi,
the Modula-2 documentation is rejected by older versions of Makeinfo because
the web of @node markers is fairly broken, apparently some subsections were
moved around, most notably between the Overview and Using sections, and the
@node markers were not (properly) adjusted.
This patch allows
From: Ju-Zhe Zhong
This patch is a NFC patch to move the codes into a wrapper function so that
they can be reused. I will reuse them in the following patches.
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc
(vector_infos_manager::create_bitmap_vectors): New function.
(vector_info
On 1/9/23 05:19, Jakub Jelinek wrote:
Hi!
The last testcase in this patch ICEs, because
maybe_init_list_as_range -> maybe_init_list_as_array
calls maybe_constant_init in:
/* Don't do this if the conversion would be constant. */
first = maybe_constant_init (first);
if (TREE_CONSTANT (fi
From: Ju-Zhe Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (pass_vsetvl::forward_demand_fusion):
Add pre-check for redundant flow.
---
gcc/config/riscv/riscv-vsetvl.cc | 8
1 file changed, 8 insertions(+)
diff --git a/gcc/config/riscv/riscv-vsetvl.cc b/gcc/config/riscv
Eric Botcazou writes:
> Hi,
>
> the Modula-2 documentation is rejected by older versions of Makeinfo because
> the web of @node markers is fairly broken, apparently some subsections were
> moved around, most notably between the Overview and Using sections, and the
> @node markers were not (pro
The existing logic in bpf_print_operand was only correct for integral
CONST_DOUBLEs, and emitted garbage for floating point modes. Fix it so
floating point mode operands are correctly handled.
Tested on bpf-unknown-none, no known regressions.
OK to check-in?
Thanks.
PR target/108293
gc
From: Ju-Zhe Zhong
This NFC patch is preparing for the following patches.
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (pass_vsetvl::backward_demand_fusion):
Refine codes.
---
gcc/config/riscv/riscv-vsetvl.cc | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git
From: Ju-Zhe Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (pass_vsetvl::backward_demand_fusion):
Add pre-check to avoid redundant flow.
---
gcc/config/riscv/riscv-vsetvl.cc | 2 ++
1 file changed, 2 insertions(+)
diff --git a/gcc/config/riscv/riscv-vsetvl.cc b/gcc/config/riscv
From: Ju-Zhe Zhong
Since the PASS is implemented base on RTL_SSA framework.
According to rtl_ssa, they name insn_info * as insn and
name rtx_insn * rinsn. I follow this rule in this pass but I missed
this function. So rename it to make codes be consistent to RTL_SSA
framework.
gcc/ChangeLog:
From: Ju-Zhe Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (vector_insn_info::operator==): Remove
dirty_pat.
(vector_insn_info::merge): Ditto.
(vector_insn_info::dump): Ditto.
(pass_vsetvl::merge_successors): Ditto.
(pass_vsetvl::backward_demand_fus
From: Ju-Zhe Zhong
Notice that the PASS is just simpily pick the probability >= 50%
to do the backward fusion which will create endless loop on Phase 3.
Adding this probability to fix this bug.
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc
(vector_infos_manager::vector_infos_manager):
From: Ju-Zhe Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (pass_vsetvl::done): Add DCE.
* config/riscv/t-riscv: Add DCE.
---
gcc/config/riscv/riscv-vsetvl.cc | 2 ++
gcc/config/riscv/t-riscv | 2 +-
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/gc
From: Ju-Zhe Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (same_bb_and_before_p): Remove it.
(real_insn_and_same_bb_p): New function.
(same_bb_and_after_or_equal_p): Remove it.
(before_p): New function.
(reg_killed_by_bb_p): Ditto.
(has_vset
From: Ju-Zhe Zhong
gcc/testsuite/ChangeLog:
* gcc.target/riscv/rvv/vsetvl/imm_bb_prop-3.c: Adjust testcase.
* gcc.target/riscv/rvv/vsetvl/imm_bb_prop-4.c: Ditto.
* gcc.target/riscv/rvv/vsetvl/imm_conflict-4.c: Ditto.
* gcc.target/riscv/rvv/vsetvl/imm_conflict-5.c:
From: Ju-Zhe Zhong
gcc/testsuite/ChangeLog:
* gcc.target/riscv/rvv/vsetvl/avl_single-2.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-20.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-21.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-22.c: New
From: Ju-Zhe Zhong
gcc/testsuite/ChangeLog:
* gcc.target/riscv/rvv/vsetvl/avl_single-1.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-10.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-11.c: New test.
* gcc.target/riscv/rvv/vsetvl/avl_single-12.c: New
On 12/6/22 09:47, Gaius Mulley via Gcc-patches wrote:
Here are the dejagnu expect library scripts for the gm2
testsuite.
A couple of weeks ago I noticed on a testrun that the modula tests
didn't seem to be timing out properly, so I made this change. It looks
like they didn't run at all in th
PR-108142 Modula-2 configure generates many subdirectories in the top
build directory. This patch dynamically creates subdirectories under
gcc/m2 if and when required.
Bootstrapped on x86_64 gnu/linux, ok for master?
regards,
Gaius
gcc/m2/ChangeLog:
* Make-lang.in (GM2_1): Change -B
On 1/8/23 21:18, Gaius Mulley wrote:
Jeff Law via Gcc-patches writes:
I've been getting sporatic errors like this since the introduction of
the modula-2 front-end:
In file included from ../../..//gcc/gcc/m2/mc-boot/GSFIO.c:29:
../../..//gcc/gcc/system.h:556:20: error: conflicting declarat
On Fri, Jan 06, 2023 at 07:41:07PM -0500, Michael Meissner wrote:
> On Wed, Dec 21, 2022 at 09:40:24PM +, Joseph Myers wrote:
> > On Wed, 21 Dec 2022, Segher Boessenkool wrote:
> >
> > > > --- a/gcc/tree.cc
> > > > +++ b/gcc/tree.cc
> > > > @@ -9442,15 +9442,6 @@ build_common_tree_nodes (bool
Until now, we applied COSTS_N_INSNS() (multiplying by 4) after dividing
the instruction length by 3, so we couldn't express the difference less
than modulo 3 in insn cost for size (e.g. 11 Bytes and 12 bytes cost the
same).
This patch fixes that.
;; 2 bytes
addi.n a2, a2, -1 ; cost 3
;; 3
Jeff Law writes:
> I'm still seeing it as of about 2 hours ago:
>
> http://law-sandy.freeddns.org:8080/job/avr-elf/2125/console
>
> A good run (yesterday):
>
> http://law-sandy.freeddns.org:8080/job/avr-elf/2124/console
>
>
Hi Jeff,
many thanks for the urls above - useful I'll attempt to reprodu
Hi,
this patch adds more tunes for zen4:
- new tunes for avx512 scater instructions.
In micro benchmarks these seems consistent loss compared to open-coded coe
- disable use of gather for zen4
While these are win for a micro benchmarks (based on TSVC), enabling gather
is a loss for par
On Tue, Jan 10, 2023 at 12:32 PM Jan Hubicka via Gcc-patches
wrote:
>
>
> Hi,
> this patch adds more tunes for zen4:
> - new tunes for avx512 scater instructions.
>In micro benchmarks these seems consistent loss compared to open-coded coe
> - disable use of gather for zen4
>While these a
> However, I noticed when I run ./contrib/update-copyright.py --this-year
> I get much more modifications out of contrib folder:
@Jakub?
Martin
65 matches
Mail list logo