On Thu, Jun 11, 2020 at 02:31:44PM -0400, Jason Merrill wrote:
> On 6/10/20 5:11 PM, Marek Polacek wrote:
> > Since r10-7096 convert_like, when called in a template, creates an
> > IMPLICIT_CONV_EXPR when we're converting to/from array type.
> >
> > In this test, we have e[f], and we're converting
On 6/16/20 3:30 PM, Segher Boessenkool wrote:
> We have had before
>
> * config/rs6000/rs6000.md (define_attr "type"): New type popcnt.
>
> and
>
> * config/rs6000/rs6000.md ('type' attribute): Add
> veclogical,veccmpfx,vecexts,vecmove insn types.
>
> (Both are fine, dou
On Tue, 2020-06-16 at 13:59 -0500, Peter Bergner wrote:
> On 6/15/20 5:43 PM, will schmidt wrote:
> > On Mon, 2020-06-15 at 14:56 -0500, Peter Bergner via Gcc-patches wrote:
> > > * config/rs6000/rs6000-cpus.def (OTHER_FUTURE_MASKS): Add
> > > OPTION_MASK_MMA.
> > > (POWERPC_MASKS): Likewise.
This improves the previous fix for PR 95282, and extends it to also
apply to the exchange function (which has a similar problem and would
become ill-formed with my proposed fix for PR 95378).
PR libstdc++/95282
* include/bits/atomic_base.h (__atomic_impl::load): Use the _Val
C++20 adds some new preconditions to std::atomic, which weren't
previously checked by our implementation.
* include/std/atomic (atomic): Add static assertions.
* testsuite/29_atomics/atomic/requirements/types_neg.cc: New test.
Tested powerpc64le-linux, committed to master.
commit
Hi,
This patch moves a couple code duplications into its own routine, the
checkAction global parameter is now initialized and properly adjusted.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-codegen.cc (build_array_b
Hi,
This patch replaces uses of casting to TypeFunction with toTypeFunction,
which takes care of asserting that `ty' is a `Tfunction'.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-frontend.cc (eval_builtin): Use toT
Hi,
This patch replaces uses of casting to StringExp with toStringExp.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-attribs.cc (build_attributes): Use toStringExp instead of cast.
* toir.cc (IRVisitor::visit
On Tue, 2020-06-16 at 18:04 +0100, Jonathan Wakely via Gcc-patches wrote:
> This was reported on the gcc-help mailing list. The regression started
> with r10-589 and was fixed by r11-963.
>
> gcc/testsuite/ChangeLog:
>
> * g++.dg/torture/pr95493-1.C: New test.
>
> Tested x86_64-linux. OK f
Hi,
This patch replaces uses of casting to Expression nodes with the newly
introduced isXxxxExp functions.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-attribs.cc (build_attributes): Use isXxxxExp helpers instead of
Hi,
This patch replaces ARG_UNUSED and ATTRIBUTE_UNUSED with unnamed
parameters. As the unused attribute was being used incorrectly.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-attribs.cc (handle_noreturn_attribut
Hi,
This patch updates comments to consistently format quotations in code
comments throughout the D front-end.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-builtins.cc: Update quotation formatting of comments.
Hi,
This patch replaces some uses of File with FILE. Memory allocated by
the DMD front-end is never freed due to the bump pointer allocator used
internally.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-lang.cc (d_p
Hi,
This patch replaces some uses of OutBuffer with obstack. Memory
allocated by the DMD front-end is never freed due to the
bump pointer allocator used internally.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-diag
Hi,
This patch is a mechanical update of various formatting to make it
consistent throughout the D front-end.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-attribs.cc: Update code formatting in a consistant style.
Hi,
This patch replaces uses of casting to Type nodes with the newly
introduced isTypeXxxx functions.
Bootstrapped and regression tested on x86_64-linux-gnu, and committed to
master.
Regards
Iain
gcc/d/ChangeLog:
* d-builtins.cc (d_eval_constant_expression): Use isTypeXxxx helpers
Currently the __atomic_{load,store,exchange,compare_exchange} built-ins
will happily store values through pointers to const, or use pointers to
volatile as the input and output arguments. This patch ensures that any
pointer that will be written through does not point to a const object,
and only the
This patch series collects several improvements/bugfixes to the reference
counting and manual deep-copy implementation for OpenACC, mostly based
on review feedback from Thomas. In short, areas addressed are:
- Some unexpectedly-dead code in goacc_enter_data_internal
introduced by "Adjust dyna
This is a slightly-updated version of the patch sent here, with some of
Thomas's suggestions incorporated:
https://gcc.gnu.org/pipermail/gcc-patches/2020-June/547407.html
I'm still assuming this is approved, but including for completeness.
Julian
ChangeLog
gcc/fortran/
* trans
Later patches in this series assume that GOMP_MAP_ATTACH will be grouped
together with a preceding GOMP_MAP_TO_PSET or other "to" data movement
clause, except in cases where an explicit "attach" clause is used.
This patch arranges for that to be so.
OK?
Julian
ChangeLog
libgomp/
This is a new version of the patch last sent here:
https://gcc.gnu.org/pipermail/gcc-patches/2020-May/546332.html
Minus the bits that Thomas has committed already (thanks!), and with
adjustments to allow for GOMP_MAP_ATTACH being grouped together with a
preceding clause.
OK?
Julian
ChangeLog
This is a minor cleanup for goacc_enter_datum. Unchanged from previous
posting, but including for completeness:
https://gcc.gnu.org/pipermail/gcc-patches/2020-May/546331.html
OK?
Julian
ChangeLog
libgomp/
* oacc-mem.c (goacc_enter_datum): Use scalar kind argument instead of
This is a repost of the following:
https://gcc.gnu.org/pipermail/gcc-patches/2020-May/546333.html
I made a minor edit to the ChangeLog, but the patch is otherwise
unchanged. Including for completeness.
OK?
ChangeLog
PR libgomp/92843
libgomp/
* oacc-mem.c (goacc_exit_d
When attaching pointers in Fortran, OpenACC 2.6 specifies that a
descriptor must be copied to the target at the same time (see next
patch). That means that stripping GOMP_MAP_TO_PSET (and lesserly,
GOMP_MAP_POINTER), which was behaviour introduced by the manual deep-copy
middle-end support patch,
This is a fix for the pointer (or array) size inadvertently being used
for the bias of attach and detach clauses (PR95270), for C and C++.
OK?
Julian
ChangeLog
PR middle-end/95270
gcc/c/
* c-typeck.c (c_finish_omp_clauses): Set OMP_CLAUSE_SIZE (bias) to zero
for
This patch fixes a set of XFAILs in some recently-added patches by
skipping a detach operation on "no-op" exit data operations for blocks
with zero dynamic refcount. This takes advantage of the ordering of
detach clauses with respect to associated data-movement clauses: i.e.,
they are grouped toge
As mentioned in the blurb for the previous patch, an "attach" operation
for a Fortran pointer with an array descriptor must copy that array
descriptor to the target. This patch arranges for that to be so.
OK?
Julian
ChangeLog
gcc/fortran/
* trans-openmp.c (gfc_trans_omp_clauses
Sorry,i mistakenly deleted local mail for
https://gcc.gnu.org/pipermail/gcc-patches/2020-June/548174.html, so i
send an another email.
> What I mean is that op2 is a CONST_INT, which in theory can have any
> HOST_WIDE_INT values.
> By assigning that to unsigned int variable, you are effectively
>
On Tue, 16 Jun 2020, Jonathan Wakely wrote:
> This was reported on the gcc-help mailing list. The regression started
> with r10-589 and was fixed by r11-963.
>
> gcc/testsuite/ChangeLog:
>
> * g++.dg/torture/pr95493-1.C: New test.
>
> Tested x86_64-linux. OK for master?
OK.
Richard.
Please find attached fix for PR95586.
OK to commit and backport?
Proposed commit message:
Fortran : ICE in gfc_validate_kind PR95586
Report syntax error for invalid letter-spec in IMPLICIT statements
for derived types and not an ICE.
Original patch by Steve Kargl. Added test cases based on
PING^1
On 6/3/20 8:28 AM, Martin Liška wrote:
On 6/2/20 3:19 PM, Martin Liška wrote:
I'm suggesting to pre-allocate 16 gcov_kvp in the gcov run-time library.
Please take a look at the attached patch. I also added a test-case that
stresses that. I've just finished LTO PGO bootstrap of the GCC.
Hello.
As mentioned in the PR, gcda files tend to occupy a large disk space
when each running process streams to its own directory. The test-case
in the PR has very low coverage and so that the data file contain
a lot of zero records.
The patch is attempt to not stream these zero COUNTERS:
a-tr
101 - 132 of 132 matches
Mail list logo