Hi Christophe,
On 01/20/2020 01:19 PM, Christophe Lyon wrote:
On Thu, 14 Nov 2019 at 15:19, Mihail Ionescu
wrote:
Hi,
This is part of a series of patches where I am trying to add new
instructions for Armv8.1-M Mainline to the arm backend.
This patch is adding the following instructions:
ASR
Hi,
This patch fixes the uninitialised 'last_regno' variable introduced in:
https://gcc.gnu.org/ml/gcc-patches/2019-12/msg01299.html
and makes the clear_operation_p code more readable.
*** gcc/ChangeLog ***
2020-01-20 Mihail-Calin Ionescu
* gcc/config/arm/arm.c (clear_operation_p):
And this was the last reference to svn.html in our tree. :)
Pushed.
---
htdocs/releases.html | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/htdocs/releases.html b/htdocs/releases.html
index 30b777f4..1c8e87e2 100644
--- a/htdocs/releases.html
+++ b/htdocs/releases.html
@@
On 20/01/2020 18:25, Mihail Ionescu wrote:
> Hi,
>
>
> This patch fixes the uninitialised 'last_regno' variable introduced in:
> https://gcc.gnu.org/ml/gcc-patches/2019-12/msg01299.html
> and makes the clear_operation_p code more readable.
>
> *** gcc/ChangeLog ***
>
> 2020-01-20 Mihail-Calin
Jonathan spotted this, so I went ahead and addressed it (adding
"git show" as another relevant command, slightly reordering the
list, and removing a link to the SvnHelp wiki entry).
Pushed.
Gerald
---
htdocs/bugs/reghunt.html | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
di
On 1/20/20 8:08 AM, Alexander Monakov wrote:
Hi,
we have this paragraph in the documentation that attempts to prohibit something
that is allowed by the language. Instead, I think we should say that this
generally should work and explain that a problem in GCC implementation
breaks this.
OK to a
On 1/20/20 3:08 AM, Tobias Burnus wrote:
Hi Sandra,
On 1/20/20 5:39 AM, Sandra Loosemore wrote:
I happen to have noticed a couple weeks ago that this language about
OpenACC support being experimental appears in multiple places in the
gfortran manual, […] The same disclaimer for that option in
On Mon, Jan 20, 2020 at 5:24 AM H.J. Lu wrote:
>
> On Sun, Jan 19, 2020 at 11:53 PM Uros Bizjak wrote:
> >
> > On Sun, Jan 19, 2020 at 10:00 PM H.J. Lu wrote:
> > >
> > > On Sun, Jan 19, 2020 at 12:16 PM Uros Bizjak wrote:
> > > >
> > > > On Sun, Jan 19, 2020 at 9:07 PM H.J. Lu wrote:
> > > >
On 19/01/20 20:06 -0700, Sandra Loosemore wrote:
On 1/13/20 9:12 AM, Joseph Myers wrote:
On Mon, 13 Jan 2020, Sandra Loosemore wrote:
On 1/13/20 7:02 AM, Eric S. Raymond wrote:
Clean up references to SVN in in the GCC docs, redirecting to Git
documentation as appropriate.
This is OK, althou
On Mon, 20 Jan 2020, Sandra Loosemore wrote:
> I'm not happy with this -- we shouldn't be talking about internal concepts
> like GIMPLE and RTL in the GCC user manual. Can we instead talk about which
> user-visible optimization options cause problems, so that users who feel the
> urgent need to w
Hi!
The following testcase ICEs, because for TFmode the particular subtraction
pattern (*subtf3) is not enabled with the given options. Using
expand_simple_binop instead of emitting the subtraction by hand just moves
the ICE one insn later, NEG of ABS is not then recognized, etc., but
ultimately
On Mon, 20 Jan 2020, Prathamesh Kulkarni wrote:
> Hi,
> This patch attempts to add returns_arg attribute for c-family
> languages. For C++ methods, first arg is assumed to be this pointer,
This is missing .texi documentation explaining the attribute and the cases
for which it would be useful.
A
Hi!
On Mon, Jan 20, 2020 at 11:52:55PM +0100, Jakub Jelinek wrote:
> PR target/93073
> * config/rs6000/rs6000.c (rs6000_emit_cmove): Punt for compare_mode
> other than SFmode or DFmode.
"If using fsel, punt for..." etc.
> + /* Don't allow compare_mode other than SFmode or DFmo
On Mon, Jan 20, 2020 at 12:04 AM Kito Cheng wrote:
> gcc/ChangeLog
>
> PR target/93304
> * config/riscv/riscv-protos.h (riscv_hard_regno_rename_ok): New.
> * config/riscv/riscv.c (riscv_hard_regno_rename_ok): New.
> * config/riscv/riscv.h (HARD_REGNO_RENAME_OK): Def
On Mon, Jan 20, 2020 at 05:10:55PM -0600, Segher Boessenkool wrote:
> On Mon, Jan 20, 2020 at 11:52:55PM +0100, Jakub Jelinek wrote:
> > PR target/93073
> > * config/rs6000/rs6000.c (rs6000_emit_cmove): Punt for compare_mode
> > other than SFmode or DFmode.
>
> "If using fsel, punt for
On Mon, 20 Jan 2020, Alexander Monakov wrote:
> Hi,
>
> we have this paragraph in the documentation that attempts to prohibit
> something that is allowed by the language. Instead, I think we should
> say that this generally should work and explain that a problem in GCC
> implementation breaks
On Tue, Jan 21, 2020 at 12:23:02AM +0100, Jakub Jelinek wrote:
> On Mon, Jan 20, 2020 at 05:10:55PM -0600, Segher Boessenkool wrote:
> > On Mon, Jan 20, 2020 at 11:52:55PM +0100, Jakub Jelinek wrote:
> > > PR target/93073
> > > * config/rs6000/rs6000.c (rs6000_emit_cmove): Punt for compare_mode
On Fri, 10 Jan 2020, Jason Merrill wrote:
> Joseph argued that those warnings are sometimes useful, and that they should
> be controlled by a separate flag. So this patch introduces
> -Warith-conversion, which is off by default in this patch.
>
> Joseph, is that default OK with you?
I am OK wit
On Mon, 2 Dec 2019, Maciej W. Rozycki wrote:
> Provide means, in the form of a `--with-toolexeclibdir=' configuration
> option, to override the default installation directory for target
> libraries, otherwise known as $toolexeclibdir. This is so that it is
> possible to get newly-built librari
The leak in get_mapped_args is due to auto_vec not properly supporting
destructible elements, in that auto_vec's destructor doesn't call the
destructors of its elements.
Successfully bootstrapped and regtested on x86_64-pc-linux-gnu, OK to commit?
gcc/cp/ChangeLog:
* constraint.cc (get_m
在 2020/1/20 下午11:49, Nathan Sidwell 写道:
On 1/20/20 12:18 AM, JunMa wrote:
Hi
This patch adds lookup_awaitable_member, it outputs error messages
when any of
the await_ready/suspend/resume functions are missing in awaitable class.
This patch also add some error check on return value of
build_c
On 1/20/20 6:51 PM, Segher Boessenkool wrote:
On Tue, Jan 21, 2020 at 12:23:02AM +0100, Jakub Jelinek wrote:
On Mon, Jan 20, 2020 at 05:10:55PM -0600, Segher Boessenkool wrote:
On Mon, Jan 20, 2020 at 11:52:55PM +0100, Jakub Jelinek wrote:
PR target/93073
* config/rs6000/rs6
在 2020/1/21 上午12:39, Iain Sandoe 写道:
JunMa wrote:
在 2020/1/20 下午8:21, Iain Sandoe 写道:
JunMa wrote:
在 2020/1/20 下午7:55, Iain Sandoe 写道:
Hi JunMa,
JunMa wrote:
在 2020/1/20 下午6:07, Iain Sandoe 写道:
Hi JunMa,
JunMa wrote:
Hi
Accroding to N4835: When a coroutine is invoked, a copy is c
> From: "Richard Earnshaw (lists)"
> Date: Fri, 17 Jan 2020 12:21:07 +0100
> As far as possible, I've made the script automatically restructure any
> existing fetch or push lines that earlier versions of the scripts may
> have created - the gcc-git-customization.sh script will convert all
> ve
> From: Hans-Peter Nilsson
> Date: Tue, 21 Jan 2020 02:47:57 +0100
> (I did not use gcc-git-customization.sh or git-fetch-vendor.sh before
> XX, so there's presumably nothing to clean up.)
Bah; "before 24b178184f260a6ec1516cfb8bb8876874a078a7".
brgds, H-P
On Mon, Jan 20, 2020 at 5:44 AM Nathan Sidwell wrote:
> I've pushed this to master, to address 80005
>
> __has_include is funky in that it is macro-like from the POV of #ifdef
> ...
With this patch, __has_include__ no longer works. There is a use of
this in the RISC-V glibc port. I see the docs
在 2020/1/21 上午9:34, JunMa 写道:
在 2020/1/21 上午12:39, Iain Sandoe 写道:
JunMa wrote:
在 2020/1/20 下午8:21, Iain Sandoe 写道:
JunMa wrote:
在 2020/1/20 下午7:55, Iain Sandoe 写道:
Hi JunMa,
JunMa wrote:
在 2020/1/20 下午6:07, Iain Sandoe 写道:
Hi JunMa,
JunMa wrote:
Hi
Accroding to N4835: When a co
On Fri, 20 Dec 2019, Mike Stump wrote:
> >> This patch series addresses a problem with the testsuite compiler being
> >> set up across libatomic, libffi, libgo, libgomp with no correlation
> >> whatsoever to the target compiler being used in GCC compilation.
> >> Consequently there in no arran
On Mon, 2 Dec 2019, Maciej W. Rozycki wrote:
> Provide means, in the form of a `--with-toolexeclibdir=' configuration
> option, to override the default installation directory for target
> libraries, otherwise known as $toolexeclibdir. This is so that it is
> possible to get newly-built librari
On Tue, 14 Jan 2020, Chung-Lin Tang wrote:
> Can you test if the attached patch works for you? The patch exports the build
> sysroot
> setting from the toplevel to target library subdirs, and adds the --sysroot=
> option
> when doing build-tree testing (I assume that blddir != "" test is suffici
Hi Jim:
Thanks, fixed and committed, and it's OK to commit to gcc 8/9 next week?
On Tue, Jan 21, 2020 at 7:13 AM Jim Wilson wrote:
> On Mon, Jan 20, 2020 at 12:04 AM Kito Cheng wrote:
> > gcc/ChangeLog
> >
> > PR target/93304
> > * config/riscv/riscv-protos.h (riscv_hard_regno_
On Tue, 21 Jan 2020, Joseph Myers wrote:
> > Provide means, in the form of a `--with-toolexeclibdir=' configuration
> > option, to override the default installation directory for target
> > libraries, otherwise known as $toolexeclibdir. This is so that it is
> > possible to get newly-built lib
On Mon, Jan 20, 2020 at 10:59 PM Iain Sandoe wrote:
>
> Hi Bin,
>
> bin.cheng wrote:
>
> > By standard, coroutine body should be encapsulated in try-catch block
> > as following:
> > try {
> > // coroutine body
> > } catch(...) {
> > promise.unhandled_exception();
> > }
> > Given above t
在 2020/1/21 上午9:31, JunMa 写道:
在 2020/1/20 下午11:49, Nathan Sidwell 写道:
On 1/20/20 12:18 AM, JunMa wrote:
Hi
This patch adds lookup_awaitable_member, it outputs error messages
when any of
the await_ready/suspend/resume functions are missing in awaitable
class.
This patch also add some error c
在 2020/1/21 上午9:31, JunMa 写道:
在 2020/1/20 下午11:49, Nathan Sidwell 写道:
On 1/20/20 12:18 AM, JunMa wrote:
Hi
This patch adds lookup_awaitable_member, it outputs error messages
when any of
the await_ready/suspend/resume functions are missing in awaitable
class.
This patch also add some error c
Hi
This patch does minor fix on changing context of label_decl from
original function to actor function which avoid assertion in gimplify pass.
Bootstrap and test on X86_64, is it OK?
Regards
JunMa
gcc/cp
2020-01-21 Jun Ma
* coroutines.cc (transform_await_wrapper): Set actor funcion
On Mon, Jan 20, 2020 at 6:46 PM Maciej W. Rozycki wrote:
>
> Ian: Can we please coordinate this somehow? The libgo/ part, like all,
> relies on config/toolexeclibdir.m4, so I can either:
>
> 1. push the whole change all at once and you'll push the libgo/ part to
>your repo independently, whi
None of our own pages refers to svn.html any longer after the updates
of the last week or two; there may be some external reference, though.
Pushed.
Gerald
---
htdocs/.htaccess | 1 +
1 file changed, 1 insertion(+)
diff --git a/htdocs/.htaccess b/htdocs/.htaccess
index e80d14e4..7aa9f8bb 100644
Pushed.
Gerald
---
htdocs/fortran/index.html | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/htdocs/fortran/index.html b/htdocs/fortran/index.html
index b7a71de2..1d140b3a 100644
--- a/htdocs/fortran/index.html
+++ b/htdocs/fortran/index.html
@@ -14,7 +14,7 @@
The purpose of
101 - 139 of 139 matches
Mail list logo