The C++ front end uses a temporary hash table to remember
specializations of local variables during template instantiations. In a
nested function such as a lambda or local class member function, we need
to retain the elements from the enclosing function's
local_specializations table; otherwise
On 12/09/2015 03:53 PM, Tobias Burnus wrote:
In principle, %<%c%> and %<%d%> should be convertable to %qc and
%qd (as the code is more readable), but the current function
annotation prevent this, telling that the q flag is not valid for
%c and %d. As %< is fine, I didn't dig into it.
You need t
On Thu 2015-12-10 12:36:18 -0500, Daniel Kahn Gillmor wrote:
> Work on the reproducible-builds project [0] has identified that build
> paths are one cause of output variation between builds. This
> changeset allows users to avoid this variation when building C objects
> with debug symbols, while l
I'm OK with the msp430 part :-)
On 12/08/2015 09:21 AM, Marek Polacek wrote:
The following is a conservative fix for this PR. This is an ICE transpiring
in the new "Factor conversion in COND_EXPR" optimization added in r225722.
Before this optimization kicks in, we have
:
...
p1_32 = (short unsigned int) _20;
:
On 12/05/2015 10:14 AM, Andris Pavenis wrote:
Patch specifies that DJGPP do not have mmap() even when sys/mman.h is
available.
libbacktrace is perhaps currently unusable for DJGPP but otherwise
mmap() usability
misdetection breaks cross-compiler build for DJGPP target (for example
Linux hosted
cr
On 12/05/2015 10:05 AM, Andris Pavenis wrote:
Included patch adds *-*-msdosdjgpp to lists of i[34567]86-*-* soft-fp
targets.
Andris
PS. Sending from different address as posts from other address seems not
to go through
2015-12-05 Andris Pavenis
* config.host: Add *-*-msdosdjgpp to lists of
On 12/05/2015 10:25 AM, Andris Pavenis wrote:
Patch enables LTO support for DJGPP in top level configure.ac
Andris
2015-12-05 Andris Pavenis
* configure.ac: enable LTO for *-*-msdosdjgpp
OK once prereqs have gone in. Note you should to the autoconf dance to
update the generated files. Ment
On 12/05/2015 11:36 AM, Andris Pavenis wrote:
On 12/05/2015 06:35 PM, Andris Pavenis wrote:
Included patch updates libstdc++-v3/config/os/djgpp/error_constants.h
according to defines available in DJGPP errno.h.
I'm reposting a patch as earlier post (Nov 15, 2015) have bug in
changelog entry
An
On 12/05/2015 10:19 AM, Andris Pavenis wrote:
Included patch updates typedefs of integer types in
config/i386/djgpp-stdint.h.
Patch is similar but not identical as attached to
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=41557
Andris
2015-12-05 Andris Pavenis
* config/i386/djgpp-stdint.h: up
On 12/05/2015 10:22 AM, Andris Pavenis wrote:
Patch include updates to DJGPP related files in gcc/config/i386.
There are too many changes to gcc/config/i386/djgpp.h and
gcc/config/i386/xm-djgpp.h to list them completely in changelog
entry.
Andris
2015-11-25 Andris Pavenis
Subject: [PATCH 6/6
> I can't really judge this one. Either DJ or Jon would need to some in
> on this.
Looks OK to me, although in the default configuration (plain DJGPP)
the #ifdefs will always be false (omitted), which is harmless.
Hi,
this patch makes lto-symtab to not merge decls where warning and error
attributes mismatch and finally clears up the invalid wanring compiling
testcase from PR 61886.
So it took only 11 patches and year and half to fix this beast...
I am now finished with merging the original transparent alia
Tested on Linux-PPC64.
2015-12-11 Ville Voutilainen
PR libstdc++/68139
/libstdc++-v3
* libsupc++/nested_exception.h (_S_rethrow): Use __std::addressof.
/testsuite
* 18_support/nested_exception/68139.cc: New.
diff --git a/libstdc++-v3/libsupc++/nested_exception.h
b/libstd
On Thu, Dec 10, 2015 at 01:26:06PM +0100, Eric Botcazou wrote:
> Thanks. It seems a little odd for the condition to test the POS (operand #2)
> and not also the LEN (operand #1) of the ZERO_EXTRACT before returning true,
> but I'm not sure what the test would be given the above example. Or mayb
Is this OK to commit if bootstrap + regtest on x86_64 succeeds?
gcc/cp/ChangeLog:
PR c++/68831
* init.c (build_delete): Use a warning sentinel to disable
-Waddress warnings when building the conditional that tests
if the operand is NULL.
gcc/testsuite/ChangeLog:
On Thu, 10 Dec 2015, Daniel Kahn Gillmor wrote:
> Specifically, if the first character of the "old" argument is a
> literal $, then gcc will treat it as an environment variable name, and
> use the value of the env var for prefix mapping.
I don't think a literal $ in option arguments is a good ide
On Thu, 10 Dec 2015, Manuel López-Ibáñez wrote:
> On 12/09/2015 03:53 PM, Tobias Burnus wrote:
> > In principle, %<%c%> and %<%d%> should be convertable to %qc and
> > %qd (as the code is more readable), but the current function
> > annotation prevent this, telling that the q flag is not valid for
On Thu 2015-12-10 18:59:33 -0500, Joseph Myers wrote:
> On Thu, 10 Dec 2015, Daniel Kahn Gillmor wrote:
>
>> Specifically, if the first character of the "old" argument is a
>> literal $, then gcc will treat it as an environment variable name, and
>> use the value of the env var for prefix mapping.
Hi,
this patch makes WPA to copy sections w/o decompressing them. This leads
to a nice /tmp usage for GCC bootstrap (about 70%) and little for Firefox.
In GCC about 5% of the ltrans object file is the global decl section, while
for Firefox it is 85%. I will try to figure out if there is something
On Thu, Dec 10, 2015 at 05:05:12PM +0100, Bernd Schmidt wrote:
> On 12/10/2015 03:36 PM, Kyrill Tkachov wrote:
> >I'm okay with delaying this for next stage 1 if people prefer, though I
> >think it's
> >pretty low risk.
>
> I think this is something we should fix now.
I agree.
> >+ x = XEXP
Hi,
this patch saves about 30% of global decl stream size in firefox. While
implementing the lto sections for initializers I put very stupid heursitcs
to get_symbol_initial_value deciding whether the initializer is better streamed
inline or offline. This ignores strings and may get bit out of han
Hi all,
Loop unrolling would decrease performance in some case due to unrolling high
register pressure
loops and produce lots of spill code.
I try to implement register pressure aware loop
unrolling(-funroll-loops-pressure-aware)
to avoid unrolling high register pressure loops.
The idea is to
On December 10, 2015 9:11:16 PM GMT+01:00, Jakub Jelinek
wrote:
>Hi!
>
>It seems some passes in between the combiner and ira aren't prepared to
>update dominance info. It usually is not a problem, because already
>before
>the combiner we call free_dominance_info. But we now have a new i?86
>stv
On Fri, 11 Dec 2015, Ville Voutilainen wrote:
Tested on Linux-PPC64.
2015-12-11 Ville Voutilainen
PR libstdc++/68139
/libstdc++-v3
* libsupc++/nested_exception.h (_S_rethrow): Use __std::addressof.
^^
Typo.
/testsuite
Hi,
On 10 Dec 14:25, Ilya Enkovich wrote:
> Ping
>
> 2015-11-26 13:33 GMT+03:00 Ilya Enkovich :
> > This patch allows usage of scalar masks for ymm and xmm registers when
> > target supports it. Bootstrapped and regtested on
> > x86_64-unknown-linux-gnu. OK for trunk?
Impact is not high. Your
gcc/c/
2015-12-10 Jan Beulich
* c-fold.c (c_fully_fold_internal): Also emit shift count
warnings for vector types.
* c-typeck.c (build_binary_op): Likewise.
--- 2015-12-09/gcc/c/c-fold.c
+++ 2015-12-09/gcc/c/c-fold.c
@@ -320,8 +320,6 @@ c_fully_fold_internal (tree expr,
On 11 December 2015 at 08:55, Marc Glisse wrote:
> On Fri, 11 Dec 2015, Ville Voutilainen wrote:
>
>> Tested on Linux-PPC64.
>>
>> 2015-12-11 Ville Voutilainen
>>
>>PR libstdc++/68139
>>
>>/libstdc++-v3
>>* libsupc++/nested_exception.h (_S_rethrow): Use __std::addressof.
>
>
On Fri, 11 Dec 2015, Ville Voutilainen wrote:
On 11 December 2015 at 08:55, Marc Glisse wrote:
On Fri, 11 Dec 2015, Ville Voutilainen wrote:
Tested on Linux-PPC64.
2015-12-11 Ville Voutilainen
PR libstdc++/68139
/libstdc++-v3
* libsupc++/nested_exception.h (_S_rethrow): Use __
On 2015.12.11 at 09:50 +0200, Ville Voutilainen wrote:
> On 11 December 2015 at 08:55, Marc Glisse wrote:
> > On Fri, 11 Dec 2015, Ville Voutilainen wrote:
> >
> >> Tested on Linux-PPC64.
> >>
> >> 2015-12-11 Ville Voutilainen
> >>
> >>PR libstdc++/68139
> >>
> >>/libstdc++-v3
> >>*
On 11 December 2015 at 09:52, Marc Glisse wrote:
/libstdc++-v3
* libsupc++/nested_exception.h (_S_rethrow): Use __std::addressof.
>>> Typo.
>> I must be blind, but I don't see what you mean. :)
> Shouldn't the underscores apply to addressof, not to the namespace?
Hah! Yes, thanks
101 - 131 of 131 matches
Mail list logo