[PATCH], PR 64019, fix power7/power8 regression

2014-12-01 Thread Michael Meissner
in my change on November 24th (adding the support to use scalar floating point values in Altivec registers) there was a regression when Spec 2000 was compiled for 32-bit big endian power7 systems. The rs6000_legitimize_reload_address function generated reg+offset address for scalar values. This r

Re: [testsuite] Fix multiple definitions of _init

2014-12-01 Thread Oleg Endo
On Mon, 2014-12-01 at 12:09 +0100, Richard Biener wrote: > On Mon, Dec 1, 2014 at 8:21 AM, Oleg Endo wrote: > > Hi, > > > > When running the testsuite on a sh-elf configuration, some test cases > > fail due to multiple definitions of the function '_init'. This is > > because on sh-elf every funct

Re: [PATCH] Fix PR15346

2014-12-01 Thread Joseph Myers
On Mon, 1 Dec 2014, Richard Biener wrote: > +/* Combine two successive divisions. */ > +(for div (trunc_div ceil_div floor_div round_div exact_div) This doesn't seem correct for all kinds of division and signedness of arguments. TRUNC_DIV_EXPR (C division) and EXACT_DIV_EXPR should be OK regar

Re: [PATCH] Fix PR 61225

2014-12-01 Thread Eric Botcazou
> I also wonder if compare-elim ought to be helping here. Isn't that the > point here, to eliminate the comparison and instead get it for free as > part of the arithmetic? If so, is it the fact that we have memory > references that prevents compare-elim from kicking in? Yes, compare-elim doesn't

Re: [PATCH 5/6] combine: handle REG_UNUSED in reg_dead_at_p (PR59278)

2014-12-01 Thread Oleg Endo
On Mon, 2014-12-01 at 10:38 -0700, Jeff Law wrote: > On 11/27/14 18:44, Segher Boessenkool wrote: > > Currently reg_dead_at_p returns 0 for registers that are set but never > > used. This patch repairs that oversight. This fixes PR59278. > > > > > > 2014-11-27 Segher Boessenkool > > > > gcc/ >

[PATCH driver/diagnostics] init color earlier, add color to driver

2014-12-01 Thread Manuel López-Ibáñez
The initialization of color diagnostics occurs too late to affect, for example, the "unrecognized command line option" error. Unfortunately, in the compiler proper we cannot initialize colors just after diagnostic_initialize() because the FEs replace the pretty-printer with their own by destroying

Re: [PATCH, MPX wrappers 1/3] Add MPX wrappers library

2014-12-01 Thread Joseph Myers
On Mon, 1 Dec 2014, Jeff Law wrote: > > diff --git a/gcc/c-family/c.opt b/gcc/c-family/c.opt > > index 8f5d76c..283c632 100644 > > --- a/gcc/c-family/c.opt > > +++ b/gcc/c-family/c.opt > > @@ -1043,6 +1043,9 @@ Instrument only functions marked with bnd_instrument > > attribute. > > static-libmpx

Re: [PATCH, aarch64] Add prefetch support

2014-12-01 Thread Richard Henderson
On 12/01/2014 05:48 PM, Gopalasubramanian, Ganesh wrote: > +2014-12-01 Ganesh Gopalasubramanian > + > + * config/aarch64/aarch64.md (define_insn "prefetch"): New. > + Looks good to me. r~

[PATCH fortran/linemap] Add enough column hint to fit any possible offset

2014-12-01 Thread Manuel López-Ibáñez
This patch actually does not touch linemap but I will appreciate Dodji's comments about the approach. The problem is that in case of long lines, the column hint of 120 might be too small, thus we do not have enough locations within one line to point to a higher column (like 132 in the testcase). Gi

[BUILDROBOT] Fallout for aarch64_be-elf (was: [PATCH] Rename gimple_build_assign_with_ops to gimple_build_assign and swap the first two arguments of it)

2014-12-01 Thread Jan-Benedict Glaw
On Mon, 2014-12-01 14:52:05 +0100, Jakub Jelinek wrote: > On Fri, Nov 28, 2014 at 08:02:23PM +0100, Jakub Jelinek wrote: > > As possible follow-up, I wonder if gimple_build_assign_with_ops > > isn't too long and too verbose either, couldn't we just > > use overloads of gimple_build_assign instead?

re-build problem with ln -s

2014-12-01 Thread Ulrich Drepper
I think the jit patches introduced a problem when you rebuild within a directory that contains an old build (i.e., no brand new build directory). The gcc/Makefile creates a symlink for xgcc with the full driver name without first removing the symlink. The right procedure (gathered from other Mak

Re: [patch] Define std::promise::set_value_at_thread_exit() etc.

2014-12-01 Thread Jonathan Wakely
On 23/10/14 17:00 +0100, Jonathan Wakely wrote: This adds: std::notify_all_at_thread_exit() std::promise<>::set_value_at_thread_exit() std::promise<>::set_exception_at_thread_exit() std::packaged_task<>::make_ready_at_thread_exit() There's a linked list of callbacks that run after TLS destructor

[PATCH DOC]Fix wrong documentation for TARGET_SCHED_FUSION_PRIORITY

2014-12-01 Thread Bin Cheng
Hi, This is an obvious patch fixing wrong documentation for TARGET_SCHED_FUSION_PRIORITY. Html file generated as expected now. Will commit it in 24h if no objection. 2014-12-02 Bin Cheng * target.def (fusion_priority): Wrap code with @smallexample. * doc/tm.texi: Regenerated.

Re: [PATCH AARCH64]load store pair optimization using sched_fusion pass.

2014-12-01 Thread Bin.Cheng
Ping^2 Thanks, bin On Tue, Nov 25, 2014 at 4:19 PM, Bin.Cheng wrote: > Ping. Anybody have a look? > > Thanks, > bin > > On Tue, Nov 18, 2014 at 4:34 PM, Bin Cheng wrote: >> Hi, >> This is the patch implementing ldp/stp optimization for aarch64. It >> consists of two parts. The first one is p

Re: [PATCH], PR 64019, fix power7/power8 regression

2014-12-01 Thread David Edelsohn
On Mon, Dec 1, 2014 at 5:48 PM, Michael Meissner wrote: > in my change on November 24th (adding the support to use scalar floating point > values in Altivec registers) there was a regression when Spec 2000 was > compiled > for 32-bit big endian power7 systems. The rs6000_legitimize_reload_addres

RE: [PATCH] Rename gimple_build_assign_with_ops to gimple_build_assign and swap the first two arguments of it

2014-12-01 Thread Gopalasubramanian, Ganesh
The following patch implements that. Bootstrapped/regtested on x86_64-linux and i686-linux, ok for trunk? Our aarch64 build also breaks as mentioned in https://gcc.gnu.org/ml/gcc-patches/2014-12/msg00119.html Regards Ganesh

Re: [PATCH fortran/linemap] Add enough column hint to fit any possible offset

2014-12-01 Thread Tobias Burnus
Hi Manuel, Manuel López-Ibáñez wrote: This patch actually does not touch linemap but I will appreciate Dodji's comments about the approach. The problem is that in case of long lines, the column hint of 120 might be too small, thus we do not have enough locations within one line to point to a hig

Re: [PATCH] Rename gimple_build_assign_with_ops to gimple_build_assign and swap the first two arguments of it

2014-12-01 Thread Jakub Jelinek
On Tue, Dec 02, 2014 at 05:13:52AM +, Gopalasubramanian, Ganesh wrote: > The following patch implements that. Bootstrapped/regtested on x86_64-linux > and i686-linux, ok for trunk? > > Our aarch64 build also breaks as mentioned in > https://gcc.gnu.org/ml/gcc-patches/2014-12/msg00119.html Y

Re: [PATCH] Rename gimple_build_assign_with_ops to gimple_build_assign and swap the first two arguments of it

2014-12-01 Thread Jakub Jelinek
On Tue, Dec 02, 2014 at 08:37:19AM +0100, Jakub Jelinek wrote: > Anyway, sorry for missing this, supposedly I've grepped for it in > subdirectories of gcc/ but not in the second level subdirectories. > And, apparently I've missed it also some time ago when removing unnecessary > last NULL arguments

[PATCH] Adjust gimple_build_assign* gimple.texi documentation

2014-12-01 Thread Jakub Jelinek
Hi! Here is an attempt to adjust gimple_build_assign* documentation. Ok for trunk? Note, apparently the documentation has not been adjusted for the gimple -> gassign * etc. changes, David, can you please work on adjusting gimple.texi to match the reality after your changes? 2014-12-02 Jakub Jel

<    1   2