[PATCH][AArch64][4.8] Backport Cortex-A53 erratum 835769 workaround

2014-10-17 Thread Kyrill Tkachov
Hi all, This is the 4.8 backport of the Cortex-A53 erratum 835769 workaround. 4.8 doesn't have rtx_insns and the type attributes are different. Other than that there's not much different from the trunk version. Bootstrapped and tested on aarch64-none-linux-gnu with and without the workaround en

[PATCH][AArch64][4.8] Add --enable-fix-cortex-a53-835769 configure option

2014-10-17 Thread Kyrill Tkachov
Hi all, This is the 4.8 backport of the configure option --enable-fix-cortex-a53-835769 to enable the workaround for the Cortex-A53 erratum 835769 by default. The patch is very similar to the trunk version, just some differences in the placement of the relevant sections. Bootstrapped and test

[gomp4] Asynchronous data unmapping & wait fixes for OpenACC

2014-10-17 Thread Julian Brown
Hi, This patch introduces a new plugin hook in libgomp to register a callback function to clean up host-side bookkeeping data after an asynchronous operation has completed (replacing the previous ad-hoc method used in the NVPTX backend), and adds code to ensure that same cleanup is done reliably i

[PATCH] -fsanitize-recover=list

2014-10-17 Thread Jakub Jelinek
On Mon, Oct 13, 2014 at 02:47:07PM +0400, Yury Gribov wrote: > On 09/30/2014 09:39 PM, Jakub Jelinek wrote: > >LGTM, will hack it up soon in GCC then. > > Do you plan to work on this in near future? Here is only very lightly tested patch, didn't get to updating documentation though, plus there is

Re: [C PATCH] Make -Wno-implicit-int work in C99 mode

2014-10-17 Thread Joseph S. Myers
On Fri, 17 Oct 2014, Marek Polacek wrote: > C99 mode warns about defaulting to int by default, but without > the possibility to suppress the warning with -Wno-implicit-int. > This is likely to arouse the ire of the users, especially with > the new default. > > Therefore the following patch tweaks

Re: [libatomic PATCH] Fix libatomic behavior for big endian toolchain

2014-10-17 Thread Shiva Chen
Hi, Joseph I have been modify the patch as your suggestion use # if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__ in architecture-independent files Is it ok for trunk ? And I don't have svn write access Could you help me to commit this patch? Shiva 2014-10-17 23:41 GMT+08:00 Joseph S. Myers : > Chang

[PATCH] Avoid the need to install when running the jit testsuite

2014-10-17 Thread David Malcolm
On Wed, 2014-10-15 at 17:29 -0400, David Malcolm wrote: > On Wed, 2014-10-15 at 14:51 -0600, Jeff Law wrote: > > On 10/15/14 12:25, David Malcolm wrote: > > > On Wed, 2014-10-15 at 11:36 -0600, Jeff Law wrote: > > >> On 10/13/14 11:45, David Malcolm wrote: > > >>> gcc/ChangeLog: > > >>> * c

Re: [PATCH][0/n] Merge from match-and-simplify

2014-10-17 Thread Sebastian Pop
Richard Biener wrote: > On Thu, 16 Oct 2014, Sebastian Pop wrote: > > > Richard Biener wrote: > > > > > > I have posted 5 patches as part of a larger series to merge > > > (parts) from the match-and-simplify branch. While I think > > > there was overall consensus that the idea behind the project

[patch] Create cfgrtl.h

2014-10-17 Thread Andrew MacLeod
Rather than trying to flatten basic-block.h and do all the work associated in one big patch, I'll try to do it in smaller steps :-) This patch creates cfgrtl.h to maintain the prototypes for functions exported from cfgrtl.c. For the moment, basic-block.h includes cfgrtl.h, keeping everythin

Re: [PATCH 5/5] Use preferred_for_speed in i386.md

2014-10-17 Thread Uros Bizjak
On Fri, Oct 17, 2014 at 4:54 PM, Richard Sandiford wrote: > Undo the original fix for 61630 and use preferred_for_speed in the > problematic pattern. > > I've not written many gcc.target/i386 tests so the markup might need > some work. > > Richard > > > gcc/ > * lra.c (lra): Remove call to

Re: [PATCH 4/5] State cleanups -- also note for MPX work

2014-10-17 Thread Jeff Law
On 10/16/14 18:41, David Malcolm wrote: Anyway, just thought it was worth explicitly pointing out that these two hunks of work, while they're tackling totally different issues may conflict because of an implementation of the MPX bits. Presumably my state cleanup patch isn't going to break the

C/C++ diagnostics guidelines (was: Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567))

2014-10-17 Thread Manuel López-Ibáñez
> The Right Thing is for -pedantic not to cause errors, only warnings > (-pedantic-errors being needed for an error). So rather than having this > conditional for whether to allow the extension at all, make the > conditional code do a pedwarn (if flag_isoc99, otherwise there will > already have be

Re: [PATCH] Fix race in libstdc++ testsuite

2014-10-17 Thread Mike Stump
On Oct 16, 2014, at 7:12 PM, Maxim Kuvyrkov wrote: > The fix is to use unique name cin_unget-1-[pid].txt for the data file. > OK to apply? Ok.

Re: [x86] Replace builtins with vector extensions

2014-10-17 Thread Uros Bizjak
On Sun, Oct 12, 2014 at 10:36 PM, Marc Glisse wrote: > for the first patch, it is actually easier to repost the old patch with some > new testcases. That doesn't mean it has to go in all at once, but you can > comment on various things. If that's a problem I'll separate them and repost > separate

Re: -fuse-caller-save - Collect register usage information

2014-10-17 Thread Mike Stump
On Oct 17, 2014, at 8:50 AM, Jeff Law wrote: >> So - I like -fipa-ra more. > Similarly. Yeah, I was going to say I liked the ipa tag in there some place but didn’t cause I didn’t want to bikeshed, but, since a few others like that, dogpiling seems ok. :-)

Re: C/C++ diagnostics guidelines (was: Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567))

2014-10-17 Thread Joseph S. Myers
On Fri, 17 Oct 2014, Manuel López-Ibáñez wrote: > Thus, I drafted some guidelines > at:https://gcc.gnu.org/wiki/Better_Diagnostics#guidelines > > Please, could you take a look and comment whether I got it right/wrong? Yes, that looks right to me. -- Joseph S. Myers jos...@codesourcery.com

Re: [PATCH][0/n] Merge from match-and-simplify

2014-10-17 Thread Richard Biener
On October 17, 2014 6:35:58 PM CEST, Sebastian Pop wrote: >Richard Biener wrote: >> On Thu, 16 Oct 2014, Sebastian Pop wrote: >> >> > Richard Biener wrote: >> > > >> > > I have posted 5 patches as part of a larger series to merge >> > > (parts) from the match-and-simplify branch. While I think

Re: [ARM] Fix DWARF unwinding breakage

2014-10-17 Thread Mike Stump
On Oct 17, 2014, at 1:21 AM, Eric Botcazou wrote: > This nevertheless used to work because the blockage insn emitted by the RTL > epilogue was acting as a "wild load" but this got broken by Richard's patch > which removed the "wild load" trick. > The attached patch fixes the breakage by marking

Re: [PATCH] Avoid the need to install when running the jit testsuite

2014-10-17 Thread Joseph S. Myers
On Fri, 17 Oct 2014, David Malcolm wrote: > +# This symlink makes the full installation name of the driver be available > +# from within the *build* directory, for use when running the JIT library > +# from there (e.g. when running its testsuite). > +$(FULL_DRIVER_NAME): ./xgcc > + $(LN) -s $<

[PATCH PR63530] Fix the pointer alignment in vectorization

2014-10-17 Thread Carrot Wei
Hi In current vectorization pass, when a new vector pointer is created, its alignment is not set correctly. We should use DR_MISALIGNMENT (dr) since only this alignment is adjusted when loop peeling or multi version is occurred. This patch passed following tests: x86_64 bootstrap. x86_64 regressi

Re: C/C++ diagnostics guidelines (was: Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567))

2014-10-17 Thread Manuel López-Ibáñez
On 17 October 2014 19:33, Joseph S. Myers wrote: > On Fri, 17 Oct 2014, Manuel López-Ibáñez wrote: > >> Thus, I drafted some guidelines >> at:https://gcc.gnu.org/wiki/Better_Diagnostics#guidelines >> >> Please, could you take a look and comment whether I got it right/wrong? > > Yes, that looks rig

Re: [ARM] Fix DWARF unwinding breakage

2014-10-17 Thread Eric Botcazou
> [ thinking out loud ] So, I can’t help but wonder if c6x, mips, nios2 and sh > now have the exact same problem (or could if they switched code-gen > some)... ARM is very peculiar here since it goes through a stack slot to copy a value into a register; other architectures, e.g. SPARC, do a bare

[patch] libstdc++/57250 shared_ptr atomic operations

2014-10-17 Thread Jonathan Wakely
I'm not very proud of this solution, but unless anyone has a better ideas this is how I plan to add the atomic operations for shared_ptr. I used __gnu_cxx::__mutex instead of std::mutex because it has fewer dependencies, so the atomic operations should always be available for shared_ptr even when

Re: [PATCH][0/n] Merge from match-and-simplify

2014-10-17 Thread Sebastian Pop
Sebastian Pop wrote: > Richard Biener wrote: > > looks like > > RTL issues and/or IVOPTs issues? > > I should have posted the first diff between the compilers with > -fdump-tree-all: > that would expose the problem at its root. Looks like this is caused by the fwprop pass: diff -u -r ./foo.i.08

[PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Manuel López-Ibáñez
While writing the guidelines https://gcc.gnu.org/wiki/Better_Diagnostics#guidelines , I noticed that we never explain the precedence rules between conflicting options. Also, the description of -pedantic-errors could be more precise. OK? Index: invoke.texi

Re: [PARCH 1/2, x86, PR63534] Fix darwin bootstrap

2014-10-17 Thread Mike Stump
On Oct 17, 2014, at 7:08 AM, Evgeny Stupachenko wrote: > The patch fixes 1st fail in darwin bootstarp. > When PIC register is pseudo we don't need to init it after setjmp or > non local goto. > > Is it ok? So, I don’t see commentary in the PR that all fallout and all bugs introduced are fixed b

Re: C/C++ diagnostics guidelines (was: Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567))

2014-10-17 Thread Manuel López-Ibáñez
On 17 October 2014 20:04, Manuel López-Ibáñez wrote: > On 17 October 2014 19:33, Joseph S. Myers wrote: >> On Fri, 17 Oct 2014, Manuel López-Ibáñez wrote: >> >>> Thus, I drafted some guidelines >>> at:https://gcc.gnu.org/wiki/Better_Diagnostics#guidelines >>> >>> Please, could you take a look and

Re: -fuse-caller-save - Collect register usage information

2014-10-17 Thread Eric Botcazou
> Let's look at the effect of the option (after the recent fix for PR61605) on > gcc.target/i386/fuse-calller-save.c: > ... > foo: > .LFB1: > .cfi_startproc > - pushq %rbx > - .cfi_def_cfa_offset 16 > - .cfi_offset 3, -16 > - movl%edi, %ebx > callbar > -

Re: [patch] Fix ICE during LTRANS on big Ada application

2014-10-17 Thread Eric Botcazou
> Yes, this looks OK. Inliner coul also take care to turn the master clone > into unanalyzed node as remove_unreachable_nodes would, but I do not think > it is worth the effort. Please put the loop later in the function so it > does not slow things down unnecesarily (there are often many inline clo

Re: [x86] Replace builtins with vector extensions

2014-10-17 Thread Marc Glisse
On Fri, 17 Oct 2014, Uros Bizjak wrote: While looking correct, I am a bit nervous about avx512fintrin.h changes, mainly because I have not much experience with these patterns. I have adder Kirill to CC for possible comments. He asked for this part of the patch, and tested it: https://gcc.gnu.o

Re: update address taken: don't drop clobbers

2014-10-17 Thread Marc Glisse
On Thu, 16 Oct 2014, Jeff Law wrote: BTW, I dislike having multiple DCE implementations... Similarly. The proposal above was just to determine if we should schedule DCE or not. Thinking about it some more, I don't think we should need any kind of DCE here. The rewriting in update_ssa alread

[Bug libstdc++/61107] stl_algo.h: std::__inplace_stable_partition() doesn't process the whole data range

2014-10-17 Thread François Dumont
Hi As proposed in the bug report I just removed the __inplace_stable_partition as __stable_partition_adaptive is able to handle a 0 buffer size. To test this bug I introduced overloads of new/delete operators in the testsuite utils. The existing set_memory_limits has no impact on new

Re: [PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Joseph S. Myers
On Fri, 17 Oct 2014, Manuel López-Ibáñez wrote: > +Some options, such as @option{-Wall} and @option{-Wextra}, turn on other > +options, such as @option{-Wunused}, which may turn on further options, > +such as @option{-Wunused-value}. The combined effect of positive and > +negative forms is that mo

Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567)

2014-10-17 Thread Marek Polacek
On Fri, Oct 17, 2014 at 03:53:46PM +, Joseph S. Myers wrote: > On Fri, 17 Oct 2014, Marek Polacek wrote: > > > Building Linux kernel failed with 'error: initializer element is not > > constant', because they're initializing objects with static storage > > duration with (T){ ...} - and that isn

Re: [C PATCH] Enable initializing statics with COMPOUND_LITERAL_EXPR in C99 (PR c/63567)

2014-10-17 Thread Joseph S. Myers
On Fri, 17 Oct 2014, Marek Polacek wrote: > Bootstrapped/regtested on x86_64-linux, ok for trunk? > > 2014-10-17 Marek Polacek > > PR c/63567 > * c-typeck.c (digest_init): Allow initializing objects with static > storage duration with compound literals even in C99 and add pe

[Patch, testsuite] clear wrap_compile_flags before setting it

2014-10-17 Thread Christophe Lyon
Hi, In testsuite/lib/wrapper.exp's ${tool}_maybe_build_wrapper, we call set_currtarget_info wrap_compile_flags to override wrap_compile_flags with additional flags when compiling testglue.c. However, dejagnu's set_currtarget_info {entry value} will write into value only if it's not already define

Re: [PATCH 05/10] JIT-related changes outside of jit subdir

2014-10-17 Thread Joseph S. Myers
Although Sphinx isn't a build dependency, as a dependency for regenerating checked-in files I think it should be documented in install.texi (like autoconf, gettext, etc.). -- Joseph S. Myers jos...@codesourcery.com

Re: [PATCH 06/10] Heart of the JIT implementation (was: Re: [PATCH 0/5] Merger of jit branch (v2))

2014-10-17 Thread Joseph S. Myers
Does libgccjit.so end up getting linked with -static-libstdc++ -static-libgcc? If so, that could be problematic (are static libstdc++ and libgcc necessarily built as PIC so it's even possible to embed them into a shared library?). It's certainly not clear that the -static-libstdc++ -static-li

[PATCH PR63581] Fix undefined references in debug_info

2014-10-17 Thread Rong Xu
Hi, The attached patch fixes PR63581. The diagnosis is in the bug report. Google ref b/17759776. Tested with bootstrap and regression. Thanks, -Rong 63581_patch Description: Binary data

Re: [PATCH][3/n] Merge from match-and-simplify, first patterns and questions

2014-10-17 Thread Joseph S. Myers
On Wed, 15 Oct 2014, Richard Biener wrote: >Caveat2: the GENERIC code-path of match-and-simplify does >not handle everything fold-const.c does - for example >it does nothing on operands with side-effects - foo () * 0 >is not simplified to (foo(), 0). It also does not >get the

Re: [PATCH PR63581] Fix undefined references in debug_info

2014-10-17 Thread Rong Xu
Here is the diff for ChangeLog Index: ChangeLog === --- ChangeLog (revision 216415) +++ ChangeLog (working copy) @@ -1,3 +1,8 @@ +2014-10-17 + + * cfgrtl.c (emit_barrier_after_bb): Append the barrier to the + footer, instead of un

Re: [PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Manuel López-Ibáñez
On 17 October 2014 22:46, Joseph S. Myers wrote: >> @@ -3318,8 +3327,8 @@ >> >> @item -pedantic-errors >> @opindex pedantic-errors >> -Like @option{-Wpedantic}, except that errors are produced rather than >> -warnings. >> +This is equivalent to @option{-Werror=pedantic} plus making into errors >

Re: [PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Joseph S. Myers
On Sat, 18 Oct 2014, Manuel López-Ibáñez wrote: > The previous version also does not match your description. You are saying that > > -Wpedantic = warning(OPT_Wpedantic) + pedwarn(OPT_Wpedantic) > and -pedantic-errors = pedwarn(OPT_Wpedantic).+ pedwarn(0) > > The current version says that > > -W

Re: [PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Manuel López-Ibáñez
On 18 October 2014 01:43, Joseph S. Myers wrote: > On Sat, 18 Oct 2014, Manuel López-Ibáñez wrote: > >> The previous version also does not match your description. You are saying >> that >> >> -Wpedantic = warning(OPT_Wpedantic) + pedwarn(OPT_Wpedantic) >> and -pedantic-errors = pedwarn(OPT_Wpedan

Re: [PATCH doc] Explain options precedence and difference between -pedantic-errors and -Werror=pedantic

2014-10-17 Thread Joseph S. Myers
On Sat, 18 Oct 2014, Manuel López-Ibáñez wrote: > Can we make "possibly in some other cases" more concrete? Otherwise, Cases where something about the code is not defined by the base standard, but a diagnostic is not required. -pedantic may give a warning for such cases. -pedantic-errors may

Go patch committed: Don't allow dup names in a tuple assignment

2014-10-17 Thread Ian Lance Taylor
The Go frontend was incorrectly accepting duplicate variable names in a tuple assignment, as in "a, a := 0, 0". This is http://golang.org/issue/8436. This patch from Chris Manghane corrects this error. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu. Committed to mainline. Ian d

<    1   2