The x86 case differs from the msp430 case in that the x86 case makes
the count a *smaller* mode (SI->QI) where the msp430 case makes it
*bigger* (HI->SI). msp430 uses the "Handle expanding beyond a word"
case in convert_move() (msp430's word is HImode), ending in the
multiword-by-hand case.
On Fri, Apr 25, 2014 at 4:40 PM, Tim Shen wrote:
> regex_match("", regex("(?:)*") will cause segfault because the
> infinite loop detection (writeen by me) is stupid. :O
Patch attached.
--
Regards,
Tim Shen
commit 71b52302793f501a60783ea6dec09202120ce592
Author: tim
Date: Fri Apr 25 01:50:1
Patch attached.
--
Regards,
Tim Shen
commit cd0683e3a3eae0c62d2867fb5456edb3735b38ae
Author: tim
Date: Fri Apr 25 10:45:26 2014 -0400
2014-04-25 Tim Shen
* include/bits/regex_automaton.h (_NFA<>::_M_insert_repeat):
Add _S_opcode_repeat support to distingush a loop
On Fri, Apr 25, 2014 at 5:14 PM, Jonathan Wakely wrote:
> I wonder if this would be simpler to read like this:
>
>if (!__re._M_automaton->_M_has_backref
> #ifndef _GLIBCXX_REGEX_USE_THOMPSON_NFA
>&& __policy == _RegexExecutorPolicy::_S_alternate
> #endif
> )
I don't
Fix a few ICEs and other problems with -fdebug-types-sections.
This is a followup to an earlier proposed patch:
http://gcc.gnu.org/ml/gcc-patches/2012-08/msg01998.html
http://gcc.gnu.org/ml/gcc-patches/2012-09/msg0.html
(1) If a function contains a local typedef of an anonymous structure
On 25/04/14 18:14 -0400, Tim Shen wrote:
On Fri, Apr 25, 2014 at 5:14 PM, Jonathan Wakely wrote:
I wonder if this would be simpler to read like this:
if (!__re._M_automaton->_M_has_backref
#ifndef _GLIBCXX_REGEX_USE_THOMPSON_NFA
&& __policy == _RegexExecutorPolicy::_S_alterna
On Fri, Apr 25, 2014 at 7:56 PM, Jonathan Wakely wrote:
> That's why I thought #ifndef would work, not #ifdef
Oh I didn't notice that. Now they are equivalent.
--
Regards,
Tim Shen
commit cb39603d6df4763e95a697792e7b45179994f096
Author: tim
Date: Fri Apr 25 01:49:31 2014 -0400
2014-04-
don't you think that it would be easier to understand the number if you
printed it largest index first, as in the routines in wide-int-print.cc?
kenny
On 04/25/2014 09:58 AM, Richard Sandiford wrote:
This patch adds a dump () method so that it's easier to read the
contents of the various wide-i
approved
On 04/25/2014 09:40 AM, Richard Sandiford wrote:
Very minor, but since shifted_mask copes with out-of-range widths,
I think mask should too.
Tested on x86_64-linux-gnu. OK to install?
Thanks,
Richard
Index: gcc/wide-int.cc
approved.
On 04/25/2014 09:39 AM, Richard Sandiford wrote:
shifted_mask would mishandle cases where the start bit is in the middle
of a HWI and the end bit is in a different HWI. The "000111000" case
needs to check that the start and end are in the same block.
In the changed lines, "shift" is t
Hi,
This patch is to address the missing optimization reported in
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60738
Now in process_single_reg_class_operands, any allocno A conflicting
with a single reg class operand B is marked to never use the reg class
in IRA. This is non-optimal when A is in a
On Fri, Apr 25, 2014 at 02:57:38PM +, rohitarul...@freescale.com wrote:
> Source file: gcc-4.8.2/gcc/varasm.c
> @@ -7120,7 +7120,7 @@
>if (CONSTANT_POOL_ADDRESS_P (symbol))
> {
> desc = SYMBOL_REF_CONSTANT (symbol);
> output_constant_pool_1 (desc, 1);
Quoting Svante Signell (2014-04-24 10:39:10)
> On Fri, 2014-04-18 at 10:03 +0200, Samuel Thibault wrote:
> > Samuel Thibault, le Thu 17 Apr 2014 00:03:45 +0200, a écrit :
> > > Thomas Schwinge, le Wed 09 Apr 2014 09:36:42 +0200, a écrit :
> > > > Well, the first step is to verify that TARGET_THREAD
101 - 113 of 113 matches
Mail list logo