Hi,
the attached patch fixes two issues with the TX backend optimization
trying to get rid of FPR save/restore operations in some cases.
The first is that the stack pointer might get clobbered on 64 bit if
the backend was able to get rid of all the FPR saves/restores and
these were the only thing
Hello,
Some of the things I've done in 4.8 to improve SH T bit handling turned
out to produce wrong code. The attached patch fixes that by introducing
an SH specific RTL pass.
Tested on rev 202876 with
make -k check RUNTESTFLAGS="--target_board=sh-sim
\{-m2/-ml,-m2/-mb,-m2a/-mb,-m4/-ml,-m4/-mb,-
Hi,
this error recovery ICE (a low priority regression) can be easily
avoided by checking the TREE_TYPE of exp too. Tested x86_64-linux.
Thanks,
Paolo.
///
/cp
2013-10-04 Paolo Carlini
PR c++/58560
* typeck2.c (build_functional_cast): Use error_operand_
Hi,
this patch makes -Ofast to also imply -mfpmath=sse. It is important win on
SPECfP (2000 and 2006). Even though for exmaple the following
float a(float b)
{
return b+10;
}
results in somewhat ridiculous
a:
.LFB0:
.cfi_startproc
subl$4, %esp
.cfi_def_cfa_offset
... and this is a more straightforward approach. Also tested x86_64-linux.
Thanks!
Paolo.
/
/cp
2013-10-04 Paolo Carlini
PR c++/58448
* pt.c (tsubst): Use error_operand_p on parameter t.
/testsuite
2013-10-04 Paolo Carlini
PR c++/58448
So here is a patch with the change. As before, bootstrapped an tested on
x86-64.
On 10/03/2013 12:16 PM, Richard Sandiford wrote:
Kenneth Zadeck writes:
Changing the representation of unsigned constants is only worthwhile
if we can avoid the force_to_size for some unsigned cases. I think we
On 10/02/13 23:49, Rong Xu wrote:
Here is the new patch. Honaz: Could you take a look?
Thanks,
-Rong
On Wed, Oct 2, 2013 at 2:31 PM, Jan Hubicka wrote:
Thanks for the suggestion. This is much cleaner than to use binary parameter.
Just want to make sure I understand it correctly about the or
>> + // Do not permit the declaration of constrained friend
>> + // function declarations. They cannot be instantiated since
>> + // the resulting declaration would never match the definition,
>> + // which must be a non-template and cannot be constrained.
>
>
>
On Thu, 3 Oct 2013, David Malcolm wrote:
> Right now all you get back from the result is a "void*" which you're
> meant to cast to machine code for the CPU. I guess we could add an
And right now the library is calling dlopen. Which means that although
what the user gets is a void *, the dynam
Just to ping this patch.
http://gcc.gnu.org/ml/gcc-patches/2013-09/msg01829.html
Regards,
Zoran Jovanovic
From: Zoran Jovanovic
Sent: Tuesday, September 24, 2013 11:59 PM
To: gcc-patches@gcc.gnu.org
Cc: Petar Jovanovic
Subject: RE: [PATCH] Add a new option
Dehao, can you take a look?
David
On Fri, Oct 4, 2013 at 6:05 AM, Ramana Radhakrishnan wrote:
> On 10/02/13 23:49, Rong Xu wrote:
>>
>> Here is the new patch. Honaz: Could you take a look?
>>
>> Thanks,
>>
>> -Rong
>>
>> On Wed, Oct 2, 2013 at 2:31 PM, Jan Hubicka wrote:
Thanks for th
On Thu, Oct 3, 2013 at 10:15 PM, Teresa Johnson wrote:
> This patch handles the fact that small profile count values sometimes
> get truncated down to 0 during updates due to integer arithmetic. This
> causes sub-optimal function splitting under
> -freorder-blocks-and-partition.
>
> The first part
Hi,
On 10/04/2013 04:13 PM, Tim Shen wrote:
This is based on disscusions
here(http://gcc.gnu.org/ml/libstdc++/2013-10/msg00034.html)
And it successfully find a bug in regex_executor.tcc :)
Booted and tested under -m32, -m64 and debug before the change in
regex_executor.tcc;
-m32 and -m64 only
On 10/04/2013 06:04 PM, Paolo Carlini wrote:
In particular, the new *_testsuite functions, isn't immediately clear
in what they differ from the non-_testsuite variants. In any case we
should figure out a better name, maybe even *_internal, if we can't
find anything more accurate, but it should
When building the location list for a variable that has been optimized
by SRA, dw_sra_loc_expr sometimes creates a DWARF expression or a
piece of an expression, but then abandons it for some reason. When
abandoning it, we neglected to release any addr_table entries created
for DW_OP_addr_index opc
.. a final one: if you don't like all those *_debug functions around,
both in rehex.h and regex.tcc, you could move all of them to a new
header matching the new naming scheme, like regex_debug.h. For the time
being I would recommend putting it in bits/, installing it, including it
from , exactl
This patch mostly re-factors tree-flow-inline.h out of existence.
the gimple-df data structure has found anew home in gimple-ssa.h, and
this actually seems like a very appropriate place for it as it holds a
lot fo the ssa specific stuff in it.
The remaining inline functions in tree-flow-inlin
I have committed the attached patch to the GCC 4.8 branch, backporting
some defined assignment patches. Committed as Rev. 203207/203208.
GCC 4.8 added defined assignment for components during intrinsic
assignment, which had some issues.
a) PR 57697/PR58469
Patch: http://gcc.gnu.org/ml/fortran
I was hoping Richard would weigh in here. In case not...
Kenneth Zadeck writes:
I was thinking that we should always be able to use the constant as-is
for max_wide_int-based and addr_wide_int-based operations. The small_prec
>>> again, you can get edge cased to death here.i think
Hi all,
This patch will change tune_params for armv8-a architecture to general
cortex.
Change has been tested for arm-none-eabi on the model.
Ok for trunk?
Kind regards,
Renlin Li
gcc/ChangeLog:
2013-10-03 Renlin Li
* config/arm/arm-cores.def (cortex-a53): Use cortex tunning.diff --g
On 10/04/2013 09:20 AM, Andrew Sutton wrote:
>Perhaps you mean that it must match a fully-instantiated function, so any
>constraints on the templates were considered during
>determine_specialization.
This seems like a simple comment fix, but there's a longer explanation
of what I want (see bel
>>> >Perhaps you mean that it must match a fully-instantiated function, so
>>> > any
>>> >constraints on the templates were considered during
>>> >determine_specialization.
>
>
>> This seems like a simple comment fix, but there's a longer explanation
>> of what I want (see below). Would this be mor
My change on the probability of builtin_expect does have an impact on
the partial inline (more outlined functions will get inline back to
the original function).
I think this triggers an existing issue.
Dehao will explain this in his coming email.
-Rong
On Fri, Oct 4, 2013 at 6:05 AM, Ramana Radh
When building the location list for a variable that has been optimized
by SRA, dw_sra_loc_expr sometimes creates a DWARF expression or a
piece of an expression, but then abandons it for some reason. When
abandoning it, we neglected to release any addr_table entries created
for DW_OP_addr_index opc
I looked at this problem. Bug updated
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58619
This is a bug when updating block during tree-inline. Basically, it is
legal for *n to be NULL. E.g. When gimple_block(id->gimple_call) is
NULL, remap_blocks_to_null will be called to set *n to NULL.
The probl
This patch from Chris Manghane changes the Go frontend to use the
backend interface when building a reference to a temporary variable.
Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu.
Committed to mainline and 4.8 branch.
Ian
2013-10-04 Chris Manghane
* go-gcc.cc (Backe
This patch to libgo fixes calling the Interface method on a Value
created by calling MakeFunc. Bootstrapped and ran Go testsuite on
x86_64-unknown-linux-gnu. Committed to mainline and 4.8 branch.
Ian
diff -r 52c01e7b81fe libgo/go/reflect/all_test.go
--- a/libgo/go/reflect/all_test.go Fri Oct 04
> I looked at this problem. Bug updated
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58619
>
> This is a bug when updating block during tree-inline. Basically, it is
> legal for *n to be NULL. E.g. When gimple_block(id->gimple_call) is
> NULL, remap_blocks_to_null will be called to set *n to NULL
On 10/04/2013 01:00 PM, Richard Sandiford wrote:
I was hoping Richard would weigh in here. In case not...
Kenneth Zadeck writes:
I was thinking that we should always be able to use the constant as-is
for max_wide_int-based and addr_wide_int-based operations. The small_prec
again, you can ge
I merged revision 203214 of the GCC 4.8 branch to the gccgo branch.
Ian
On Fri, Oct 4, 2013 at 11:54 AM, Jan Hubicka wrote:
>> I looked at this problem. Bug updated
>> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58619
>>
>> This is a bug when updating block during tree-inline. Basically, it is
>> legal for *n to be NULL. E.g. When gimple_block(id->gimple_call) is
>> N
OK.
Jason
Hi!
I've committed the following patch to gomp-4.0-branch.
The omp-low.c changes are to fix some bugs with if clause on
#pragma omp target{, data, update}.
The c-cppbuiltin.c is to finally announce OpenMP 4.0 support for C/C++.
The libgomp changes are:
1) as required by OpenMP 4.0, thread_limit_
This pulls out the code to search for a threading opportunity in a
normal block into its own subroutine. No functional changes.
Bootstrapped and regression tested on x86_64-unknown-linux-gnu.
Installed on the trunk.
diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index 065ebf1..cf4a45c 100644
OK.
Jason
> On Fri, Oct 4, 2013 at 11:54 AM, Jan Hubicka wrote:
> >> I looked at this problem. Bug updated
> >> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58619
> >>
> >> This is a bug when updating block during tree-inline. Basically, it is
> >> legal for *n to be NULL. E.g. When gimple_block(id->gimple_c
On Thu, Oct 3, 2013 at 3:43 PM, Michael Hudson-Doyle
wrote:
> Hi,
>
> As libatomic builds for and the tests pass on AArch64 (built on x86_64
> but tested on a foundation model, logs and summary:
>
> http://people.linaro.org/~mwhudson/libatomic.sum.txt
> http://people.linaro.org/~mwhudson/r
OK.
Jason
OK.
Jason
Oleg Endo wrote:
> Some of the things I've done in 4.8 to improve SH T bit handling turned
> out to produce wrong code. The attached patch fixes that by introducing
> an SH specific RTL pass.
>
> Tested on rev 202876 with
> make -k check RUNTESTFLAGS="--target_board=sh-sim
> \{-m2/-ml,-m2/-mb,-m
Hi Andrew,
On 10/04/2013 07:36 PM, Andrew Sutton wrote:
+ if (!check_template_constraints (tmpl, args))
+{
+ location_t loc = DECL_SOURCE_LOCATION (function);
+ error ("%qD is not a viable candidate", function);
+ diagnose_constraints (
41 matches
Mail list logo