2013/5/5 Jerry DeLisle :
> On 05/04/2013 06:30 PM, Steve Kargl wrote:
>> On Sat, May 04, 2013 at 05:13:51PM -0700, Jerry DeLisle wrote:
>>>
>>> CASE_SEPARATORS:/* Not a repeat count. */
>>> case EOF:
>>> +case '!':
>>
>> if (c == '!')
>> gfc_warning("GNU Fortra
On Fri, May 3, 2013 at 3:10 PM, Julian Brown wrote:
> gcc/
> * gcse.c (compute_ld_motion_mems): Invalidate non-simple mem refs
> in REG_EQUAL notes.
Makes sense to me. Looking at REG_EQUAL notes in hash_scan_set is
something relatively new. Your patch fixes something we appear to have
Hi,
committed to mainline.
Thanks,
Paolo.
///
2013-05-05 Paolo Carlini
* pt.c (convert_nontype_argument): Add missing whitespace in
error message.
Index: pt.c
===
--- pt.c(revision 198607
Hi,
On Mon, 2013-04-29 at 11:31 +0200, Christian Bruel wrote:
> Hello,
>
> This patches set the correct operand mode for tstsi_t_zero_extract_eq,
> to avoid reload generating a move between a constant and a void register.
>
> Reg tested for sh-elf. No performance impact
Unfortunately after your
Janus Weil wrote:
2013/5/5 Jerry DeLisle :
On 05/04/2013 06:30 PM, Steve Kargl wrote:
On Sat, May 04, 2013 at 05:13:51PM -0700, Jerry DeLisle wrote:
CASE_SEPARATORS:/* Not a repeat count. */
case EOF:
+case '!':
if (c == '!')
gfc_warning("GNU Fortran
On Sat, May 04, 2013 at 10:25:19PM -0700, Jerry DeLisle wrote:
> On 05/04/2013 06:30 PM, Steve Kargl wrote:
> > On Sat, May 04, 2013 at 05:13:51PM -0700, Jerry DeLisle wrote:
> >>
> >>CASE_SEPARATORS:/* Not a repeat count. */
> >>case EOF:
> >> + case '!':
> >
> > if (c =
Ping.
http://gcc.gnu.org/ml/fortran/2013-04/msg00272.html
Also pending: use-associated NULL() at
http://gcc.gnu.org/ml/fortran/2013-05/msg6.html
Tobias Burnus wrote:
The issue was found by Reinhold Bader when testing the Fortran-Dev
branch (thanks!), but it also affects GCC 4.6 and later.
Hi Tobias,
Ping.
http://gcc.gnu.org/ml/fortran/2013-04/msg00272.html
OK.
Also pending: use-associated NULL() at
http://gcc.gnu.org/ml/fortran/2013-05/msg6.html
Also OK (obvious really ;-)
Thanks for the patches!
Thomas
On 01/05/2013 03:02, Jason Merrill wrote:
> Since GNU Make doesn't support anything like the .MUTEX directive
> (http://savannah.gnu.org/bugs/?func=detailitem&item_id=17873), and
> accidentally doing "make -j8 -l4" makes my laptop useless for several
> minutes while it tries to link all the front e
Oleg Endo wrote:
> The operand mode in the tstsi_t_zero_extract_eq pattern was void on
> purpose to match any mode (at least QI HI SI DI). The attached patch
> fixes that.
> OK for trunk and 4.8 if it passes testing? (I'd leave 4.7 alone since
> it doesn't have the iterators.md).
OK.
> (BTW,
I still have no idea from your answer how a user is meant to know whether
to use the option when compiling, linking or both, which is what needs to
be clear from invoke.texi.
What does it mean for the option to be supported for compiling but not
linking? What in that case will the linker do wi
On Sun, 5 May 2013, Alan Modra wrote:
> Something to consider for the future is making more of the -mcall
> options endian agnostic, like -mcall-sysv. Tested with a number of
> powerpc ELF builds.
I'd like to suggest removing those -mcall-* options (as far as they affect
specs, anyway). No oth
On Sun, May 5, 2013 at 12:35 AM, Alan Modra wrote:
> This fixes a couple more little-endian bugs. bswapdi stores when
> !TARGET_LDBRX were being split to two bswapsi but written to the wrong
> words because we word swapped twice. ashrdi3 resulted in a libcall.
>
> I think I have ashrdi3_no_power
On Sun, May 5, 2013 at 10:21 AM, Joseph S. Myers
wrote:
> On Sun, 5 May 2013, Alan Modra wrote:
>
>> Something to consider for the future is making more of the -mcall
>> options endian agnostic, like -mcall-sysv. Tested with a number of
>> powerpc ELF builds.
>
> I'd like to suggest removing thos
> + a += v >> (sizeof (intptr_t) * CHAR_BIT / 2);
> + b += v & (((intptr_t) 1 << (sizeof (intptr_t) * CHAR_BIT / 2)) - 1);
It would be far easier to read if you added a BITS_PER_POINTER define
somewhere. Other than that it looks good to me, but I cannot approve.
-Andi
Hello!
2013-05-05 Uros Bizjak
* config/i386/sse.md (*vec_extract_0): Merge
from sse2_stored and *sse2_storeq_rex64 using SWI48 mode iterator.
Add m->r,x alternatives.
(*vec_extract_0 splitters): Merge V2DI and V4SI
splitters using SWI48x mode iterator.
(*vec_extract_v2d
libcaf produces warnings because it defines functions without
prototypes. This patch adds prototypes.
Bootstrapped on powerpc-ibm-aix7.1.0.0.
Thanks, David
* libcaf.h (_gfortran_caf_critical): Add a prototype.
(_gfortran_caf_end_critical): Same.
Index: libcaf.h
=
On 05/05/2013 05:47 AM, Steve Kargl wrote:
> On Sat, May 04, 2013 at 10:25:19PM -0700, Jerry DeLisle wrote:
>> On 05/04/2013 06:30 PM, Steve Kargl wrote:
>>> On Sat, May 04, 2013 at 05:13:51PM -0700, Jerry DeLisle wrote:
CASE_SEPARATORS:/* Not a repeat count. */
case
On Sun, May 5, 2013 at 8:25 AM, Jerry DeLisle wrote:
> I don't see much point in issuing a warning if we accept it. I can just as
> easily make it an error with something like "A value separator is required
> before a namelist comment" and be done with trying to second guess whether
> someone is
This patch changes the setting of the extent field. TS29113 requires
that extent is >= 0; before we used ubound directly, i.e. extent =
ubound - lbound+1. Thus, the extent could become negative. Actually,
TS29113 also permits negative extents: For assumed-size arrays.
Now since the extent is c
David Edelsohn wrote:
libcaf produces warnings because it defines functions without
prototypes. This patch adds prototypes.
Bootstrapped on powerpc-ibm-aix7.1.0.0.
OK - given that the removal of _gfortran_caf_critical takes longer than
expected, it makes sense to add a prototype to silence t
On Sun, 5 May 2013, David Edelsohn wrote:
> The -mcall-* options are more about PPC eABI.
Where the options are about changing the function-calling ABI, I don't
think they cause problems. It's the way the options make spec handling
different from other architectures that's problematic, and the
When creating a phi-adjustment along an incoming edge, where the related
argument should use the "hidden basis" directly, I created a situation
where we double-count the subsequent adjustment based on the candidate's
index. The candidate's index shouldn't be taken into account at all for
the edge
On 14-Apr-13, at 7:37 AM, Steven Bosscher wrote:
On Tue, Apr 9, 2013 at 3:46 AM, John David Anglin wrote:
Seems to cause a reload problem:
Problem may be in not removing the continuation character "\" from
various
macro definitions.
Right, ASM_OUTPUT_ADDR_VEC_ELT and ASM_OUTPUT_ADDR_DIFF_E
On Sun, May 5, 2013 at 10:50 PM, John David Anglin wrote:
> Committed the attached version after testing on hppa2.0w-hp-hpux11.11 and
> hppa64-hp-hpux11.11.
Thanks for working on this!
Ciao!
Steven
Hi,
Some of the SH div0s integer sign comparison cases stopped working. The
attached patch fixes that.
Tested on rev 198595 with
make -k check RUNTESTFLAGS="--target_board=sh-sim
\{-m2/-ml,-m2/-mb,-m2a/-mb,-m4/-ml,-m4/-mb,-m4a/-ml,-m4a/-mb}"
and no new failures.
OK?
Cheers,
Oleg
gcc/ChangeLog
Oleg Endo wrote:
> Some of the SH div0s integer sign comparison cases stopped working. The
> attached patch fixes that.
>
> Tested on rev 198595 with
> make -k check RUNTESTFLAGS="--target_board=sh-sim
> \{-m2/-ml,-m2/-mb,-m2a/-mb,-m4/-ml,-m4/-mb,-m4a/-ml,-m4a/-mb}"
>
> and no new failures.
> O
Thomas Schwinge writes:
>> libgcc/
>> * fp-bit.c (unpack_d, pack_d): Properly preserve and restore a
>> NaN's payload.
>> * fp-bit.h [FLOAT] (QUIET_NAN): Correct value.
This is OK.
Thanks.
Ian
On Sat, May 4, 2013 at 1:41 PM, David Edelsohn wrote:
> 2013-05-04 David Edelsohn
> Peter Bergner
> Segher Boessenkool
> Jakub Jelinek
This is OK (the actual ChangeLog entry was omitted).
Thanks.
Ian
On Sun, May 05, 2013 at 04:09:30PM +0930, Alan Modra wrote:
> * config/rs6000/sysv4.h (ENDIAN_SELECT): Define, extracted from
> (ASM_SPEC): ..here. Emit DEFAULT_ASM_ENDIAN too.
> (DEFAULT_ASM_ENDIAN): Define.
> (CC1_SPEC, LINK_TARGET_SPEC): Use ENDIAN_SELECT.
> * conf
> +2013-05-03 David Malcolm
> +
> + * gengtype-state.c: (indent_amount): New variable,
> + (had_recent_newline): likewise
> + (write_new_line): New function
> + (write_any_indent): likewise
> + (write_open_paren): likewise
> + (write_close_paren): likewise
> +
I'd really like to see this in, so that powerpc doesn't silently
generate wrong code. Bootstrapped and regression tested
powerpc64-linux, with Jakub's java fixes applied.
* varasm.c (output_object_block): Use .org for each item in
section anchor block rather than padding.
Index:
32 matches
Mail list logo