On 12/04/2015 06:15 PM, Dominik Vogt wrote:
> Version 5 with the latest requested changes. Seems to work now.
> I've dropped the extra patch and rather marked the failing tests
> as "xfail".
>
> Ciao
>
> Dominik ^_^ ^_^
>
Patch applied with minor changes:
> + ; Convert Pmode to BLKmode
> +
ChangeLog
* gcc.target/s390/md/setmem_long-1.c: New test.
>From 74780dc2756ed1c2052f0d6b836799dcad1217e7 Mon Sep 17 00:00:00 2001
From: Dominik Vogt
Date: Wed, 4 Nov 2015 03:16:24 +0100
Subject: [PATCH] S/390: Fix warnings in "*setmem_long..." patterns.
---
gcc/
On 12/02/2015 02:11 PM, Andreas Krebbel wrote:
> On 12/02/2015 01:51 PM, Ulrich Weigand wrote:
>> Andreas Krebbel wrote:
>>> On 12/02/2015 11:12 AM, Dominik Vogt wrote:
Hopefully, this is correct now; it does pass the functional test case
that's part of the patch. Unfortunately the defin
On 12/02/2015 01:51 PM, Ulrich Weigand wrote:
> Andreas Krebbel wrote:
>> On 12/02/2015 11:12 AM, Dominik Vogt wrote:
>>> Hopefully, this is correct now; it does pass the functional test case
>>> that's part of the patch. Unfortunately the define_insn patters
>>> had to be duplicated because of th
Andreas Krebbel wrote:
> On 12/02/2015 11:12 AM, Dominik Vogt wrote:
> > Hopefully, this is correct now; it does pass the functional test case
> > that's part of the patch. Unfortunately the define_insn patters
> > had to be duplicated because of the new subreg offsets.
>
> The number of patter
On 12/02/2015 11:12 AM, Dominik Vogt wrote:
> Hopefully, this is correct now; it does pass the functional test case
> that's part of the patch. Unfortunately the define_insn patters
> had to be duplicated because of the new subreg offsets.
The number of patterns could possibly be reduced using
c.target/s390/md/setmem_long-1.c: New test.
>From 922d200afbe8493e62b0ffb300fbac11356469c8 Mon Sep 17 00:00:00 2001
From: Dominik Vogt
Date: Wed, 4 Nov 2015 03:16:24 +0100
Subject: [PATCH 1/1.5] S/390: Fix warnings in "*setmem_long..." patterns.
---
gcc/config/s390/s390.c
On Tue, Dec 01, 2015 at 10:59:54AM +0100, Dominik Vogt wrote:
> @@ -3336,11 +3342,12 @@
> (set_attr "type" "vs")])
>
> (define_insn "*setmem_long_31z"
> - [(clobber (match_operand:TI 0 "register_operand" "=d"))
> - (set (mem:BLK (subreg:SI (match_operand:TI 3 "register_operand" "0") 4))
>
* config/s390/s390.c (s390_expand_setmem): Use new expanders.
* config/s390/s390.md ("*setmem_long")
("*setmem_long_and", "*setmem_long_31z"): Fix warnings.
("setmem_long_"): New expanders.
("setmem_long"): Remove
On 11/30/2015 06:11 PM, Ulrich Weigand wrote:
...
> However, I agree that UNSPEC_P_TO_BLK really should also get the length
> as input, to make it have precisely defined semantics. Also, I'd rather
> use a more descriptive name, like UNSPEC_REPLICATE_BYTE or the like.
>
> What would you think abo
Andreas Krebbel wrote:
> On 11/30/2015 04:11 PM, Dominik Vogt wrote:
> > The attached patch fixes some warnings generated by the setmem...
> > patterns in s390.md during build and add test cases for the
> > patterns. The patch is to be added on to p of the movstr patch:
> > https://gcc.gnu.org/ml/
On 11/30/2015 04:11 PM, Dominik Vogt wrote:
> The attached patch fixes some warnings generated by the setmem...
> patterns in s390.md during build and add test cases for the
> patterns. The patch is to be added on to p of the movstr patch:
> https://gcc.gnu.org/ml/gcc-patches/2015-11/msg03485.html
03f6b Mon Sep 17 00:00:00 2001
From: Dominik Vogt
Date: Wed, 4 Nov 2015 03:16:24 +0100
Subject: [PATCH 1/1.5] S/390: Fix warnings in "*setmem_long..." patterns.
---
gcc/config/s390/s390.c | 7 ++-
gcc/config/s390/s390.md | 18
13 matches
Mail list logo