>
> 2014-12-08 Martin Liska
>
> * lto-partition.c (add_symbol_to_partition_1): New inline_summary_d
> is used.
> (undo_partition): Likewise.
> (lto_balanced_map): Likewise.
>
> gcc/ChangeLog:
>
> 2014-12-08 Martin Liska
>
> * cgraphunit.c (symbol_table::proc
On 11/14/2014 04:24 PM, Martin Liška wrote:
On 11/14/2014 03:09 PM, Martin Liška wrote:
On 11/13/2014 05:04 PM, Jan Hubicka wrote:
+ if (!inline_summary_summary)
+inline_summary_summary = (inline_summary_cgraph_summary *)
inline_summary_cgraph_summary::create_ggc (symtab);
Hehe, this is
On 11/18/2014 11:25 PM, Martin Jambor wrote:
On Tue, Nov 18, 2014 at 07:59:26PM +0100, Jan Hubicka wrote:
Hi,
On Tue, Nov 18, 2014 at 04:39:00PM +0100, Jan Hubicka wrote:
On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
b) with GTY, we cannot call destructor
Everything in symb
On Tue, Nov 18, 2014 at 07:59:26PM +0100, Jan Hubicka wrote:
> > Hi,
> >
> > On Tue, Nov 18, 2014 at 04:39:00PM +0100, Jan Hubicka wrote:
> > > > On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > > > > > >
> > > > > > > > b) with GTY, we cannot call destructor
> > > > > > >
> > >
On Tue, Nov 18, 2014 at 07:59:26PM +0100, Jan Hubicka wrote:
> > Hi,
> >
> > On Tue, Nov 18, 2014 at 04:39:00PM +0100, Jan Hubicka wrote:
> > > > On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > > > > > >
> > > > > > > > b) with GTY, we cannot call destructor
> > > > > > >
> > >
> Hi,
>
> On Tue, Nov 18, 2014 at 04:39:00PM +0100, Jan Hubicka wrote:
> > > On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > > > > >
> > > > > > > b) with GTY, we cannot call destructor
> > > > > >
> > > > > > Everything in symbol table is expecitely memory managed (i.e. enver
Hi,
On Tue, Nov 18, 2014 at 04:39:00PM +0100, Jan Hubicka wrote:
> > On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > > > >
> > > > > > b) with GTY, we cannot call destructor
> > > > >
> > > > > Everything in symbol table is expecitely memory managed (i.e. enver
> > > > > left
>
> On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > > >
> > > > > b) with GTY, we cannot call destructor
> > > >
> > > > Everything in symbol table is expecitely memory managed (i.e. enver left
> > > > to be freed by garbage collector). It resists in GTY only to allow
> > > > link
On Fri, Nov 14, 2014 at 08:59:10PM +0100, Jan Hubicka wrote:
> > >
> > > > b) with GTY, we cannot call destructor
> > >
> > > Everything in symbol table is expecitely memory managed (i.e. enver left
> > > to be freed by garbage collector). It resists in GTY only to allow linking
> > > garbage col
On 11/14/2014 05:06 PM, Jan Hubicka wrote:
In a way I would like to see these to be methods of the underlying type rather
than
virtual methods of the summary, becuase these are operations on the data
themselves.
I was thinking to model these by specual constructor and copy constructor
(taking
> > I would say that main advantage (in addition to have a way to provide
> > resonable
> > defaults) is to make ctors/dtors of the embedded classes working well, so
> > one can
> > for example embedd pointer_map and not care about its
> > construction/destruction.
>
> It was actually me who su
On Fri, Nov 14, 2014 at 05:06:44PM +0100, Jan Hubicka wrote:
> > >
> > >In a way I would like to see these to be methods of the underlying type
> > >rather than
> > >virtual methods of the summary, becuase these are operations on the data
> > >themselves.
> > >I was thinking to model these by spe
> >
> >In a way I would like to see these to be methods of the underlying type
> >rather than
> >virtual methods of the summary, becuase these are operations on the data
> >themselves.
> >I was thinking to model these by specual constructor and copy constructor
> >(taking the extra node pointer p
On 11/14/2014 03:09 PM, Martin Liška wrote:
On 11/13/2014 05:04 PM, Jan Hubicka wrote:
+ if (!inline_summary_summary)
+inline_summary_summary = (inline_summary_cgraph_summary *)
inline_summary_cgraph_summary::create_ggc (symtab);
Hehe, this is funny naming scheme.
Peraps inline_summary_d
On 11/13/2014 05:04 PM, Jan Hubicka wrote:
+ if (!inline_summary_summary)
+inline_summary_summary = (inline_summary_cgraph_summary *)
inline_summary_cgraph_summary::create_ggc (symtab);
Hehe, this is funny naming scheme.
Peraps inline_summary_d and inline_summary_t for the data and type?
> + if (!inline_summary_summary)
> +inline_summary_summary = (inline_summary_cgraph_summary *)
> inline_summary_cgraph_summary::create_ggc (symtab);
Hehe, this is funny naming scheme.
Peraps inline_summary_d and inline_summary_t for the data and type?
> -
> -static void
> -inline_node_duplic
16 matches
Mail list logo