On Sat, May 4, 2013 at 1:41 PM, David Edelsohn wrote:
> 2013-05-04 David Edelsohn
> Peter Bergner
> Segher Boessenkool
> Jakub Jelinek
This is OK (the actual ChangeLog entry was omitted).
Thanks.
Ian
> + a += v >> (sizeof (intptr_t) * CHAR_BIT / 2);
> + b += v & (((intptr_t) 1 << (sizeof (intptr_t) * CHAR_BIT / 2)) - 1);
It would be far easier to read if you added a BITS_PER_POINTER define
somewhere. Other than that it looks good to me, but I cannot approve.
-Andi
The revised version of hash_pointer() produces warnings when compiled
on a 32 bit host because it shift a 32 bit variable by 32 bits.
+ intptr_t v = (intptr_t)p;
...
+ b += v & 0x;
The code is not executed when intptr_t is 32 bits, but it still is
present in the function, causing a
On Fri, Apr 19, 2013 at 2:31 PM, Andi Kleen wrote:
> From: Andi Kleen
>
> 2013-04-18 Andi Kleen
>
> * hashtab.c (hash_pointer): Move to end of file and reimplement.
> +/* Returns a hash code for pointer P. Simplified version of evahash */
> +
> +static hashval_t
> +hash_pointer (cons