Re: [PATCH] recog: Use parameter packs for operator()

2020-06-23 Thread Gerald Pfeifer
On Mon, 22 Jun 2020, Richard Sandiford wrote: > OK, I've applied the below as (hopefully) obvious after testing > on aarch64-linux-gnu. > >> I filed https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95805 and included >> the relevant part of the build log. > > But I forgot about the PR, sorry, so didn

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-22 Thread Richard Sandiford
Gerald Pfeifer writes: > On Thu, 18 Jun 2020, Sebastian Huber wrote: >> b952c2cfcd74c284970e1b9bf1fca58f5f69ab23 on 10th of June. I build GCC >> roughly once per week. > > I have daily builds running on i386-unknown-freebsd11.3 (since this is > the flavor most likely to trigger issues) and the fa

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-21 Thread Gerald Pfeifer
On Thu, 18 Jun 2020, Sebastian Huber wrote: > b952c2cfcd74c284970e1b9bf1fca58f5f69ab23 on 10th of June. I build GCC > roughly once per week. I have daily builds running on i386-unknown-freebsd11.3 (since this is the flavor most likely to trigger issues) and the failure started in the 24 hours le

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-18 Thread Jonathan Wakely via Gcc-patches
On 18/06/20 10:02 +0100, Jonathan Wakely wrote: On 18/06/20 08:55 +0100, Richard Sandiford wrote: Sebastian Huber writes: On 18/06/2020 09:09, Richard Sandiford wrote: Sebastian Huber writes: On 16/06/2020 12:42, Richard Sandiford wrote: [...] 2020-06-16 Richard Sandiford gcc/

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-18 Thread Jonathan Wakely via Gcc-patches
On 18/06/20 08:55 +0100, Richard Sandiford wrote: Sebastian Huber writes: On 18/06/2020 09:09, Richard Sandiford wrote: Sebastian Huber writes: On 16/06/2020 12:42, Richard Sandiford wrote: [...] 2020-06-16 Richard Sandiford gcc/ * coretypes.h (first_type): New alias template.

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-18 Thread Richard Sandiford
Sebastian Huber writes: > On 18/06/2020 09:09, Richard Sandiford wrote: > >> Sebastian Huber writes: >>> On 16/06/2020 12:42, Richard Sandiford wrote: >>> [...] 2020-06-16 Richard Sandiford gcc/ * coretypes.h (first_type): New alias template. * recog.h (insn

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-18 Thread Sebastian Huber
On 18/06/2020 09:09, Richard Sandiford wrote: Sebastian Huber writes: On 16/06/2020 12:42, Richard Sandiford wrote: [...] 2020-06-16 Richard Sandiford gcc/ * coretypes.h (first_type): New alias template. * recog.h (insn_gen_fn::operator()): Use it instead of a decltype.

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-18 Thread Richard Sandiford
Sebastian Huber writes: > On 16/06/2020 12:42, Richard Sandiford wrote: > >> [...] >> 2020-06-16 Richard Sandiford >> >> gcc/ >> * coretypes.h (first_type): New alias template. >> * recog.h (insn_gen_fn::operator()): Use it instead of a decltype. >> Remove spurious “...” and spli

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-17 Thread Sebastian Huber
On 16/06/2020 12:42, Richard Sandiford wrote: [...] 2020-06-16 Richard Sandiford gcc/ * coretypes.h (first_type): New alias template. * recog.h (insn_gen_fn::operator()): Use it instead of a decltype. Remove spurious “...” and split the function type out into a typede

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-16 Thread Jonathan Wakely via Gcc-patches
On 16/06/20 11:42 +0100, Richard Sandiford wrote: Jonathan Wakely writes: + template + rtx_insn *operator() (Ts... args...) const Why is this declared as a variadic template **and** a varargs function? I think the second ellipsis is wrong, it should be just: + template + rtx_insn *operat

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-16 Thread Richard Sandiford
Jonathan Wakely writes: > + template > + rtx_insn *operator() (Ts... args...) const > > Why is this declared as a variadic template **and** a varargs function? > > I think the second ellipsis is wrong, it should be just: > > + template > + rtx_insn *operator() (Ts... args) const Oops, yes. >

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-15 Thread Jonathan Wakely via Gcc-patches
+ template + rtx_insn *operator() (Ts... args...) const Why is this declared as a variadic template **and** a varargs function? I think the second ellipsis is wrong, it should be just: + template + rtx_insn *operator() (Ts... args) const And this seems like a more direct way to say "a list

Re: [PATCH] recog: Use parameter packs for operator()

2020-06-09 Thread Jeff Law via Gcc-patches
On Tue, 2020-06-02 at 15:00 +0100, Richard Sandiford wrote: > This patch uses parameter packs to define insn_gen_fn::operator(). > I guess in some ways it's C++-ification for its own sake, but it does > make things simpler and removes the current artificial limit of 16 > arguments. > > Note that t