Re: [PATCH] DWARF5 .debug_rnglists support

2016-11-01 Thread Jakub Jelinek
On Tue, Nov 01, 2016 at 09:44:27PM +0100, Rainer Orth wrote: > this patch broke Solaris bootstrap with /bin/as: > > /vol/gcc/src/hg/trunk/local/gcc/dwarf2out.c: In function 'void > output_rnglists()': > /vol/gcc/src/hg/trunk/local/gcc/dwarf2out.c:11055:8: error: unused variable > 'basebuf' [-Wer

Re: [PATCH] DWARF5 .debug_rnglists support

2016-11-01 Thread Rainer Orth
Hi Jakub, > 2016-11-01 Jakub Jelinek > > * tree.h (BLOCK_IN_COLD_SECTION_P): Define. > * final.c (final_scan_insn): Set BLOCK_IN_COLD_SECTION_P. > * dwarf2out.c (rnglist_idx): New variable. > (struct dw_ranges): Add label, idx and maybe_new_sec fields. > (DEBUG_RNG

Re: [PATCH] DWARF5 .debug_rnglists support

2016-11-01 Thread Jason Merrill
On Tue, Nov 1, 2016 at 12:14 PM, Jakub Jelinek wrote: > On Mon, Oct 31, 2016 at 05:03:12PM -0400, Jason Merrill wrote: >> > Ok. Another option would be to call value_format in size_of_die >> > in this case and put the comment into value_format. >> >> That works, too. > > Done. >> >> >> In general

Re: [PATCH] DWARF5 .debug_rnglists support

2016-11-01 Thread Jakub Jelinek
On Mon, Oct 31, 2016 at 05:03:12PM -0400, Jason Merrill wrote: > > Ok. Another option would be to call value_format in size_of_die > > in this case and put the comment into value_format. > > That works, too. Done. > > >> In general there's a lot of code duplication between the existing ranges >

Re: [PATCH] DWARF5 .debug_rnglists support

2016-10-31 Thread Jason Merrill
On Mon, Oct 31, 2016 at 3:33 PM, Jakub Jelinek wrote: > On Mon, Oct 31, 2016 at 02:42:15PM -0400, Jason Merrill wrote: >> On 10/20/2016 02:52 PM, Jakub Jelinek wrote: >> >@@ -8476,7 +8498,16 @@ size_of_die (dw_die_ref die) >> > size += DWARF_OFFSET_SIZE; >> > break; >> > case

Re: [PATCH] DWARF5 .debug_rnglists support

2016-10-31 Thread Jakub Jelinek
On Mon, Oct 31, 2016 at 02:42:15PM -0400, Jason Merrill wrote: > On 10/20/2016 02:52 PM, Jakub Jelinek wrote: > >@@ -8476,7 +8498,16 @@ size_of_die (dw_die_ref die) > > size += DWARF_OFFSET_SIZE; > > break; > > case dw_val_class_range_list: > >- size += DWARF_OFFSET_S

Re: [PATCH] DWARF5 .debug_rnglists support

2016-10-31 Thread Jason Merrill
On 10/20/2016 02:52 PM, Jakub Jelinek wrote: @@ -8476,7 +8498,16 @@ size_of_die (dw_die_ref die) size += DWARF_OFFSET_SIZE; break; case dw_val_class_range_list: - size += DWARF_OFFSET_SIZE; + if (dwarf_split_debug_info + && dwarf_version