On Wed, 23 Oct 2013, Richard Sandiford wrote:
> Mike Stump writes:
> > On Oct 23, 2013, at 5:00 AM, Richard Sandiford
> > wrote:
> >> offset_int, max_int, wi::to_offset and wi::to_max sound OK to me.
> >> Kenny? Mike?
> >
> > Those two names seem reasonable. to_offset should document that thes
Mike Stump writes:
> On Oct 23, 2013, at 5:00 AM, Richard Sandiford
> wrote:
>> offset_int, max_int, wi::to_offset and wi::to_max sound OK to me.
>> Kenny? Mike?
>
> Those two names seem reasonable. to_offset should document that these
> are for address offsets (and address constants) exclusive
On Oct 23, 2013, at 5:00 AM, Richard Sandiford
wrote:
> offset_int, max_int, wi::to_offset and wi::to_max sound OK to me.
> Kenny? Mike?
Those two names seem reasonable. to_offset should document that these are for
address offsets (and address constants) exclusively.
On Oct 23, 2013, at 2:09 AM, Richard Biener wrote:
> Good. Better names - ah well, wi::to_max_wide_int (t) and
> wi::to_addr_wide_int (t)? Btw, "addr_wide_int" is an odd name
The idea was to have one type to rule them all… everything address related...
bit offsets, byte offsets… Bit offset
On 10/23/2013 08:13 AM, Richard Biener wrote:
On Wed, 23 Oct 2013, Richard Sandiford wrote:
Richard Biener writes:
The patch does that by adding:
wi::address (t)
for when we want to extend tree t to addr_wide_int precision and:
wi::extend (t)
for when we want to extend it to max_wid
On Wed, 23 Oct 2013, Richard Sandiford wrote:
> Richard Biener writes:
> >> The patch does that by adding:
> >>
> >> wi::address (t)
> >>
> >> for when we want to extend tree t to addr_wide_int precision and:
> >>
> >> wi::extend (t)
> >>
> >> for when we want to extend it to max_wide_int
Richard Biener writes:
>> The patch does that by adding:
>>
>> wi::address (t)
>>
>> for when we want to extend tree t to addr_wide_int precision and:
>>
>> wi::extend (t)
>>
>> for when we want to extend it to max_wide_int precision. (Better names
>> welcome.) These act just like addr_w