On 09/15/2011 02:06 PM, Andrew MacLeod wrote:
>> Please don't embed = inside IF conditions.
>>
> sure, i just figured the extra parenthesis covered that.
It covers the -Wall warning, but I still find it significantly
harder to read. And in this case all it does is make the IF
line too long.
r~
On 09/15/2011 05:02 PM, Richard Henderson wrote:
! /* Initialize the fields for each supported opcode. */
! static struct op_functions add_op = { sync_mem_fetch_add_optab,
! sync_mem_add_fetch_optab,
! sync_mem_add_optab,
!
> ! /* Initialize the fields for each supported opcode. */
> ! static struct op_functions add_op = { sync_mem_fetch_add_optab,
> ! sync_mem_add_fetch_optab,
> ! sync_mem_add_optab,
> ! sync_old_ad