Re: [RFC] HOST_WIDE_INT transition steps

2014-05-22 Thread Richard Sandiford
"Joseph S. Myers" writes: > On Tue, 20 May 2014, Eric Botcazou wrote: >> > Make the code base easier to understand for newcomers. It's also a >> > documentation improvement (you see what a HOST_WIDE_INT really is), >> > alongside with [u]int64_t being less to type ... >> >> I personally find the

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Joseph S. Myers
On Tue, 20 May 2014, Eric Botcazou wrote: > > Make the code base easier to understand for newcomers. It's also a > > documentation improvement (you see what a HOST_WIDE_INT really is), > > alongside with [u]int64_t being less to type ... > > I personally find the abstraction and the separation w

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Richard Biener
On Tue, 20 May 2014, Eric Botcazou wrote: > > Same as for going C++. > > Not to the same extent, this will be worse because done en masse throughout > the code instead of gradually. Like the gimple -> gimple * change pending or the various gimple -> gswitch,glabel,etc. stuff? It's on a similar

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Eric Botcazou
> Same as for going C++. Not to the same extent, this will be worse because done en masse throughout the code instead of gradually. > Make the code base easier to understand for newcomers. It's also a > documentation improvement (you see what a HOST_WIDE_INT really is), > alongside with [u]int6

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Richard Biener
On Tue, 20 May 2014, Eric Botcazou wrote: > > The following is my current idea on progressing on the HOST_WIDE_INT > > removal > > > > 1) https://gcc.gnu.org/ml/gcc-patches/2014-05/msg00381.html (ping) > > > > 2) make sure [u]int64_t is available and use that to define HOST_WIDE_INT > > > > 3)

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Eric Botcazou
> The following is my current idea on progressing on the HOST_WIDE_INT > removal > > 1) https://gcc.gnu.org/ml/gcc-patches/2014-05/msg00381.html (ping) > > 2) make sure [u]int64_t is available and use that to define HOST_WIDE_INT > > 3) s/HOST_WIDE_INT/int64_t/ (same for unsigned HOST_WIDE_INT)

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-20 Thread Mikael Pettersson
Richard Biener writes: > > The following is my current idea on progressing on the HOST_WIDE_INT > removal ... > And HOST_WIDEST_FAST_INT for which > I don't have a very good suggestion other than either keeping > it, unconditionally using 'long' (thus simply remove > use_long_long_for_wides

Re: [RFC] HOST_WIDE_INT transition steps

2014-05-19 Thread Richard Sandiford
Richard Biener writes: > The following is my current idea on progressing on the HOST_WIDE_INT > removal > > 1) https://gcc.gnu.org/ml/gcc-patches/2014-05/msg00381.html (ping) > > 2) make sure [u]int64_t is available and use that to define HOST_WIDE_INT > > 3) s/HOST_WIDE_INT/int64_t/ (same for uns

[RFC] HOST_WIDE_INT transition steps

2014-05-19 Thread Richard Biener
The following is my current idea on progressing on the HOST_WIDE_INT removal 1) https://gcc.gnu.org/ml/gcc-patches/2014-05/msg00381.html (ping) 2) make sure [u]int64_t is available and use that to define HOST_WIDE_INT 3) s/HOST_WIDE_INT/int64_t/ (same for unsigned HOST_WIDE_INT) Leaves us with