On 9/15/21 15:08, Martin Liška wrote:
Hello.
I noticed the change likely caused the following failure when building
x86_64-linux-gnu cross compiler:
g++ -fno-PIE -c -DIN_GCC_FRONTEND -DIN_GCC_FRONTEND -g -DIN_GCC
-DCROSS_DIRECTORY_STRUCTURE -fno-exceptions -fno-rtti
-fasynchronous-unwi
Hello.
I noticed the change likely caused the following failure when building
x86_64-linux-gnu cross compiler:
g++ -fno-PIE -c -DIN_GCC_FRONTEND -DIN_GCC_FRONTEND -g -DIN_GCC
-DCROSS_DIRECTORY_STRUCTURE -fno-exceptions -fno-rtti
-fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwri
On 8/30/2021 12:52 AM, Xi Ruoyao via Gcc-patches wrote:
These two patches look good to me. Still, need a maintainer's approval.
Consider them approved.
Thanks,
Jeff
These two patches look good to me. Still, need a maintainer's approval.
On Sun, 2021-08-29 at 22:59 -0400, YunQiang Su wrote:
> Currently mips-cpu.defs, mips.h, netbsd.h and config.gcc are
> using hardcoded numbers for isa level.
>
> Let's replace them with more readable enum mips_isa.
>
> gcc/
Currently mips-cpu.defs, mips.h, netbsd.h and config.gcc are
using hardcoded numbers for isa level.
Let's replace them with more readable enum mips_isa.
gcc/ChangeLog:
* config/mips/mips.h (struct mips_cpu_info): define enum mips_isa;
use enum instead of int for 'isa' member.