Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-18 Thread Andrew MacLeod via Gcc-patches
On 8/18/20 12:38 PM, Aldy Hernandez wrote: And here's the patch without the sanity check. Aldy That diff was difficult to read.. I had to apply the patch to really follow it :-P Anyway, yeah, this looks better.  effectively, you have   1) left the input range "vr" range merging in adjust-ra

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-18 Thread Aldy Hernandez via Gcc-patches
And here's the patch without the sanity check. Aldy diff --git a/gcc/vr-values.c b/gcc/vr-values.c index fe51a6faeb8..9b21441dff3 100644 --- a/gcc/vr-values.c +++ b/gcc/vr-values.c @@ -1006,7 +1006,7 @@ vr_values::extract_range_from_comparison (value_range_equiv *vr, overflow. */ static b

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-18 Thread Aldy Hernandez via Gcc-patches
On 8/17/20 5:59 PM, Andrew MacLeod wrote: On 8/17/20 6:04 AM, Aldy Hernandez wrote: On 8/14/20 7:16 PM, Andrew MacLeod wrote: On 8/14/20 12:05 PM, Aldy Hernandez wrote: I made some minor changes to the function comments. gcc/ChangeLog: * vr-values.c (check_for_binary_op_overflow): Ch

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-17 Thread Andrew MacLeod via Gcc-patches
On 8/17/20 6:04 AM, Aldy Hernandez wrote: On 8/14/20 7:16 PM, Andrew MacLeod wrote: On 8/14/20 12:05 PM, Aldy Hernandez wrote: I made some minor changes to the function comments. gcc/ChangeLog: * vr-values.c (check_for_binary_op_overflow): Change type of store to range_query. (v

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-17 Thread Aldy Hernandez via Gcc-patches
On 8/14/20 7:16 PM, Andrew MacLeod wrote: On 8/14/20 12:05 PM, Aldy Hernandez wrote: I made some minor changes to the function comments. gcc/ChangeLog: * vr-values.c (check_for_binary_op_overflow): Change type of store to range_query. (vr_values::adjust_range_with_scev): Abstract

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-14 Thread Andrew MacLeod via Gcc-patches
On 8/14/20 12:05 PM, Aldy Hernandez wrote: I made some minor changes to the function comments. gcc/ChangeLog: * vr-values.c (check_for_binary_op_overflow): Change type of store to range_query. (vr_values::adjust_range_with_scev): Abstract most of the code... (range_of_var_in_loo

Re: PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-14 Thread Aldy Hernandez via Gcc-patches
I made some minor changes to the function comments. gcc/ChangeLog: * vr-values.c (check_for_binary_op_overflow): Change type of store to range_query. (vr_values::adjust_range_with_scev): Abstract most of the code... (range_of_var_in_loop): ...here. Remove value_r

PING: Fwd: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-11 Thread Aldy Hernandez via Gcc-patches
-- Forwarded message - From: Aldy Hernandez Date: Tue, Aug 4, 2020, 14:03 Subject: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv. To: Cc: , Aldy Hernandez I've abstracted out the parts of the code that had nothing to do with value_range_

Re: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-04 Thread Aldy Hernandez via Gcc-patches
On Tue, Aug 4, 2020 at 3:27 PM Richard Biener wrote: > > On Tue, Aug 4, 2020 at 2:05 PM Aldy Hernandez via Gcc-patches > wrote: > > > > I've abstracted out the parts of the code that had nothing to do with > > value_range_equiv into an externally visible range_of_var_in_loop(). > > This way, it c

Re: [PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-04 Thread Richard Biener via Gcc-patches
On Tue, Aug 4, 2020 at 2:05 PM Aldy Hernandez via Gcc-patches wrote: > > I've abstracted out the parts of the code that had nothing to do with > value_range_equiv into an externally visible range_of_var_in_loop(). > This way, it can be called with any range. > > adjust_range_with_scev still works

[PATCH 2/2] Decouple adjust_range_from_scev from vr_values and value_range_equiv.

2020-08-04 Thread Aldy Hernandez via Gcc-patches
I've abstracted out the parts of the code that had nothing to do with value_range_equiv into an externally visible range_of_var_in_loop(). This way, it can be called with any range. adjust_range_with_scev still works as before, intersecting with a known range. Due to the way value_range_equiv::in