Re: [PATCH] dwarf2out: Print the name of the unspec as part of the warning

2011-03-22 Thread Richard Henderson
On 03/21/2011 03:26 AM, Andreas Krebbel wrote: > + (XINT (rtl, 1) >= 0 && XINT (rtl, 1) < NUM_UNSPEC_VALUES) > + ? unspec_strings[XINT (rtl, 1)] : "unkown", > + XINT (rtl, 1)); The parentheses ought to be enclosing the entire ternary expression for clarity. Als

[PATCH] dwarf2out: Print the name of the unspec as part of the warning

2011-03-21 Thread Andreas Krebbel
Hi, with the attached patch dwarf2out tries to print the name of the unspec together with the numeric value in case the back end uses define_c_enum for the unspec constants. Ok for mainline? Bye, -Andreas- 2011-03-21 Andreas Krebbel * dwarf2out.c (const_ok_for_output_1): Print the